summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-12-24 13:08:26 +0000
committerPacho Ramos <pacho@gentoo.org>2012-12-24 13:08:26 +0000
commitc7c048c6cb44de96c3aba1ae2cb6c86f29444e51 (patch)
tree72faa9affca96f848a98161f619d725f54a45dab /app-misc/tasque
parentadd ~arm (diff)
downloadgentoo-2-c7c048c6cb44de96c3aba1ae2cb6c86f29444e51.tar.gz
gentoo-2-c7c048c6cb44de96c3aba1ae2cb6c86f29444e51.tar.bz2
gentoo-2-c7c048c6cb44de96c3aba1ae2cb6c86f29444e51.zip
Version bump, drop old
(Portage version: 2.1.11.37/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-misc/tasque')
-rw-r--r--app-misc/tasque/ChangeLog9
-rw-r--r--app-misc/tasque/files/tasque-0.1.9-cachetasks.patch244
-rw-r--r--app-misc/tasque/tasque-0.1.12.ebuild53
-rw-r--r--app-misc/tasque/tasque-0.1.9.ebuild66
4 files changed, 60 insertions, 312 deletions
diff --git a/app-misc/tasque/ChangeLog b/app-misc/tasque/ChangeLog
index d6e3103a7cf2..f8c80cc9f15f 100644
--- a/app-misc/tasque/ChangeLog
+++ b/app-misc/tasque/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/tasque
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tasque/ChangeLog,v 1.11 2012/12/07 04:51:40 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tasque/ChangeLog,v 1.12 2012/12/24 13:08:26 pacho Exp $
+
+*tasque-0.1.12 (24 Dec 2012)
+
+ 24 Dec 2012; Pacho Ramos <pacho@gentoo.org> +tasque-0.1.12.ebuild,
+ -files/tasque-0.1.9-cachetasks.patch, -tasque-0.1.9.ebuild:
+ Version bump, drop old
07 Dec 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> tasque-0.1.11.ebuild:
x86 stable wrt bug #435202
@@ -45,4 +51,3 @@
+files/tasque-0.1.8-debug-fixup.patch, +metadata.xml,
+tasque-0.1.8.ebuild:
Add Tasque. Ebuild by Andreas Proschofsky, bugs by me :-).
-
diff --git a/app-misc/tasque/files/tasque-0.1.9-cachetasks.patch b/app-misc/tasque/files/tasque-0.1.9-cachetasks.patch
deleted file mode 100644
index 994b85749d47..000000000000
--- a/app-misc/tasque/files/tasque-0.1.9-cachetasks.patch
+++ /dev/null
@@ -1,244 +0,0 @@
-diff --git a/src/Backends/Sqlite/SqliteBackend.cs b/src/Backends/Sqlite/SqliteBackend.cs
-index 4e7ec7a..417f6b2 100644
---- a/src/Backends/Sqlite/SqliteBackend.cs
-+++ b/src/Backends/Sqlite/SqliteBackend.cs
-@@ -243,10 +243,10 @@ namespace Tasque.Backends.Sqlite
- bool hasValues = false;
-
- string command = "SELECT id FROM Categories";
-- SqliteCommand cmd = db.Connection.CreateCommand();
-- cmd.CommandText = command;
-- SqliteDataReader dataReader = cmd.ExecuteReader();
-- while(dataReader.Read()) {
-+ SqliteCommand cmd = db.Connection.CreateCommand();
-+ cmd.CommandText = command;
-+ SqliteDataReader dataReader = cmd.ExecuteReader();
-+ while(dataReader.Read()) {
- int id = dataReader.GetInt32(0);
- hasValues = true;
-
-@@ -255,10 +255,10 @@ namespace Tasque.Backends.Sqlite
- defaultCategory = newCategory;
- iter = categoryListStore.Append ();
- categoryListStore.SetValue (iter, 0, newCategory);
-- }
--
-- dataReader.Close();
-- cmd.Dispose();
-+ }
-+
-+ dataReader.Close();
-+ cmd.Dispose();
-
- if(!hasValues)
- {
-@@ -286,23 +286,32 @@ namespace Tasque.Backends.Sqlite
- Gtk.TreeIter iter;
- SqliteTask newTask;
- bool hasValues = false;
--
-- string command = "SELECT id FROM Tasks";
-- SqliteCommand cmd = db.Connection.CreateCommand();
-- cmd.CommandText = command;
-- SqliteDataReader dataReader = cmd.ExecuteReader();
-- while(dataReader.Read()) {
-- int id = dataReader.GetInt32(0);
-+
-+ string command = "SELECT id,Category,Name,DueDate,CompletionDate,Priority, State FROM Tasks";
-+ SqliteCommand cmd = db.Connection.CreateCommand();
-+ cmd.CommandText = command;
-+ SqliteDataReader dataReader = cmd.ExecuteReader();
-+ while(dataReader.Read()) {
-+ int id = dataReader.GetInt32(0);
-+ int category = dataReader.GetInt32(1);
-+ string name = dataReader.GetString(2);
-+ int dueDate = dataReader.GetInt32(3);
-+ int completionDate = dataReader.GetInt32(4);
-+ int priority = dataReader.GetInt32(5);
-+ int state = dataReader.GetInt32(6);
-+
- hasValues = true;
--
-- newTask = new SqliteTask(this, id);
-+
-+ newTask = new SqliteTask(this, id, category,
-+ name, dueDate, completionDate,
-+ priority, state);
- iter = taskStore.AppendNode();
- taskStore.SetValue (iter, 0, newTask);
- taskIters [newTask.SqliteId] = iter;
-- }
-+ }
-
-- dataReader.Close();
-- cmd.Dispose();
-+ dataReader.Close();
-+ cmd.Dispose();
-
- if(!hasValues)
- {
-diff --git a/src/Backends/Sqlite/SqliteTask.cs b/src/Backends/Sqlite/SqliteTask.cs
-index a9f5d42..9ede1b1 100644
---- a/src/Backends/Sqlite/SqliteTask.cs
-+++ b/src/Backends/Sqlite/SqliteTask.cs
-@@ -12,22 +12,41 @@ namespace Tasque.Backends.Sqlite
- {
- private SqliteBackend backend;
- private int id;
-+ private int category;
-+ private string name;
-+ private long dueDate;
-+ private long completionDate;
-+ private int priority;
-+ private int state;
-
- public SqliteTask(SqliteBackend backend, string name)
- {
- this.backend = backend;
- Logger.Debug("Creating New Task Object : {0} (id={1})", name, id);
- name = backend.SanitizeText (name);
-+ this.name = name;
-+ this.dueDate = Database.FromDateTime(DateTime.MinValue);
-+ this.completionDate = Database.FromDateTime(DateTime.MinValue);
-+ this.category = 0;
-+ this.priority = (int)(TaskPriority.None);
-+ this.state = (int)TaskState.Active;
- string command = String.Format("INSERT INTO Tasks (Name, DueDate, CompletionDate, Priority, State, Category, ExternalID) values ('{0}','{1}', '{2}','{3}', '{4}', '{5}', '{6}'); SELECT last_insert_rowid();",
-- name, Database.FromDateTime(DateTime.MinValue), Database.FromDateTime(DateTime.MinValue),
-- ((int)(TaskPriority.None)), ((int)TaskState.Active), 0, string.Empty );
-+ name, dueDate, completionDate,
-+ priority, state, category, string.Empty);
- this.id = Convert.ToInt32 (backend.Database.ExecuteScalar (command));
- }
--
-- public SqliteTask (SqliteBackend backend, int id)
-+
-+ public SqliteTask (SqliteBackend backend, int id, int category, string name,
-+ long dueDate, long completionDate, int priority, int state)
- {
- this.backend = backend;
- this.id = id;
-+ this.category = category;
-+ this.name = name;
-+ this.dueDate = dueDate;
-+ this.completionDate = completionDate;
-+ this.priority = priority;
-+ this.state = state;
- }
-
- #region Public Properties
-@@ -44,12 +63,10 @@ namespace Tasque.Backends.Sqlite
-
- public override string Name
- {
-- get {
-- string command = String.Format("SELECT Name FROM Tasks where ID='{0}'", id);
-- return backend.Database.GetSingleString(command);
-- }
-+ get { return this.name; }
- set {
- string name = backend.SanitizeText (value);
-+ this.name = name;
- string command = String.Format("UPDATE Tasks set Name='{0}' where ID='{1}'", name, id);
- backend.Database.ExecuteScalar(command);
- backend.UpdateTask(this);
-@@ -58,12 +75,10 @@ namespace Tasque.Backends.Sqlite
-
- public override DateTime DueDate
- {
-- get {
-- string command = String.Format("SELECT DueDate FROM Tasks where ID='{0}'", id);
-- return backend.Database.GetDateTime(command);
-- }
-+ get { return Database.ToDateTime(this.dueDate); }
- set {
-- string command = String.Format("UPDATE Tasks set DueDate='{0}' where ID='{1}'", Database.FromDateTime(value), id);
-+ this.dueDate = Database.FromDateTime(value);
-+ string command = String.Format("UPDATE Tasks set DueDate='{0}' where ID='{1}'", this.dueDate, id);
- backend.Database.ExecuteScalar(command);
- backend.UpdateTask(this);
- }
-@@ -72,14 +87,12 @@ namespace Tasque.Backends.Sqlite
-
- public override DateTime CompletionDate
- {
-- get {
-- string command = String.Format("SELECT CompletionDate FROM Tasks where ID='{0}'", id);
-- return backend.Database.GetDateTime(command);
-- }
-+ get { return Database.ToDateTime(this.completionDate); }
- set {
-- string command = String.Format("UPDATE Tasks set CompletionDate='{0}' where ID='{1}'", Database.FromDateTime(value), id);
-+ this.completionDate = Database.FromDateTime(value);
-+ string command = String.Format("UPDATE Tasks set CompletionDate='{0}' where ID='{1}'", this.completionDate, id);
- backend.Database.ExecuteScalar(command);
-- backend.UpdateTask(this);
-+ backend.UpdateTask(this);
- }
- }
-
-@@ -96,14 +109,12 @@ namespace Tasque.Backends.Sqlite
-
- public override TaskPriority Priority
- {
-- get {
-- string command = String.Format("SELECT Priority FROM Tasks where ID='{0}'", id);
-- return (TaskPriority)backend.Database.GetSingleInt(command);
-- }
-+ get { return (TaskPriority) this.priority; }
- set {
-- string command = String.Format("UPDATE Tasks set Priority='{0}' where ID='{1}'", ((int)value), id);
-+ this.priority = (int) value;
-+ string command = String.Format("UPDATE Tasks set Priority='{0}' where ID='{1}'", this.priority, id);
- backend.Database.ExecuteScalar(command);
-- backend.UpdateTask(this);
-+ backend.UpdateTask(this);
- }
- }
-
-@@ -127,27 +138,21 @@ namespace Tasque.Backends.Sqlite
-
- public TaskState LocalState
- {
-- get {
-- string command = String.Format("SELECT State FROM Tasks where ID='{0}'", id);
-- return (TaskState)backend.Database.GetSingleInt(command);
-- }
-+ get { return (TaskState) this.state; }
- set {
-- string command = String.Format("UPDATE Tasks set State='{0}' where ID='{1}'", ((int)value), id);
-+ this.state = (int) value;
-+ string command = String.Format("UPDATE Tasks set State='{0}' where ID='{1}'", this.state, id);
- backend.Database.ExecuteScalar(command);
-- backend.UpdateTask(this);
-+ backend.UpdateTask(this);
- }
- }
-
- public override ICategory Category
- {
-- get {
-- string command = String.Format("SELECT Category FROM Tasks where ID='{0}'", id);
-- int catID = backend.Database.GetSingleInt(command);
-- SqliteCategory sqCat = new SqliteCategory(backend, catID);
-- return sqCat;
-- }
-+ get { return new SqliteCategory(backend, this.category); }
- set {
-- string command = String.Format("UPDATE Tasks set Category='{0}' where ID='{1}'", ((int)(value as SqliteCategory).ID), id);
-+ this.category = (int)(value as SqliteCategory).ID;
-+ string command = String.Format("UPDATE Tasks set Category='{0}' where ID='{1}'", category, id);
- backend.Database.ExecuteScalar(command);
- backend.UpdateTask(this);
- }
-@@ -166,7 +171,7 @@ namespace Tasque.Backends.Sqlite
- int taskId = dataReader.GetInt32(0);
- string text = dataReader.GetString(1);
- notes.Add (new SqliteNote (taskId, text));
-- }
-+ }
-
- return notes;
- }
---
-cgit v0.9.0.2
diff --git a/app-misc/tasque/tasque-0.1.12.ebuild b/app-misc/tasque/tasque-0.1.12.ebuild
new file mode 100644
index 000000000000..fe4ed79648ce
--- /dev/null
+++ b/app-misc/tasque/tasque-0.1.12.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tasque/tasque-0.1.12.ebuild,v 1.1 2012/12/24 13:08:26 pacho Exp $
+
+EAPI=5
+inherit eutils gnome.org mono
+
+DESCRIPTION="Simple task management app (TODO list) for the Linux Desktop"
+HOMEPAGE="https://live.gnome.org/Tasque"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+rememberthemilk +sqlite hiveminder debug"
+
+LANGS="ca ca@valencia cs da de el en_GB eo es et fi fr gl hu id it ja lv nb nds nl pl
+ pt pt_BR ro ru sl sr sr@latin sv th tr zh_CN zh_TW"
+
+for lang in ${LANGS}; do
+ IUSE+=" linguas_${lang}"
+done
+
+REQUIRED_USE="|| ( rememberthemilk sqlite hiveminder )"
+
+RDEPEND=">=dev-dotnet/gtk-sharp-2.12.7-r5
+ >=dev-dotnet/notify-sharp-0.4.0_pre20080912
+ dev-dotnet/dbus-sharp
+ dev-dotnet/dbus-sharp-glib
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --disable-backend-icecore \
+ --disable-backend-eds \
+ --disable-appindicator \
+ --enable-backend-rtm \
+ $(use_enable sqlite backend-sqlite) \
+ $(use_enable hiveminder backend-hiveminder) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ mv_command="cp -pPR" mono_multilib_comply
+ einfo "Cleaning up locales..."
+ for lang in ${LANGS}; do
+ use "linguas_${lang}" && {
+ einfo "- keeping ${lang}"
+ continue
+ }
+ rm -Rf "${D}"/usr/share/locale/"${lang}" || die
+ done
+}
diff --git a/app-misc/tasque/tasque-0.1.9.ebuild b/app-misc/tasque/tasque-0.1.9.ebuild
deleted file mode 100644
index 8b0446bdc970..000000000000
--- a/app-misc/tasque/tasque-0.1.9.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tasque/tasque-0.1.9.ebuild,v 1.5 2012/05/29 18:50:55 suka Exp $
-
-EAPI="3"
-
-inherit eutils gnome.org mono
-
-DESCRIPTION="Tasky is a simple task management app (TODO list) for the Linux Desktop"
-HOMEPAGE="http://live.gnome.org/Tasque"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+rememberthemilk +sqlite hiveminder debug"
-
-RDEPEND=">=dev-dotnet/gtk-sharp-2.12.7-r5
- >=dev-dotnet/gnome-sharp-2.24.0
- >=dev-dotnet/notify-sharp-0.4.0_pre20080912
- >=dev-dotnet/ndesk-dbus-0.6
- >=dev-dotnet/ndesk-dbus-glib-0.4
- sqlite? ( dev-db/sqlite:3 )
- "
-
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- BACKEND=false
- for usef in sqlite hiveminder rememberthemilk
- do
- use $usef && BACKEND=true
- done
- if [[ "${BACKEND}" != "true" ]]
- then
- eerror "You must select one of the following backends by enabling their useflag:"
- eerror "sqlite ( uses a local, file-backed database to keep track of your TODO list )"
- eerror "rememberthemilk ( integrates with www.rememberthemilk.com )"
- eerror "hiveminder ( integrates with www.hiveminder.com )"
- die "Please select a backend"
- fi
-}
-
-src_prepare() {
-
- # upstream patch to increase performance, in next release
- epatch "${FILESDIR}/${P}-cachetasks.patch"
-
-}
-
-src_configure() {
- #http://bugzilla.gnome.org/show_bug.cgi?id=568910
- export GTK_DOTNET_20_LIBS=" " \
- GTK_DOTNET_20_CFLAGS=" "
- econf --disable-backend-icecore \
- --disable-backend-eds \
- --enable-backend-rtm \
- $(use_enable sqlite backend-sqlite) \
- $(use_enable hiveminder backend-hiveminder) \
- $(use_enable debug)
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "emake failed"
- dodoc NEWS TODO README AUTHORS || die "docs installation failed"
- mv_command="cp -pPR" mono_multilib_comply
-}