summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-03-13 19:59:54 +0000
committerHanno Böck <hanno@gentoo.org>2009-03-13 19:59:54 +0000
commitb4f5e0016cc9c166e663c6dec78169506b450bb2 (patch)
tree7e49892c384bb159c54ef61ef992ad70818200be /app-misc/towitoko/towitoko-2.0.7-r2.ebuild
parentVersion bump <http://my.opera.com/desktopteam/blog/2009/03/13/opera-turbo-lab... (diff)
downloadgentoo-2-b4f5e0016cc9c166e663c6dec78169506b450bb2.tar.gz
gentoo-2-b4f5e0016cc9c166e663c6dec78169506b450bb2.tar.bz2
gentoo-2-b4f5e0016cc9c166e663c6dec78169506b450bb2.zip
towitoko: don't enable devfs, this results in obsolete paths not available in current udev
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/towitoko/towitoko-2.0.7-r2.ebuild')
-rw-r--r--app-misc/towitoko/towitoko-2.0.7-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/towitoko/towitoko-2.0.7-r2.ebuild b/app-misc/towitoko/towitoko-2.0.7-r2.ebuild
new file mode 100644
index 000000000000..b4ade1b745c1
--- /dev/null
+++ b/app-misc/towitoko/towitoko-2.0.7-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/towitoko/towitoko-2.0.7-r2.ebuild,v 1.1 2009/03/13 19:59:54 hanno Exp $
+
+IUSE="static moneyplex"
+
+DESCRIPTION="This library provides a driver for using Towitoko smartcard readers under UNIX environment."
+SRC_URI="http://www.geocities.com/cprados/files/${P}.tar.gz"
+HOMEPAGE="http://www.geocities.com/cprados/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ local myconf
+
+ myconf=""
+ use moneyplex && myconf="${myconf} --disable-atr-check"
+
+ econf \
+ `use_enable static` \
+ `use_enable moneyplex win32-com` \
+ ${myconf} || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+}
+
+pkg_postinst() {
+ if ! use moneyplex
+ then
+ elog "If you want to use the moneyplex home banking software from"
+ elog "http://www.matrica.de"
+ elog "then please re-emerge this package with 'moneyplex' in USE"
+ fi
+}