summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-23 19:30:24 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-23 19:30:24 +0000
commit8fafb47a016d93202d67cf35afb2d6a835661491 (patch)
treeac3483a6787695c3b1b3b38ea7b2f9035e46c443 /app-misc/tpconfig
parentRemoved bootcd USE flag (diff)
downloadgentoo-2-8fafb47a016d93202d67cf35afb2d6a835661491.tar.gz
gentoo-2-8fafb47a016d93202d67cf35afb2d6a835661491.tar.bz2
gentoo-2-8fafb47a016d93202d67cf35afb2d6a835661491.zip
new ebuild closes 4852
Diffstat (limited to 'app-misc/tpconfig')
-rw-r--r--app-misc/tpconfig/ChangeLog9
-rw-r--r--app-misc/tpconfig/files/digest-tpconfig-3.1.31
-rw-r--r--app-misc/tpconfig/files/tpconfig22
-rw-r--r--app-misc/tpconfig/files/tpconfig.conf5
-rw-r--r--app-misc/tpconfig/tpconfig-3.1.3.ebuild27
5 files changed, 64 insertions, 0 deletions
diff --git a/app-misc/tpconfig/ChangeLog b/app-misc/tpconfig/ChangeLog
new file mode 100644
index 000000000000..315a31f501b7
--- /dev/null
+++ b/app-misc/tpconfig/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-misc/tpconfig
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tpconfig/ChangeLog,v 1.1 2002/10/23 19:30:24 lostlogic Exp $
+
+*tpconfig-3.1.3 (23 Oct 2002)
+
+ 23 Oct 2002; Brandon Low <lostlogic@gentoo.org> tpconfig-3.1.3.ebuild:
+
+ New ebuild thanks to ndecker@gmx.de, closes bug 4852.
diff --git a/app-misc/tpconfig/files/digest-tpconfig-3.1.3 b/app-misc/tpconfig/files/digest-tpconfig-3.1.3
new file mode 100644
index 000000000000..36a5feb6726c
--- /dev/null
+++ b/app-misc/tpconfig/files/digest-tpconfig-3.1.3
@@ -0,0 +1 @@
+MD5 50acfa33b3be03aac9d7131edb07373f tpconfig-3.1.3.tar.gz 106789
diff --git a/app-misc/tpconfig/files/tpconfig b/app-misc/tpconfig/files/tpconfig
new file mode 100644
index 000000000000..75946f1089bf
--- /dev/null
+++ b/app-misc/tpconfig/files/tpconfig
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ before xdm
+}
+
+start() {
+ ebegin "Loading tpconfig options..."
+ /usr/bin/tpconfig ${TPOPTIONS} > /dev/null 2> /tmp/tpconfig.start
+ if [ -z "`cat /tmp/tpconfig.start 2> /dev/null`" ]; then
+ eend 0
+ else
+ eend 1
+ fi
+}
+
+stop() {
+ ebegin "Stoping tpconfig (this does nothing)..."
+ eend 0
+}
diff --git a/app-misc/tpconfig/files/tpconfig.conf b/app-misc/tpconfig/files/tpconfig.conf
new file mode 100644
index 000000000000..6080cbb8dfdb
--- /dev/null
+++ b/app-misc/tpconfig/files/tpconfig.conf
@@ -0,0 +1,5 @@
+#!/bin/sh
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+TPOTIONS="--tapmode=0"
diff --git a/app-misc/tpconfig/tpconfig-3.1.3.ebuild b/app-misc/tpconfig/tpconfig-3.1.3.ebuild
new file mode 100644
index 000000000000..0f4a9570a9c2
--- /dev/null
+++ b/app-misc/tpconfig/tpconfig-3.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tpconfig/tpconfig-3.1.3.ebuild,v 1.1 2002/10/23 19:30:24 lostlogic Exp $
+
+IUSE=""
+
+DESCRIPTION="Touchpad config for ALPS and Synaptics TPs. Controls tap/click behaviour"
+HOMEPAGE="http://www.compass.com/synaptics/"
+LICENSE="GPL"
+DEPEND="virtual/glibc"
+SRC_URI="http://www.compass.com/${PN}/${P}.tar.gz"
+S=${WORKDIR}/${P}
+SLOT="0"
+KEYWORDS="~x86"
+
+src_compile() {
+ econf || die "Failed econf"
+ emake || die "Failed emake"
+}
+
+src_install () {
+ dobin tpconfig
+ dodoc README AUTHORS NEWS INSTALL COPYING
+ exeinto /etc/init.d ; doexe ${FILESDIR}/tpconfig
+ insinto /etc/conf.d ; newins ${FILESDIR}/tpconfig.conf tpconfig
+}
+