summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-25 19:49:51 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-25 19:49:51 +0000
commit6d2956dd866fe8601de61ae5d343ca6632eadbfe (patch)
tree780c614944bda56712f74336c14f2acd23b5eff1 /app-misc/ttyrec
parentremove old 2.x versions (diff)
downloadgentoo-2-6d2956dd866fe8601de61ae5d343ca6632eadbfe.tar.gz
gentoo-2-6d2956dd866fe8601de61ae5d343ca6632eadbfe.tar.bz2
gentoo-2-6d2956dd866fe8601de61ae5d343ca6632eadbfe.zip
Revision bump: EAPI 5, base eclass, QA fixes. Respect LDFLAGS, wrt bug #331843, patch by Olivier Huber <oli.huber AT gmail.com>
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-misc/ttyrec')
-rw-r--r--app-misc/ttyrec/ChangeLog9
-rw-r--r--app-misc/ttyrec/files/ttyrec-1.0.8-ldflags.patch19
-rw-r--r--app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild30
3 files changed, 57 insertions, 1 deletions
diff --git a/app-misc/ttyrec/ChangeLog b/app-misc/ttyrec/ChangeLog
index bfc795ed63cf..0976b7d39e4b 100644
--- a/app-misc/ttyrec/ChangeLog
+++ b/app-misc/ttyrec/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/ttyrec
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ttyrec/ChangeLog,v 1.23 2013/02/03 12:06:28 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ttyrec/ChangeLog,v 1.24 2013/02/25 19:49:50 pinkbyte Exp $
+
+*ttyrec-1.0.8-r1 (25 Feb 2013)
+
+ 25 Feb 2013; Sergey Popov <pinkbyte@gentoo.org> +ttyrec-1.0.8-r1.ebuild,
+ +files/ttyrec-1.0.8-ldflags.patch:
+ Revision bump: EAPI 5, base eclass, QA fixes. Respect LDFLAGS, wrt bug
+ #331843, patch by Olivier Huber <oli.huber AT gmail.com>
03 Feb 2013; Pacho Ramos <pacho@gentoo.org> -ttyrec-1.0.6-r1.ebuild,
metadata.xml:
diff --git a/app-misc/ttyrec/files/ttyrec-1.0.8-ldflags.patch b/app-misc/ttyrec/files/ttyrec-1.0.8-ldflags.patch
new file mode 100644
index 000000000000..5b2393ce5393
--- /dev/null
+++ b/app-misc/ttyrec/files/ttyrec-1.0.8-ldflags.patch
@@ -0,0 +1,19 @@
+--- Makefile~ 2010-08-09 14:01:24.351716328 -0400
++++ Makefile 2010-08-09 14:00:45.981716329 -0400
+@@ -10,13 +10,13 @@
+ all: $(TARGET)
+
+ ttyrec: ttyrec.o io.o
+- $(CC) $(CFLAGS) -o ttyrec ttyrec.o io.o
++ $(CC) $(LDFLAGS) $(CFLAGS) -o ttyrec ttyrec.o io.o
+
+ ttyplay: ttyplay.o io.o
+- $(CC) $(CFLAGS) -o ttyplay ttyplay.o io.o
++ $(CC) $(LDFLAGS) $(CFLAGS) -o ttyplay ttyplay.o io.o
+
+ ttytime: ttytime.o io.o
+- $(CC) $(CFLAGS) -o ttytime ttytime.o io.o
++ $(CC) $(LDFLAGS) $(CFLAGS) -o ttytime ttytime.o io.o
+
+ clean:
+ rm -f *.o $(TARGET) ttyrecord *~
diff --git a/app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild b/app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..1e6404cf797d
--- /dev/null
+++ b/app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild,v 1.1 2013/02/25 19:49:50 pinkbyte Exp $
+
+EAPI=5
+
+inherit base flag-o-matic toolchain-funcs
+
+DESCRIPTION="tty recorder"
+HOMEPAGE="http://namazu.org/~satoru/ttyrec/"
+SRC_URI="http://namazu.org/~satoru/ttyrec/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+# Bug 331843
+PATCHES=( "${FILESDIR}/${P}-ldflags.patch" )
+
+src_compile() {
+ # Bug 106530
+ append-cppflags -DSVR4 -D_XOPEN_SOURCE=500
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ttyrec ttyplay ttytime
+ dodoc README
+ doman *.1
+}