summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-06-20 23:08:34 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-06-20 23:08:34 +0000
commitf9218f4d0aaf18770ab0f8a7db365075306fb839 (patch)
tree810036fb08026314877a06eea02690fdc24013ae /app-misc/wipe
parentsome mask cleanups. clarified gnumeric/gimp masks (diff)
downloadgentoo-2-f9218f4d0aaf18770ab0f8a7db365075306fb839.tar.gz
gentoo-2-f9218f4d0aaf18770ab0f8a7db365075306fb839.tar.bz2
gentoo-2-f9218f4d0aaf18770ab0f8a7db365075306fb839.zip
fix gcc 3.2.3 breakage (bug 23165)
Diffstat (limited to 'app-misc/wipe')
-rw-r--r--app-misc/wipe/ChangeLog5
-rw-r--r--app-misc/wipe/Manifest4
-rw-r--r--app-misc/wipe/wipe-2.1.0.ebuild12
3 files changed, 16 insertions, 5 deletions
diff --git a/app-misc/wipe/ChangeLog b/app-misc/wipe/ChangeLog
index 61383d62c8ff..65e94949e7d2 100644
--- a/app-misc/wipe/ChangeLog
+++ b/app-misc/wipe/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-misc/wipe
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/ChangeLog,v 1.2 2003/02/12 05:10:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/ChangeLog,v 1.3 2003/06/20 23:08:30 msterret Exp $
+
+ 20 Jun 2003; <msterret@gentoo.org> wipe-2.1.0.ebuild:
+ fix gcc 3.2.3 breakage (bug 23165)
*wipe-2.1.0 (29 Oct 2002)
diff --git a/app-misc/wipe/Manifest b/app-misc/wipe/Manifest
index cdafddcd4119..e11f14722a22 100644
--- a/app-misc/wipe/Manifest
+++ b/app-misc/wipe/Manifest
@@ -1,3 +1,3 @@
-MD5 c9ad29ec72c774f9646ab04766dfbc40 ChangeLog 352
-MD5 cd32079ef88a5cbccf5ef11fc21d055b wipe-2.1.0.ebuild 726
+MD5 673107142d970ece728a752731b21d6b ChangeLog 448
+MD5 aed937930b51b36163d7e8b1627fd9e6 wipe-2.1.0.ebuild 902
MD5 a53f8775aa00a2b49d527fa520203136 files/digest-wipe-2.1.0 62
diff --git a/app-misc/wipe/wipe-2.1.0.ebuild b/app-misc/wipe/wipe-2.1.0.ebuild
index 804fbc304404..80ab148b4490 100644
--- a/app-misc/wipe/wipe-2.1.0.ebuild
+++ b/app-misc/wipe/wipe-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/wipe-2.1.0.ebuild,v 1.3 2003/02/13 09:12:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/wipe-2.1.0.ebuild,v 1.4 2003/06/20 23:08:30 msterret Exp $
DESCRIPTION="Secure file wiping utility based on Peter Gutman's patterns"
SRC_URI="mirror://sourceforge/wipe/${P}.tar.bz2"
@@ -10,8 +10,16 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e '28 i\#include <errno.h>' ${S}/rand.c || die "sed rand.c failed"
+}
+
src_compile() {
- econf
+ econf || die "econf failed"
emake || die "compile problem"
}