summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-02-22 09:10:20 +0000
committerTorsten Veller <tove@gentoo.org>2008-02-22 09:10:20 +0000
commitb3e9808c62e7099aa2490f3f702f762370ff0a89 (patch)
treef52890f0ea7c96fa62a3241d12be91d7f426335c /app-misc/wyrd/wyrd-1.4.4.ebuild
parentapp-emacs/cdrw removal, bug 207133 (diff)
downloadgentoo-2-b3e9808c62e7099aa2490f3f702f762370ff0a89.tar.gz
gentoo-2-b3e9808c62e7099aa2490f3f702f762370ff0a89.tar.bz2
gentoo-2-b3e9808c62e7099aa2490f3f702f762370ff0a89.zip
Version bump and cleaning. Fixes insecure tempfile creation (#210609)
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-misc/wyrd/wyrd-1.4.4.ebuild')
-rw-r--r--app-misc/wyrd/wyrd-1.4.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/wyrd/wyrd-1.4.4.ebuild b/app-misc/wyrd/wyrd-1.4.4.ebuild
new file mode 100644
index 000000000000..d7eac5ef2c0f
--- /dev/null
+++ b/app-misc/wyrd/wyrd-1.4.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/wyrd-1.4.4.ebuild,v 1.1 2008/02/22 09:10:20 tove Exp $
+
+inherit eutils
+
+DESCRIPTION="Text-based front-end to Remind"
+HOMEPAGE="http://pessimization.com/software/wyrd/"
+SRC_URI="http://pessimization.com/software/wyrd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="unicode"
+
+DEPEND=">=dev-lang/ocaml-3.08
+ sys-libs/ncurses
+ >=x11-misc/remind-03.01"
+RDEPEND=${DEPEND}
+
+pkg_setup() {
+ use unicode || return 0
+ if ! built_with_use sys-libs/ncurses unicode ; then
+ eerror "To use unicode in wyrd you must build sys-libs/ncurses"
+ eerror "with unicode support."
+ die "Please rebuilt sys-libs/ncurses with unicode in USE!"
+ fi
+}
+
+src_compile() {
+ econf $(use_enable unicode utf8 ) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install died"
+
+ dodoc ChangeLog || die "dodoc failed"
+ dohtml doc/manual.html || die "dohtml failed"
+}