summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-02 15:39:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-02 15:39:41 +0000
commit3289719890c6a5eb7b9dd8a941b10786b21f7ac3 (patch)
tree80dfe2930dd0ceefba76837d1d2b76bef0695dc6 /app-misc
parentx86 stable, bug #278981 (diff)
downloadgentoo-2-3289719890c6a5eb7b9dd8a941b10786b21f7ac3.tar.gz
gentoo-2-3289719890c6a5eb7b9dd8a941b10786b21f7ac3.tar.bz2
gentoo-2-3289719890c6a5eb7b9dd8a941b10786b21f7ac3.zip
Thanks to Lars Wendler again, get the ebuild syntax properly fixed.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/mc/ChangeLog5
-rw-r--r--app-misc/mc/files/mc-4.7.0_pre1-ebuild_syntax.patch40
-rw-r--r--app-misc/mc/mc-4.7.0_pre1.ebuild9
3 files changed, 50 insertions, 4 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 6e9a33b0cbd2..d06a3ac2b1a3 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,8 +1,9 @@
# ChangeLog for app-misc/mc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.152 2009/08/02 15:18:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.153 2009/08/02 15:39:41 ssuominen Exp $
- 02 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> files/ebuild.syntax:
+ 02 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> mc-4.7.0_pre1.ebuild,
+ +files/mc-4.7.0_pre1-ebuild_syntax.patch:
Update ebuild syntax wrt #198019, thanks to Lars Wendler for patch.
*mc-4.7.0_pre1 (02 Aug 2009)
diff --git a/app-misc/mc/files/mc-4.7.0_pre1-ebuild_syntax.patch b/app-misc/mc/files/mc-4.7.0_pre1-ebuild_syntax.patch
new file mode 100644
index 000000000000..2453115b13a2
--- /dev/null
+++ b/app-misc/mc/files/mc-4.7.0_pre1-ebuild_syntax.patch
@@ -0,0 +1,40 @@
+diff -ur mc-4.7.0-pre1.orig/syntax/ebuild.syntax mc-4.7.0-pre1/syntax/ebuild.syntax
+--- mc-4.7.0-pre1.orig/syntax/ebuild.syntax 2009-06-23 21:55:12.000000000 +0300
++++ mc-4.7.0-pre1/syntax/ebuild.syntax 2009-08-02 18:37:56.000000000 +0300
+@@ -38,9 +38,9 @@
+ keyword LINGUAS brightcyan
+
+ keyword whole _elibtoolize yellow
+- keyword whole check_KV yellow
+ keyword whole best_version yellow
+ keyword whole built_with_use yellow
++ keyword whole check_KV yellow
+ keyword whole die yellow
+ keyword whole diropts yellow
+ keyword whole dobin yellow
+@@ -64,6 +64,7 @@
+ keyword whole dosbin yellow
+ keyword whole dosed yellow
+ keyword whole dosym yellow
++ keyword whole eaclocal yellow
+ keyword whole eautoconf yellow
+ keyword whole eautoreconf yellow
+ keyword whole eautomake yellow
+@@ -110,6 +111,8 @@
+ keyword whole use yellow
+ keyword whole use_enable yellow
+ keyword whole use_with yellow
++ #cvs
++ keyword whole cvs_src_unpack yellow
+ #flag-o-matic
+ keyword whole append-flags yellow
+ keyword whole replace-flags yellow
+@@ -118,6 +121,8 @@
+ keyword whole git_src_unpack yellow
+ #java-ant-2
+ keyword whole EANT_BUILD_TARGET yellow
++ #mercurial
++ keyword whole mercurial_src_unpack yellow
+ #svn
+ keyword whole subversion_src_unpack yellow
+
diff --git a/app-misc/mc/mc-4.7.0_pre1.ebuild b/app-misc/mc/mc-4.7.0_pre1.ebuild
index 76a9369135b0..8c8f1f2369f5 100644
--- a/app-misc/mc/mc-4.7.0_pre1.ebuild
+++ b/app-misc/mc/mc-4.7.0_pre1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.7.0_pre1.ebuild,v 1.4 2009/08/02 15:20:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.7.0_pre1.ebuild,v 1.5 2009/08/02 15:39:41 ssuominen Exp $
EAPI=2
+inherit eutils
MY_P=${P/_/-}
@@ -13,7 +14,7 @@ SRC_URI="http://www.midnight-commander.org/downloads/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~arm ~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="gpm nls +slang X"
+IUSE="gpm nls samba +slang X"
RDEPEND=">=dev-libs/glib-2.6:2
gpm? ( sys-libs/gpm )
@@ -31,6 +32,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ebuild_syntax.patch
+}
+
src_configure() {
local myscreen=ncurses