summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-02-26 19:56:32 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-02-26 19:56:32 +0000
commit72622ed314e21c2611ac18eab0af64c2181ea97b (patch)
tree34e504a1c1db36e243c3a389ed1849cf95fe963d /app-misc
parentmarked x86 per bug 405365 (diff)
downloadgentoo-2-72622ed314e21c2611ac18eab0af64c2181ea97b.tar.gz
gentoo-2-72622ed314e21c2611ac18eab0af64c2181ea97b.tar.bz2
gentoo-2-72622ed314e21c2611ac18eab0af64c2181ea97b.zip
Bump to 1.3.3, fix metadata. Thanks to slepnoga
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/hivex/ChangeLog13
-rw-r--r--app-misc/hivex/files/1.3.3/0001-Fixed-gnulib-integration-for-hivexml.patch70
-rw-r--r--app-misc/hivex/files/1.3.3/0002-automake.patch67
-rw-r--r--app-misc/hivex/files/1.3.3/0003_autoconf_fix_automagic-1.3.3.patch105
-rw-r--r--app-misc/hivex/hivex-1.3.3.ebuild80
-rw-r--r--app-misc/hivex/metadata.xml2
6 files changed, 334 insertions, 3 deletions
diff --git a/app-misc/hivex/ChangeLog b/app-misc/hivex/ChangeLog
index eca2989b292b..c1260b2a0c47 100644
--- a/app-misc/hivex/ChangeLog
+++ b/app-misc/hivex/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-misc/hivex
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.11 2011/12/01 17:26:53 maksbotan Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.12 2012/02/26 19:56:32 maksbotan Exp $
+
+*hivex-1.3.3 (26 Feb 2012)
+
+ 26 Feb 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/1.3.3/0001-Fixed-gnulib-integration-for-hivexml.patch,
+ +files/1.3.3/0002-automake.patch,
+ +files/1.3.3/0003_autoconf_fix_automagic-1.3.3.patch, +hivex-1.3.3.ebuild,
+ metadata.xml:
+ Bump to 1.3.3, fix metadata. Thanks to slepnoga
*hivex-1.3.2-r1 (01 Dec 2011)
diff --git a/app-misc/hivex/files/1.3.3/0001-Fixed-gnulib-integration-for-hivexml.patch b/app-misc/hivex/files/1.3.3/0001-Fixed-gnulib-integration-for-hivexml.patch
new file mode 100644
index 000000000000..553f7a7ad87e
--- /dev/null
+++ b/app-misc/hivex/files/1.3.3/0001-Fixed-gnulib-integration-for-hivexml.patch
@@ -0,0 +1,70 @@
+From: Hilko Bengen <bengen@debian.org>
+Date: Thu, 1 Dec 2011 22:07:26 +0100
+Subject: Fixed gnulib integration for hivexml
+
+---
+ lib/Makefile.am | 5 ++++-
+ sh/Makefile.am | 1 +
+ xml/Makefile.am | 3 ++-
+ xml/hivexml.c | 2 ++
+ 4 files changed, 9 insertions(+), 2 deletions(-)
+
+diff --git a/lib/Makefile.am b/lib/Makefile.am
+index cfd2e05..a339a00 100644
+--- a/lib/Makefile.am
++++ b/lib/Makefile.am
+@@ -39,7 +39,10 @@ libhivex_la_LDFLAGS = \
+ $(LTLIBINTL) \
+ $(LTLIBTHREAD)
+ libhivex_la_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
+-libhivex_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib -I$(srcdir)
++libhivex_la_CPPFLAGS = \
++ -I$(top_srcdir)/gnulib/lib \
++ -I$(top_builddir)/gnulib/lib \
++ -I$(srcdir)
+
+ include_HEADERS = hivex.h
+
+diff --git a/sh/Makefile.am b/sh/Makefile.am
+index 0898370..a6f5ae6 100644
+--- a/sh/Makefile.am
++++ b/sh/Makefile.am
+@@ -38,6 +38,7 @@ hivexsh_SOURCES = \
+ hivexsh_LDADD = ../lib/libhivex.la ../gnulib/lib/libgnu.la $(LIBREADLINE)
+ hivexsh_CFLAGS = \
+ -I$(top_srcdir)/gnulib/lib \
++ -I$(top_builddir)/gnulib/lib \
+ -I$(top_srcdir)/lib \
+ -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
+ $(WARN_CFLAGS) $(WERROR_CFLAGS)
+diff --git a/xml/Makefile.am b/xml/Makefile.am
+index b2af45d..67ba248 100644
+--- a/xml/Makefile.am
++++ b/xml/Makefile.am
+@@ -23,10 +23,11 @@ bin_PROGRAMS = hivexml
+ hivexml_SOURCES = \
+ hivexml.c
+
+-hivexml_LDADD = ../lib/libhivex.la $(LIBXML2_LIBS)
++hivexml_LDADD = ../lib/libhivex.la ../gnulib/lib/libgnu.la $(LIBXML2_LIBS)
+ hivexml_CFLAGS = \
+ -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
+ -I$(top_srcdir)/gnulib/lib \
++ -I$(top_builddir)/gnulib/lib \
+ -I$(top_srcdir)/lib \
+ $(LIBXML2_CFLAGS) \
+ $(WARN_CFLAGS) $(WERROR_CFLAGS)
+diff --git a/xml/hivexml.c b/xml/hivexml.c
+index 5030c24..d38e9d4 100644
+--- a/xml/hivexml.c
++++ b/xml/hivexml.c
+@@ -32,6 +32,8 @@
+ #include <libintl.h>
+ #endif
+
++#include <getopt.h>
++
+ #include <libxml/xmlwriter.h>
+
+ #include "hivex.h"
+--
diff --git a/app-misc/hivex/files/1.3.3/0002-automake.patch b/app-misc/hivex/files/1.3.3/0002-automake.patch
new file mode 100644
index 000000000000..8af8117c7f64
--- /dev/null
+++ b/app-misc/hivex/files/1.3.3/0002-automake.patch
@@ -0,0 +1,67 @@
+From: Hilko Bengen <bengen@debian.org>
+Date: Thu, 1 Dec 2011 22:08:07 +0100
+Subject: automake
+
+---
+ lib/Makefile.in | 6 +++++-
+ sh/Makefile.in | 1 +
+ xml/Makefile.in | 6 ++++--
+ 3 files changed, 10 insertions(+), 3 deletions(-)
+
+diff --git a/lib/Makefile.in b/lib/Makefile.in
+index 65734dd..5cf7bde 100644
+--- a/lib/Makefile.in
++++ b/lib/Makefile.in
+@@ -1045,7 +1045,11 @@ libhivex_la_LDFLAGS = \
+ $(LTLIBTHREAD)
+
+ libhivex_la_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
+-libhivex_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib -I$(srcdir)
++libhivex_la_CPPFLAGS = \
++ -I$(top_srcdir)/gnulib/lib \
++ -I$(top_builddir)/gnulib/lib \
++ -I$(srcdir)
++
+ include_HEADERS = hivex.h
+ man_MANS = hivex.3
+ noinst_DATA = \
+diff --git a/sh/Makefile.in b/sh/Makefile.in
+index 109c8e8..0308a32 100644
+--- a/sh/Makefile.in
++++ b/sh/Makefile.in
+@@ -995,6 +995,7 @@ hivexsh_SOURCES = \
+ hivexsh_LDADD = ../lib/libhivex.la ../gnulib/lib/libgnu.la $(LIBREADLINE)
+ hivexsh_CFLAGS = \
+ -I$(top_srcdir)/gnulib/lib \
++ -I$(top_builddir)/gnulib/lib \
+ -I$(top_srcdir)/lib \
+ -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
+ $(WARN_CFLAGS) $(WERROR_CFLAGS)
+diff --git a/xml/Makefile.in b/xml/Makefile.in
+index ed4cd72..5cb647f 100644
+--- a/xml/Makefile.in
++++ b/xml/Makefile.in
+@@ -119,7 +119,8 @@ PROGRAMS = $(bin_PROGRAMS)
+ am_hivexml_OBJECTS = hivexml-hivexml.$(OBJEXT)
+ hivexml_OBJECTS = $(am_hivexml_OBJECTS)
+ am__DEPENDENCIES_1 =
+-hivexml_DEPENDENCIES = ../lib/libhivex.la $(am__DEPENDENCIES_1)
++hivexml_DEPENDENCIES = ../lib/libhivex.la ../gnulib/lib/libgnu.la \
++ $(am__DEPENDENCIES_1)
+ AM_V_lt = $(am__v_lt_$(V))
+ am__v_lt_ = $(am__v_lt_$(AM_DEFAULT_VERBOSITY))
+ am__v_lt_0 = --silent
+@@ -976,10 +977,11 @@ EXTRA_DIST = \
+ hivexml_SOURCES = \
+ hivexml.c
+
+-hivexml_LDADD = ../lib/libhivex.la $(LIBXML2_LIBS)
++hivexml_LDADD = ../lib/libhivex.la ../gnulib/lib/libgnu.la $(LIBXML2_LIBS)
+ hivexml_CFLAGS = \
+ -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
+ -I$(top_srcdir)/gnulib/lib \
++ -I$(top_builddir)/gnulib/lib \
+ -I$(top_srcdir)/lib \
+ $(LIBXML2_CFLAGS) \
+ $(WARN_CFLAGS) $(WERROR_CFLAGS)
+--
diff --git a/app-misc/hivex/files/1.3.3/0003_autoconf_fix_automagic-1.3.3.patch b/app-misc/hivex/files/1.3.3/0003_autoconf_fix_automagic-1.3.3.patch
new file mode 100644
index 000000000000..e49d2d390e0c
--- /dev/null
+++ b/app-misc/hivex/files/1.3.3/0003_autoconf_fix_automagic-1.3.3.patch
@@ -0,0 +1,105 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -183,11 +183,19 @@
+ AC_CHECK_FUNC([open_memstream])
+ AM_CONDITIONAL([HAVE_HIVEXSH],[test "x$ac_cv_func_open_memstream" = "xyes"])
+
++
+ dnl Check for OCaml (optional, for OCaml bindings).
++AC_ARG_ENABLE([ocaml],
++ AS_HELP_STRING([--with-ocaml],[build Ocaml binding]))
++
++
++
++
+ AC_PROG_OCAML
+ AC_PROG_FINDLIB
+ AM_CONDITIONAL([HAVE_OCAML],
+- [test "x$OCAMLC" != "xno" && test "x$OCAMLFIND" != "xno"])
++ [test "x$OCAMLC" != "xno" -a "x$OCAMLFIND" != "xno" -a "x$enable_ocaml" = "xyes"])
++
+ AM_CONDITIONAL([HAVE_OCAMLOPT],
+ [test "x$OCAMLOPT" != "xno" && test "x$OCAMLFIND" != "xno"])
+
+@@ -227,21 +235,32 @@
+ dnl Check for Perl modules that must be present to compile and
+ dnl test the Perl bindings.
+ missing_perl_modules=no
+-for pm in Test::More ExtUtils::MakeMaker IO::Stringy; do
+- AC_MSG_CHECKING([for $pm])
+- if ! perl -M$pm -e1 >/dev/null 2>&1; then
+- AC_MSG_RESULT([no])
+- missing_perl_modules=yes
+- else
+- AC_MSG_RESULT([yes])
+- fi
+-done
+-if test "x$missing_perl_modules" = "xyes"; then
+- AC_MSG_WARN([some Perl modules required to compile or test the Perl bindings are missing])
+-fi
++AC_ARG_ENABLE([perl],
++ AS_HELP_STRING([--with-perl],[build Perl binding]))
++
++
++PERL=
++AS_IF([test "x$enable_perl" != "xno" ],[
++ AC_CHECK_PROG([PERL],[perl],[yes],[no])
++
++ for pm in Test::More ExtUtils::MakeMaker IO::Stringy; do
++ AC_MSG_CHECKING([for $pm])
++ if ! perl -M$pm -e1 >/dev/null 2>&1; then
++ AC_MSG_RESULT([no])
++ missing_perl_modules=yes
++ else
++ AC_MSG_RESULT([yes])
++ fi
++ done
++
++ AS_IF([test "x$missing_perl_modules" = "xyes"],
++ [AC_MSG_FAILURE([some Perl modules required to compile or test the Perl bindings are missing])],
++ )
++])
+
+ AM_CONDITIONAL([HAVE_PERL],
+- [test "x$PERL" != "xno" && test "x$missing_perl_modules" != "xyes"])
++ [test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes" -a "x$enable_perl" = "xyes"])
++
+
+ dnl Check for Python (optional, for Python bindings).
+ PYTHON_PREFIX=
+@@ -251,6 +270,7 @@
+
+ AC_CHECK_PROG([PYTHON],[python],[python],[no])
+
++
+ if test "x$PYTHON" != "xno"; then
+ AC_MSG_CHECKING([Python prefix])
+ PYTHON_PREFIX=`$PYTHON -c "import sys; print (sys.prefix)"`
+@@ -308,15 +328,24 @@
+ AC_SUBST(PYTHON_INCLUDEDIR)
+ AC_SUBST(PYTHON_INSTALLDIR)
+
++AC_ARG_ENABLE([python],
++ AS_HELP_STRING([--with-python],[build Python binding]))
++
+ AM_CONDITIONAL([HAVE_PYTHON],
+- [test "x$PYTHON" != "xno" && test "x$PYTHON_INCLUDEDIR" != "x" && test "x$PYTHON_INSTALLDIR" != "x"])
++ [test "x$PYTHON_INCLUDEDIR" != "x" -a "x$PYTHON_SITE_PACKAGES" != "x" -a "x$enable_python" = "xyes"])
++
++
+
+ dnl Check for Ruby and rake (optional, for Ruby bindings).
++AC_ARG_ENABLE([ruby],
++ AS_HELP_STRING([--with-ruby],[build Ruby binding]))
++
+ AC_CHECK_LIB([ruby],[ruby_init],[HAVE_LIBRUBY=1],[HAVE_LIBRUBY=0])
+ AC_CHECK_PROG([RAKE],[rake],[rake],[no])
+
+ AM_CONDITIONAL([HAVE_RUBY],
+- [test "x$RAKE" != "xno" && test -n "$HAVE_LIBRUBY"])
++ [test "x$RAKE" != "xno" && test -n "$HAVE_LIBRUBY" -a "x$enable_ruby" = "xyes"])
++
+
+ dnl dnl Check for Java.
+ dnl AC_ARG_WITH(java_home,
diff --git a/app-misc/hivex/hivex-1.3.3.ebuild b/app-misc/hivex/hivex-1.3.3.ebuild
new file mode 100644
index 000000000000..be7e4b5a2c39
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.3.ebuild,v 1.1 2012/02/26 19:56:32 maksbotan Exp $
+
+EAPI=4
+
+WANT_AUTOMAKE="1.11"
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PYTHON_DEPEND="python? 2:2.6"
+inherit base autotools-utils perl-app python
+
+DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
+HOMEPAGE="http://libguestfs.org"
+SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocaml readline perl python test static-libs ruby"
+
+RDEPEND="virtual/libiconv
+ virtual/libintl
+ dev-libs/libxml2:2
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ readline? ( sys-libs/readline )
+ perl? ( dev-perl/IO-stringy )
+ "
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ perl? (
+ test? ( dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage ) )
+ ruby? ( dev-ruby/rake )
+ "
+PATCHES=("${FILESDIR}"/"${PV}")
+DOCS=(README)
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ python_need_rebuild
+ fi
+}
+
+src_prepare() {
+ EPATCH_SUFFIX=patch EPATCH_FORCE=yes base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ --enable-nls
+ $(use_enable python)
+ $(use_enable ruby)
+ --disable-rpath )
+
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_compile check
+}
+
+src_install() {
+ strip-linguas -i po
+
+ autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
+
+ if use perl; then
+ fixlocalpod
+ fi
+}
diff --git a/app-misc/hivex/metadata.xml b/app-misc/hivex/metadata.xml
index c0e52e1baa3d..3c86df53987d 100644
--- a/app-misc/hivex/metadata.xml
+++ b/app-misc/hivex/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>proxy-maintainers</herd>
<maintainer>
- <email>spamslepnoga@inbox.ru</email>
+ <email>andreis.vinogradovs@gmail.com</email>
</maintainer>
<maintainer>
<email>maksbotan@gentoo.org</email>