summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Conrad Tilstra <tadpol@gentoo.org>2001-08-15 19:32:35 +0000
committerMichael Conrad Tilstra <tadpol@gentoo.org>2001-08-15 19:32:35 +0000
commita420b6b6d742cf8fd2ee44bb00dce171fffd4351 (patch)
tree92c65ba11ebb7852d485936c048ad047c33a95b5 /app-misc
parentheader (diff)
downloadgentoo-2-a420b6b6d742cf8fd2ee44bb00dce171fffd4351.tar.gz
gentoo-2-a420b6b6d742cf8fd2ee44bb00dce171fffd4351.tar.bz2
gentoo-2-a420b6b6d742cf8fd2ee44bb00dce171fffd4351.zip
- added patch to make the --colour high=red (not the lack of a `+')
This patch will be submitted to the proper places.
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/devtodo/devtodo-0.1.11-r1.ebuild63
-rw-r--r--app-misc/devtodo/files/devtodo-0.1.11.colourplain.patch12
-rw-r--r--app-misc/devtodo/files/digest-devtodo-0.1.11-r11
3 files changed, 76 insertions, 0 deletions
diff --git a/app-misc/devtodo/devtodo-0.1.11-r1.ebuild b/app-misc/devtodo/devtodo-0.1.11-r1.ebuild
new file mode 100644
index 000000000000..c770696a24fd
--- /dev/null
+++ b/app-misc/devtodo/devtodo-0.1.11-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author AJ Lewis <roadrunner@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.11-r1.ebuild,v 1.1 2001/08/15 19:32:35 tadpol Exp $
+
+#Source directory; the dir where the sources can be found (automatically unpacked)
+S=${WORKDIR}/${P}
+
+#Short one-line description
+DESCRIPTION="A nice command line todo list for developers"
+
+#Point to any required sources; these will be automatically downloaded by Portage
+SRC_URI="http://activelysecure.net/~alec/development/devtodo/0.1.11/${P}.tar.gz"
+
+#Homepage, not used by Portage directly but handy for developer reference
+HOMEPAGE="http://activelysecure.net/~alec/development/devtodo/"
+
+#build-time dependencies
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1
+ >=sys-devel/gcc-2.95.3"
+
+#run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}.colourplain.patch
+}
+
+src_compile() {
+ #the "try" command will stop the build process if the specified command fails. Prefix critical
+ #commands with "try"
+ try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}
+ #Note the use of --infodir and --mandir, above. This is to make this package FHS 2.2-compliant
+ #(/usr/share is used for info and man now).
+
+ try make
+ #emake (previously known as pmake) is a script that calls the standard GNU make with parallel
+ #building options for speedier builds on SMP systems. Use emake first; it might not work. If
+ #not, then replace the line above with:
+
+ #try make
+}
+
+src_install () {
+ #you must *personally verify* that this trick doesn't install
+ #anything outside of DESTDIR; do this by reading and understanding
+ #the install part of the Makefiles. Also note that this will often
+ #also work for autoconf stuff (usually much more often than DESTDIR,
+ #which is actually quite rare.
+
+ # try make prefix=${D}/usr install
+
+ try make DESTDIR=${D} install
+ #again, verify the Makefiles! We don't want anything falling outside
+ #of ${D}.
+
+ dodoc AUTHORS COPYING ChangeLog QuickStart README TODO
+}
+
diff --git a/app-misc/devtodo/files/devtodo-0.1.11.colourplain.patch b/app-misc/devtodo/files/devtodo-0.1.11.colourplain.patch
new file mode 100644
index 000000000000..079fc2d02a2b
--- /dev/null
+++ b/app-misc/devtodo/files/devtodo-0.1.11.colourplain.patch
@@ -0,0 +1,12 @@
+diff -ru devtodo-0.1.11.orig/src/TodoDB.cc devtodo-0.1.11/src/TodoDB.cc
+--- devtodo-0.1.11.orig/src/TodoDB.cc Wed Jul 11 06:42:35 2001
++++ devtodo-0.1.11/src/TodoDB.cc Wed Aug 15 14:10:05 2001
+@@ -814,6 +814,8 @@
+ if (clr[0] == '+') {
+ a = ::bold;
+ clr = colour.substr(1);
++ }else{
++ a = StreamColour::mono;
+ }
+ if (clr == "black") c = ::black;
+ else
diff --git a/app-misc/devtodo/files/digest-devtodo-0.1.11-r1 b/app-misc/devtodo/files/digest-devtodo-0.1.11-r1
new file mode 100644
index 000000000000..f15813677a92
--- /dev/null
+++ b/app-misc/devtodo/files/digest-devtodo-0.1.11-r1
@@ -0,0 +1 @@
+MD5 501566f92724a2073280cbdf8adeb709 devtodo-0.1.11.tar.gz