summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-02-27 00:51:22 +0000
committerJeroen Roovers <jer@gentoo.org>2012-02-27 00:51:22 +0000
commita45a0ae0be3fe0f29cb4edd309cade1e5b0ceb5f (patch)
tree862dec07d055bf4ad37b2f6d86f09c56776927b7 /app-misc
parentRestricting jython (diff)
downloadgentoo-2-a45a0ae0be3fe0f29cb4edd309cade1e5b0ceb5f.tar.gz
gentoo-2-a45a0ae0be3fe0f29cb4edd309cade1e5b0ceb5f.tar.bz2
gentoo-2-a45a0ae0be3fe0f29cb4edd309cade1e5b0ceb5f.zip
Add missing dependency. Fix building with x11-libs/fltk[-static-libs] by Attila Stehr (bug #405819). Clean up patch.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/nut/ChangeLog9
-rw-r--r--app-misc/nut/files/nut-16.12-makefile.patch53
-rw-r--r--app-misc/nut/nut-17.4-r1.ebuild48
-rw-r--r--app-misc/nut/nut-17.4.ebuild9
4 files changed, 94 insertions, 25 deletions
diff --git a/app-misc/nut/ChangeLog b/app-misc/nut/ChangeLog
index 7e096e330a94..88be72e55792 100644
--- a/app-misc/nut/ChangeLog
+++ b/app-misc/nut/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/nut
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.34 2012/02/24 23:43:14 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.35 2012/02/27 00:51:22 jer Exp $
+
+*nut-17.4-r1 (27 Feb 2012)
+
+ 27 Feb 2012; Jeroen Roovers <jer@gentoo.org> files/nut-16.12-makefile.patch,
+ nut-17.4.ebuild, +nut-17.4-r1.ebuild:
+ Add missing dependency. Fix building with x11-libs/fltk[-static-libs] by
+ Attila Stehr (bug #405819). Clean up patch.
24 Feb 2012; Tim Harder <radhermit@gentoo.org>
-files/nut-16.5-build-fixes.patch, -nut-16.9.ebuild:
diff --git a/app-misc/nut/files/nut-16.12-makefile.patch b/app-misc/nut/files/nut-16.12-makefile.patch
index 90fac0b32555..749d6025d46c 100644
--- a/app-misc/nut/files/nut-16.12-makefile.patch
+++ b/app-misc/nut/files/nut-16.12-makefile.patch
@@ -1,25 +1,5 @@
---- nut-16.12.orig//fltk/Makefile
-+++ nut-16.12/fltk/Makefile
-@@ -16,7 +16,7 @@
- CXX = g++
- endif
-
--CFLAGS := -I.. `fltk-config --optim --cflags` -O -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR)
-+CFLAGS += -I.. `fltk-config --optim --cflags` -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR)
-
- ifeq ($(CXX),g++)
- CFLAGS += -Wall -fno-inline -ansi
-@@ -28,7 +28,7 @@
- OBJS := ../anameal.o ../db.o ../food.o ../meal.o ../options.o ../prtmenu.o ../recmeal.o ../util.o $(patsubst %.cc,%.o,$(SOURCE))
-
- nut: $(OBJS)
-- $(CXX) -O -o $(EXECUTABLE) $(OBJS) $(LIBS)
-+ $(CXX) $(LDFLAGS) -o $(EXECUTABLE) $(OBJS) $(LIBS)
-
- deps:
- makedepend -Y. *.h *.cc >/dev/null 2>&1
---- nut-16.12.orig//Makefile
-+++ nut-16.12/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -1,4 +1,4 @@
-prefix = /usr/local
+prefix = /usr
@@ -69,3 +49,32 @@
deps:
makedepend -Y. *.c >/dev/null 2>&1
+--- a/fltk/Makefile
++++ b/fltk/Makefile
+@@ -5,7 +5,7 @@
+ NUTDIR := \".nutdb\"
+ FOODDIR := \"$(libdir)\"
+ EXECUTABLE := Nut
+-LIBS := `fltk-config --ldstaticflags` -lXpm
++LIBS := `fltk-config --ldflags` -lXpm
+
+ OS := $(shell uname -s)
+ ifeq ($(OS),HP-UX)
+@@ -17,7 +17,7 @@
+ CXX = g++
+ endif
+
+-CFLAGS := -I.. `fltk-config --optim --cflags` -O -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR)
++CFLAGS += -I.. `fltk-config --optim --cflags` -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR)
+
+ ifeq ($(CXX),g++)
+ CFLAGS := -I.. `fltk-config --optim --cflags` -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR) -Wall -fno-inline -ansi
+@@ -29,7 +29,7 @@
+ OBJS := ../anameal.o ../db.o ../food.o ../meal.o ../options.o ../prtmenu.o ../recmeal.o ../util.o $(patsubst %.cc,%.o,$(SOURCE))
+
+ nut: $(OBJS)
+- $(CXX) -O -o $(EXECUTABLE) $(OBJS) $(LIBS)
++ $(CXX) $(LDFLAGS) -o $(EXECUTABLE) $(OBJS) $(LIBS)
+
+ deps:
+ makedepend -Y.. ../anameal.c ../db.c ../food.c ../meal.c ../options.c ../prtmenu.c ../recmeal.c ../util.c *.cc >/dev/null 2>&1
diff --git a/app-misc/nut/nut-17.4-r1.ebuild b/app-misc/nut/nut-17.4-r1.ebuild
new file mode 100644
index 000000000000..8aaa3ba38d34
--- /dev/null
+++ b/app-misc/nut/nut-17.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-17.4-r1.ebuild,v 1.1 2012/02/27 00:51:22 jer Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Record what you eat and analyze your nutrient levels"
+HOMEPAGE="http://nut.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86"
+IUSE="X"
+
+RDEPEND="
+ X? (
+ x11-libs/fltk:1
+ x11-libs/libXpm
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-16.12-makefile.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) FOODDIR=\\\"/usr/share/nut\\\"
+ if use X ; then
+ cd fltk
+ emake CXX=$(tc-getCXX) FOODDIR=\\\"/usr/share/nut\\\"
+ fi
+}
+
+src_install() {
+ insinto /usr/share/nut
+ doins raw.data/*
+ dobin nut
+ doman nut.1
+ if use X ; then
+ dobin fltk/Nut
+ doicon nut.xpm
+ make_desktop_entry Nut nut nut Education
+ fi
+}
diff --git a/app-misc/nut/nut-17.4.ebuild b/app-misc/nut/nut-17.4.ebuild
index 68b70d3828ac..6d5cdd7620a5 100644
--- a/app-misc/nut/nut-17.4.ebuild
+++ b/app-misc/nut/nut-17.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-17.4.ebuild,v 1.4 2012/02/24 19:33:06 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-17.4.ebuild,v 1.5 2012/02/27 00:51:22 jer Exp $
EAPI=4
@@ -15,7 +15,12 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~arm ppc x86"
IUSE="X"
-RDEPEND="X? ( x11-libs/fltk:1 )"
+RDEPEND="
+ X? (
+ x11-libs/fltk:1
+ x11-libs/libXpm
+ )
+"
DEPEND="${RDEPEND}"
src_prepare() {