summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-07 12:51:20 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-07 12:51:20 +0000
commita8c1c187f789103bc3cd54ed41a0693237e1306c (patch)
treeccd57097d9a82d5d444bcb9db70f350d2f3d1c0c /app-misc
parentInitial import. (diff)
downloadgentoo-2-a8c1c187f789103bc3cd54ed41a0693237e1306c.tar.gz
gentoo-2-a8c1c187f789103bc3cd54ed41a0693237e1306c.tar.bz2
gentoo-2-a8c1c187f789103bc3cd54ed41a0693237e1306c.zip
Disable auth/telnet/ftp cruft as other packages do these things better. Switch to the linuxa target to avoid parsing /usr/include/ directly. Make ncurses support optional. Respect all env build flags. Clean up missing prototypes and other bad warnings.
(Portage version: 2.2_rc55/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ckermit/ChangeLog11
-rw-r--r--app-misc/ckermit/ckermit-8.0.211-r4.ebuild74
-rw-r--r--app-misc/ckermit/files/ckermit-8.0.211-cleanup.patch78
3 files changed, 162 insertions, 1 deletions
diff --git a/app-misc/ckermit/ChangeLog b/app-misc/ckermit/ChangeLog
index 9ee314f693f9..423662fffa5b 100644
--- a/app-misc/ckermit/ChangeLog
+++ b/app-misc/ckermit/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-misc/ckermit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ckermit/ChangeLog,v 1.30 2009/12/07 07:54:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ckermit/ChangeLog,v 1.31 2009/12/07 12:51:20 vapier Exp $
+
+*ckermit-8.0.211-r4 (07 Dec 2009)
+
+ 07 Dec 2009; Mike Frysinger <vapier@gentoo.org>
+ +ckermit-8.0.211-r4.ebuild, +files/ckermit-8.0.211-cleanup.patch:
+ Disable auth/telnet/ftp cruft as other packages do these things better.
+ Switch to the linuxa target to avoid parsing /usr/include/ directly. Make
+ ncurses support optional. Respect all env build flags. Clean up missing
+ prototypes and other bad warnings.
07 Dec 2009; Mike Frysinger <vapier@gentoo.org> ckermit-8.0.211-r3.ebuild:
Mark all stable.
diff --git a/app-misc/ckermit/ckermit-8.0.211-r4.ebuild b/app-misc/ckermit/ckermit-8.0.211-r4.ebuild
new file mode 100644
index 000000000000..c99d1334e658
--- /dev/null
+++ b/app-misc/ckermit/ckermit-8.0.211-r4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ckermit/ckermit-8.0.211-r4.ebuild,v 1.1 2009/12/07 12:51:20 vapier Exp $
+
+inherit versionator eutils flag-o-matic toolchain-funcs
+
+# Columbia University only uses the third component, e.g. cku211.tar.gz for
+# what we would call 8.0.211.
+MY_P="cku$( get_version_component_range 3 ${PV} )"
+
+DESCRIPTION="combined serial and network communication software package"
+SRC_URI="ftp://kermit.columbia.edu/kermit/archives/${MY_P}.tar.gz"
+HOMEPAGE="http://www.kermit-project.org/"
+
+LICENSE="Kermit"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="ncurses"
+
+DEPEND="ncurses? ( >=sys-libs/ncurses-5.2 )"
+RDEPEND="${DEPEND}
+ net-dialup/lrzsz"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-cleanup.patch
+ sed -i -r \
+ -e 's:"(CC2?) = gcc":"\1=$(CC)":g' \
+ -e 's:"CFLAGS = -O:"CFLAGS = $(CFLAGS):' \
+ makefile || die
+}
+
+ck_use() {
+ use $1 && append-cppflags $2 && libs="${libs} $3"
+}
+src_compile() {
+ # we don't enable any of the telnet/ftp authentication stuff
+ # since there are other packages which do these things better
+ # USE="kerberos pam shadow ssl zlib"
+ append-cppflags -DNO_AUTHENTICATION -DNOLOGIN -DNOFTP
+
+ local libs
+ ck_use ncurses -DCK_NCURSES -lncurses
+ append-cppflags -DHAVE_PTMX -D_XOPEN_SOURCE -D_BSD_SOURCE #202840
+ append-cppflags -DHAVE_CRYPT_H
+ emake \
+ CC="$(tc-getCC)" \
+ KFLAGS="${CPPFLAGS}" \
+ LIBS="-lcrypt -lresolv ${libs}" \
+ LNKFLAGS="${LDFLAGS}" \
+ linuxa || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ emake \
+ DESTDIR="${D}" \
+ BINDIR=/usr/bin \
+ MANDIR="${D}"/usr/share/man/man1 \
+ MANEXT=1 \
+ install || die
+
+ # make the correct symlink
+ rm -f "${D}"/usr/bin/kermit-sshsub
+ dosym /usr/bin/kermit /usr/bin/kermit-sshsub
+
+ # the ckermit.ini script is calling the wrong kermit binary --
+ # the one from ${D}
+ dosed /usr/bin/ckermit.ini
+ dodoc COPYING.TXT UNINSTALL *.txt
+}
diff --git a/app-misc/ckermit/files/ckermit-8.0.211-cleanup.patch b/app-misc/ckermit/files/ckermit-8.0.211-cleanup.patch
new file mode 100644
index 000000000000..5b7c1ed6b951
--- /dev/null
+++ b/app-misc/ckermit/files/ckermit-8.0.211-cleanup.patch
@@ -0,0 +1,78 @@
+clean up missing prototypes and broken printfs
+
+--- a/ckcmai.c
++++ b/ckcmai.c
+@@ -623,6 +623,8 @@ ACKNOWLEDGMENTS:
+ #include "ckntap.h"
+ #endif /* NT */
+
++#include <time.h>
++
+ #ifndef NOSERVER
+ /* Text message definitions.. each should be 256 chars long, or less. */
+ #ifdef MINIX
+--- a/ckufio.c
++++ b/ckufio.c
+@@ -40,6 +40,7 @@ char *ckzv = "UNIX File support, 8.0.200, 4 Mar 2004";
+ #include "ckcsym.h"
+ #include "ckcdeb.h"
+ #include "ckcasc.h"
++#include "ckuusr.h"
+
+ #ifndef NOCSETS
+ #include "ckcxla.h"
+@@ -1803,6 +1804,8 @@ zxin(n,s,x) int n, x; char *s; {
+ return(fread(s, sizeof (char), x, fp[n]));
+ }
+
++extern int ttwait(int fd, int secs);
++
+ /*
+ Z I N F I L L -- Buffered file input.
+
+--- a/ckutio.c
++++ b/ckutio.c
+@@ -1808,6 +1808,11 @@ ttgwsiz() {
+ #endif /* NONAWS */
+ }
+
++#ifdef CK_NAWS /* Negotiate About Window Size */
++#ifdef RLOGCODE
++_PROTOTYP( int rlog_naws, (void) );
++#endif /* RLOGCODE */
++#endif /* CK_NAWS */
+
+ #ifndef NOSIGWINCH
+ #ifdef SIGWINCH
+--- a/ckuus5.c
++++ b/ckuus5.c
+@@ -7747,7 +7747,7 @@ doshow(x) int x; {
+ printf(" --bannerfile=%s\n",bannerfile ? bannerfile : "(null)");
+ printf(" --cdfile:%s\n",cdmsgstr ? cdmsgstr : "(null)");
+ printf(" --cdmessage:%d\n",srvcdmsg);
+- printf(" --helpfile:%d\n",helpfile);
++ printf(" --helpfile:%s\n",helpfile ? helpfile : "(null)");
+ if (inserver) {
+ printf("\n");
+ break;
+--- a/ckuus7.c
++++ b/ckuus7.c
+@@ -2981,7 +2981,7 @@ dopurge() { /* Do the PURGE command */
+ if (n < tokeep) { /* Not deleting any */
+ count = 0;
+ if (listing)
+- printf(" Matches = %d: Not enough to purge.\n");
++ printf(" Matches = %d: Not enough to purge.\n", n);
+ goto xpurge;
+ }
+
+--- a/ckuusx.c
++++ b/ckuusx.c
+@@ -56,7 +56,6 @@
+ #include <termcap.h>
+ #endif /* NOHTERMCAP */
+ #endif /* BSD44 */
+-#else /* !BSD44 */
+ #ifdef linux
+ #include <term.h>
+ #endif /* linux */