summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-03-12 08:34:06 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-03-12 08:34:06 +0000
commitd0bef82d96e555452713e7eb03dcf5a328cca08b (patch)
treec397a7782b8c778ce9f51d3a5c65f6120f9f646d /app-misc
parentstable x86, bug 260038 (diff)
downloadgentoo-2-d0bef82d96e555452713e7eb03dcf5a328cca08b.tar.gz
gentoo-2-d0bef82d96e555452713e7eb03dcf5a328cca08b.tar.bz2
gentoo-2-d0bef82d96e555452713e7eb03dcf5a328cca08b.zip
version bump, bug 261578
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/alexandria/ChangeLog8
-rw-r--r--app-misc/alexandria/alexandria-0.6.4_beta1.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/app-misc/alexandria/ChangeLog b/app-misc/alexandria/ChangeLog
index 8101b7dd3374..a571ad2225af 100644
--- a/app-misc/alexandria/ChangeLog
+++ b/app-misc/alexandria/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/alexandria
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.25 2009/02/25 14:14:26 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.26 2009/03/12 08:34:06 fauli Exp $
+
+*alexandria-0.6.4_beta1 (12 Mar 2009)
+
+ 12 Mar 2009; Christian Faulhammer <fauli@gentoo.org>
+ +alexandria-0.6.4_beta1.ebuild:
+ version bump, bug 261578
25 Feb 2009; Joseph Jezak <josejx@gentoo.org> alexandria-0.6.3-r1.ebuild:
Marked ~ppc for bug #219053.
diff --git a/app-misc/alexandria/alexandria-0.6.4_beta1.ebuild b/app-misc/alexandria/alexandria-0.6.4_beta1.ebuild
new file mode 100644
index 000000000000..2a6a336274c5
--- /dev/null
+++ b/app-misc/alexandria/alexandria-0.6.4_beta1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/alexandria-0.6.4_beta1.ebuild,v 1.1 2009/03/12 08:34:06 fauli Exp $
+
+inherit gnome2 ruby
+
+MY_PV=${PV//_beta/b}
+
+DESCRIPTION="A GNOME application to help you manage your book collection"
+HOMEPAGE="http://alexandria.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="evo"
+
+DOCS="ChangeLog README TODO"
+
+RDEPEND=">=dev-lang/ruby-1.8.0
+ >=dev-ruby/ruby-gettext-0.6.1
+ >=dev-ruby/ruby-gnome2-0.16.0
+ >=dev-ruby/ruby-libglade2-0.12.0
+ >=dev-ruby/ruby-gconf2-0.12.0
+ >=dev-ruby/imagesize-0.1.1
+ evo? ( >=dev-ruby/revolution-0.5 )"
+
+DEPEND=">=dev-lang/ruby-1.8.0
+ app-text/scrollkeeper
+ dev-ruby/rake"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-rakefile.patch"
+)
+
+src_compile() {
+ rake || die
+}
+
+src_install() {
+ export PREFIX="${D}/usr"
+ rake install || die
+
+ [ -n "${DOCS}" ] && dodoc ${DOCS}
+
+ # Move the installed docs to the gentoo standard directory
+ for doc in "${D}/usr/share/doc/alexandria/*"
+ do
+ dodoc $doc
+ done
+ rm -rf "${D}/usr/share/doc/alexandria"
+}
+
+pkg_postinst() {
+ unset PREFIX
+
+ gnome2_gconf_install
+
+ # For the next line see bug #76726
+ "${ROOT}/usr/bin/gconftool-2" --shutdown
+
+ echo
+ elog "To enable some book providers you will need to emerge"
+ elog "additional packages:"
+ echo
+ elog " For the Deastore book provider:"
+ elog " dev-ruby/htmlentities"
+ echo
+ elog " For Z39.50 support and the Library of Congress and"
+ elog " British Library book proviers:"
+ elog " dev-ruby/ruby-zoom"
+ echo
+ elog " For the Amazon book provider:"
+ elog " dev-ruby/hpricot"
+ echo
+}