summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-11-02 12:46:58 +0000
committerAlin Năstac <mrness@gentoo.org>2008-11-02 12:46:58 +0000
commitf94cbadae676046e66821044cdc282afe1b3620b (patch)
treed01be1b9441a35799dc5d760755683e4c718e2f0 /app-mobilephone/gammu
parentReassigned package to maintainer-needed. (diff)
downloadgentoo-2-f94cbadae676046e66821044cdc282afe1b3620b.tar.gz
gentoo-2-f94cbadae676046e66821044cdc282afe1b3620b.tar.bz2
gentoo-2-f94cbadae676046e66821044cdc282afe1b3620b.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-mobilephone/gammu')
-rw-r--r--app-mobilephone/gammu/ChangeLog7
-rw-r--r--app-mobilephone/gammu/gammu-1.21.0.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/app-mobilephone/gammu/ChangeLog b/app-mobilephone/gammu/ChangeLog
index 720d5c7dce5a..95a98580cc45 100644
--- a/app-mobilephone/gammu/ChangeLog
+++ b/app-mobilephone/gammu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/gammu
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.57 2008/07/31 19:56:55 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.58 2008/11/02 12:46:58 mrness Exp $
+
+*gammu-1.21.0 (02 Nov 2008)
+
+ 02 Nov 2008; Alin Năstac <mrness@gentoo.org> +gammu-1.21.0.ebuild:
+ Version bump.
31 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-mobilephone/gammu/gammu-1.21.0.ebuild b/app-mobilephone/gammu/gammu-1.21.0.ebuild
new file mode 100644
index 000000000000..f0e058e37b33
--- /dev/null
+++ b/app-mobilephone/gammu/gammu-1.21.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.21.0.ebuild,v 1.1 2008/11/02 12:46:58 mrness Exp $
+
+inherit cmake-utils
+
+DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
+HOMEPAGE="http://www.gammu.org"
+SRC_URI="ftp://dl.cihar.com/gammu/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug bluetooth irda mysql postgres nls"
+
+RDEPEND="bluetooth? ( net-wireless/bluez-libs )
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-server )
+ dev-util/dialog"
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( sys-devel/gettext )
+ dev-util/cmake"
+
+# sys-devel/gettext is needed for creating .mo files
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" cs de es id it pl ru"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_unpack() {
+ unpack ${A}
+
+ pushd "${S}"/locale || die "locale directory not found"
+ local lang support_linguas=no
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if use linguas_${lang} ; then
+ support_linguas=yes
+ break
+ fi
+ done
+ # install all languages when all selected LINGUAS aren't supported
+ if [ "${support_linguas}" = "yes" ]; then
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ sed -i -e "/^[[:space:]]*${lang}[[:space:]]*$/d" CMakeLists.txt
+ fi
+ done
+ fi
+ popd
+}
+
+src_compile() {
+ # debug flag is used inside cmake-utils.eclass
+ local mycmakeargs="$(cmake-utils_use_with bluetooth Bluez) \
+ $(cmake-utils_use_with irda IrDA) \
+ $(cmake-utils_use_with mysql MySQL) \
+ $(cmake-utils_use_with postgres Postgres) \
+ -DENABLE_SHARED=ON"
+ cmake-utils_src_compile
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${WORKDIR}"/${PN}_build/common cmake-utils_src_test
+}