summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-12-13 12:35:19 +0000
committerAlin Năstac <mrness@gentoo.org>2008-12-13 12:35:19 +0000
commit4369ab1b9440c559b69870490963a1a06fa576ef (patch)
treef42cbb486008cb7c6b1926dd8c3cd0446265f058 /app-mobilephone/gnokii
parentStable on sparc, bug #243096 (diff)
downloadgentoo-2-4369ab1b9440c559b69870490963a1a06fa576ef.tar.gz
gentoo-2-4369ab1b9440c559b69870490963a1a06fa576ef.tar.bz2
gentoo-2-4369ab1b9440c559b69870490963a1a06fa576ef.zip
Version bump (#248667).
Change postgresql-server dependency atom to postgresql-base (#250347). (Portage version: 2.1.4.5)
Diffstat (limited to 'app-mobilephone/gnokii')
-rw-r--r--app-mobilephone/gnokii/ChangeLog8
-rw-r--r--app-mobilephone/gnokii/gnokii-0.6.27.ebuild90
2 files changed, 97 insertions, 1 deletions
diff --git a/app-mobilephone/gnokii/ChangeLog b/app-mobilephone/gnokii/ChangeLog
index c759e111c6c1..091268c88af8 100644
--- a/app-mobilephone/gnokii/ChangeLog
+++ b/app-mobilephone/gnokii/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/gnokii
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/ChangeLog,v 1.82 2008/08/31 07:13:53 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/ChangeLog,v 1.83 2008/12/13 12:35:19 mrness Exp $
+
+*gnokii-0.6.27 (13 Dec 2008)
+
+ 13 Dec 2008; Alin Năstac <mrness@gentoo.org> +gnokii-0.6.27.ebuild:
+ Version bump (#248667). Change postgresql-server dependency atom to
+ postgresql-base (#250347).
31 Aug 2008; Alin Năstac <mrness@gentoo.org> gnokii-0.6.22-r2.ebuild,
gnokii-0.6.26-r2.ebuild:
diff --git a/app-mobilephone/gnokii/gnokii-0.6.27.ebuild b/app-mobilephone/gnokii/gnokii-0.6.27.ebuild
new file mode 100644
index 000000000000..128118ffc90e
--- /dev/null
+++ b/app-mobilephone/gnokii/gnokii-0.6.27.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/gnokii-0.6.27.ebuild,v 1.1 2008/12/13 12:35:19 mrness Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="user space driver and tools for use with mobile phones"
+HOMEPAGE="http://www.gnokii.org/"
+SRC_URI="http://www.gnokii.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls bluetooth ical irda sms postgres mysql usb X debug"
+
+RDEPEND="sys-apps/pcsc-lite
+ X? ( >=x11-libs/gtk+-2 )
+ bluetooth? ( >=net-wireless/bluez-libs-2.25 )
+ sms? ( >=dev-libs/glib-2
+ postgres? ( >=virtual/postgresql-base-8.0 )
+ mysql? ( >=virtual/mysql-4.1 )
+ )
+ ical? ( dev-libs/libical )
+ usb? ( dev-libs/libusb )"
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( sys-devel/gettext )"
+
+CONFIG_CHECK="UNIX98_PTYS"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" cs de et fi fr it nl pl pt sk sl sv zh_CN"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_compile() {
+ strip-linguas ${MY_AVAILABLE_LINGUAS}
+
+ local config_xdebug="--disable-xdebug"
+ use X && use debug && config_xdebug="--enable-xdebug"
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable ical libical) \
+ $(use_enable usb libusb) \
+ $(use_enable irda) \
+ $(use_enable bluetooth) \
+ $(use_with X x) \
+ $(use_with sms smsd) \
+ $(use_enable debug fulldebug) \
+ ${config_xdebug} \
+ $(use_enable debug rlpdebug) \
+ --enable-security \
+ --disable-unix98test \
+ --enable-libpcsclite \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ insinto /etc
+ doins Docs/sample/gnokiirc
+ sed -i -e 's:/usr/local:/usr:' "${D}/etc/gnokiirc"
+
+ # only one file needs suid root to make a pseudo device
+ fperms 4755 /usr/sbin/mgnokiidev
+
+ if use X; then
+ insinto /usr/share/pixmaps
+ newins Docs/sample/logo/gnokii.xpm xgnokii.xpm
+ fi
+
+ if use sms; then
+ pushd "${S}/smsd"
+ insinto /usr/share/doc/${PN}/smsd
+ use mysql && doins sms.tables.mysql.sql README.MySQL
+ use postgres && doins sms.tables.pq.sql
+ doins README ChangeLog README.Tru64 action
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "Make sure the user that runs gnokii has read/write access to the device"
+ elog "which your phone is connected to."
+ elog "The simple way of doing that is to add your user to the uucp group."
+}