summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-12-29 20:56:05 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-12-29 20:56:05 +0000
commitb967c6c978cac19d4aede59c3a9bf5220d87ba2a (patch)
tree819344835f05ce50056a8266101df1e8b7a26867 /app-mobilephone
parentarm stable, bug #344827 (diff)
downloadgentoo-2-b967c6c978cac19d4aede59c3a9bf5220d87ba2a.tar.gz
gentoo-2-b967c6c978cac19d4aede59c3a9bf5220d87ba2a.tar.bz2
gentoo-2-b967c6c978cac19d4aede59c3a9bf5220d87ba2a.zip
version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/wammu/ChangeLog7
-rw-r--r--app-mobilephone/wammu/wammu-0.35.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/app-mobilephone/wammu/ChangeLog b/app-mobilephone/wammu/ChangeLog
index a03f0d6bea72..5fda413cea27 100644
--- a/app-mobilephone/wammu/ChangeLog
+++ b/app-mobilephone/wammu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/wammu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.44 2010/10/10 16:38:38 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.45 2010/12/29 20:56:05 fauli Exp $
+
+*wammu-0.35 (29 Dec 2010)
+
+ 29 Dec 2010; Christian Faulhammer <fauli@gentoo.org> +wammu-0.35.ebuild:
+ version bump
10 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
wammu-0.34.ebuild:
diff --git a/app-mobilephone/wammu/wammu-0.35.ebuild b/app-mobilephone/wammu/wammu-0.35.ebuild
new file mode 100644
index 000000000000..e5dabb74679f
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.35.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.35.ebuild,v 1.1 2010/12/29 20:56:05 fauli Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Front-end for gammu to access mobile phones easily"
+HOMEPAGE="http://www.wammu.eu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bluetooth"
+
+RDEPEND=">=app-mobilephone/gammu-1.25.0[python]
+ >=dev-python/wxpython-2.8
+ bluetooth? (
+ || (
+ dev-python/pybluez
+ net-wireless/gnome-bluetooth
+ )
+ )"
+DEPEND="${RDEPEND}"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv zh_CN zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ local lang support_linguas=no
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if use linguas_${lang} ; then
+ support_linguas=yes
+ break
+ fi
+ done
+ # install all languages when all selected LINGUAS aren't supported
+ if [ "${support_linguas}" = "yes" ]; then
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm -r locale/${lang} || die
+ fi
+ done
+ fi
+
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS FAQ"
+ SKIPWXCHECK=yes distutils_src_install
+}