summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-02-06 18:52:55 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2013-02-06 18:52:55 +0000
commit10e1bdf295063fc5c02c4ba0cdea1494ad6ad1ed (patch)
tree48065e10d4f2d03411ba83028c29bd08a065c531 /app-office/akonadi-server
parentFix update checker removal. (diff)
downloadgentoo-2-10e1bdf295063fc5c02c4ba0cdea1494ad6ad1ed.tar.gz
gentoo-2-10e1bdf295063fc5c02c4ba0cdea1494ad6ad1ed.tar.bz2
gentoo-2-10e1bdf295063fc5c02c4ba0cdea1494ad6ad1ed.zip
Version bump KDE SC 4.10.0
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'app-office/akonadi-server')
-rw-r--r--app-office/akonadi-server/ChangeLog10
-rw-r--r--app-office/akonadi-server/akonadi-server-1.9.0.ebuild113
-rw-r--r--app-office/akonadi-server/files/akonadi-server-1.9.0-qt5.patch24
3 files changed, 145 insertions, 2 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index 656fe3bde567..b3700c908aaf 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/akonadi-server
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.94 2012/11/30 15:11:40 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.95 2013/02/06 18:52:54 alexxy Exp $
+
+*akonadi-server-1.9.0 (06 Feb 2013)
+
+ 06 Feb 2013; Alexey Shvetsov <alexxy@gentoo.org>
+ +akonadi-server-1.9.0.ebuild, +files/akonadi-server-1.9.0-qt5.patch:
+ Version bump KDE SC 4.10.0
30 Nov 2012; <ago@gentoo.org> akonadi-server-1.8.1.ebuild:
Stable for ppc, wrt bug #442394
diff --git a/app-office/akonadi-server/akonadi-server-1.9.0.ebuild b/app-office/akonadi-server/akonadi-server-1.9.0.ebuild
new file mode 100644
index 000000000000..ac626e541ec8
--- /dev/null
+++ b/app-office/akonadi-server/akonadi-server-1.9.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.9.0.ebuild,v 1.1 2013/02/06 18:52:54 alexxy Exp $
+
+EAPI=4
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-2
+ EGIT_REPO_URI="git://anongit.kde.org/akonadi"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://kde/stable/${PN/-server/}/src/${P/-server/}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${P/-server/}"
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+DESCRIPTION="The server part of Akonadi"
+HOMEPAGE="http://pim.kde.org/akonadi"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="mysql postgres +sqlite test"
+
+CDEPEND="
+ dev-libs/boost
+ >=dev-libs/soprano-2.6.51
+ >=x11-libs/qt-gui-4.5.0:4[dbus]
+ >=x11-libs/qt-sql-4.5.0:4[mysql?,postgres?]
+ >=x11-libs/qt-test-4.5.0:4
+ x11-misc/shared-mime-info
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ >=dev-util/automoc-0.9.88
+"
+RDEPEND="${CDEPEND}
+ postgres? ( dev-db/postgresql-server )
+"
+
+REQUIRED_USE="|| ( sqlite mysql postgres )"
+
+RESTRICT=test
+
+PATCHES=( "${FILESDIR}/${P}-qt5.patch" )
+
+pkg_setup() {
+ # Set default storage backend in order: SQLite, MySQL, PostgreSQL
+ # reverse driver check to keep the order
+ if use postgres; then
+ DRIVER="QPSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use mysql; then
+ DRIVER="QMYSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use sqlite; then
+ DRIVER="QSQLITE3"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ # Notify about driver name change
+ if use sqlite && has_version "<=${CATEGORY}/${PN}-1.4.0[sqlite]"; then
+ ewarn
+ ewarn "SQLite driver name changed from QSQLITE to QSQLITE3."
+ ewarn "Please edit your ~/.config/akonadi/akonadiserverrc."
+ fi
+
+ # Notify about MySQL not being default anymore
+ if ! use mysql && has_version "<=${CATEGORY}/${PN}-1.4.0[mysql]"; then
+ ewarn
+ ewarn "MySQL driver is not enabled by default in Gentoo anymore."
+ ewarn "If you intend to use it, please enable mysql USE flag and reinstall"
+ ewarn "${CATEGORY}/${PN}."
+ ewarn "Otherwise select different driver in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "Available drivers are:${AVAILABLE}"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DAKONADI_USE_STRIGI_SEARCH=OFF
+ -DWITH_QT5=OFF
+ $(cmake-utils_use test AKONADI_BUILD_TESTS)
+ $(cmake-utils_use sqlite AKONADI_BUILD_QSQLITE)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ echo
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+ elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are: ${AVAILABLE}"
+}
diff --git a/app-office/akonadi-server/files/akonadi-server-1.9.0-qt5.patch b/app-office/akonadi-server/files/akonadi-server-1.9.0-qt5.patch
new file mode 100644
index 000000000000..132557ad8532
--- /dev/null
+++ b/app-office/akonadi-server/files/akonadi-server-1.9.0-qt5.patch
@@ -0,0 +1,24 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e0efd25..efcdbe0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -21,6 +21,7 @@ option(AKONADI_BUILD_QSQLITE "Build the Sqlite backend." TRUE)
+ option(AKONADI_USE_STRIGI_SEARCH "Build Akonadi with strigi as search engine." FALSE)
+ option(INSTALL_QSQLITE_IN_QT_PREFIX "Install the QSQLite plugin in QT_PLUGIN_DIR" FALSE)
+ option(STATIC_LIBRARY "Build Akonadi as a static library." FALSE)
++OPTION(WITH_QT5 "Build against Qt5." TRUE)
+
+ if(NOT DEFINED DATABASE_BACKEND)
+ set(DATABASE_BACKEND "MYSQL" CACHE STRING "The default database backend to use for Akonadi. Can be either MYSQL, POSTGRES or SQLITE")
+@@ -128,7 +129,10 @@ set_default_db_backend(${DATABASE_BACKEND})
+ set(QT_USE_IMPORTED_TARGETS TRUE) # Qt 4 only
+ set(QT_MIN_VERSION 4.6.0) # Qt 4 only
+
+-find_package(Qt5Core QUIET)
++if (WITH_QT5)
++ find_package(Qt5Core QUIET)
++endif()
++
+ if (Qt5Core_FOUND)
+ find_package(Qt5Gui REQUIRED)
+ find_package(Qt5Widgets REQUIRED)