summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-05-08 18:38:22 +0000
committerJohannes Huber <johu@gentoo.org>2013-05-08 18:38:22 +0000
commit9c3d855296b51b5245d9073aaadfb708ec62e229 (patch)
tree88d23b230e2bed5a66eb66521bad25611e0a3d96 /app-office/akonadi-server
parentMarked ~amd64-linux, bug #466374 (diff)
downloadgentoo-2-9c3d855296b51b5245d9073aaadfb708ec62e229.tar.gz
gentoo-2-9c3d855296b51b5245d9073aaadfb708ec62e229.tar.bz2
gentoo-2-9c3d855296b51b5245d9073aaadfb708ec62e229.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'app-office/akonadi-server')
-rw-r--r--app-office/akonadi-server/ChangeLog7
-rw-r--r--app-office/akonadi-server/akonadi-server-1.9.2.ebuild106
2 files changed, 112 insertions, 1 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index e8bffdc7c56b..ed1bfd82b3c1 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/akonadi-server
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.109 2013/04/03 08:01:11 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.110 2013/05/08 18:38:22 johu Exp $
+
+*akonadi-server-1.9.2 (08 May 2013)
+
+ 08 May 2013; Johannes Huber <johu@gentoo.org> +akonadi-server-1.9.2.ebuild:
+ Version bump.
03 Apr 2013; Michael Palimaka <kensington@gentoo.org>
-akonadi-server-1.8.0.ebuild, -akonadi-server-1.8.1.ebuild,
diff --git a/app-office/akonadi-server/akonadi-server-1.9.2.ebuild b/app-office/akonadi-server/akonadi-server-1.9.2.ebuild
new file mode 100644
index 000000000000..3869a45141b2
--- /dev/null
+++ b/app-office/akonadi-server/akonadi-server-1.9.2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.9.2.ebuild,v 1.1 2013/05/08 18:38:22 johu Exp $
+
+EAPI=5
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-2
+ EGIT_REPO_URI="git://anongit.kde.org/akonadi"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://kde/stable/${PN/-server/}/src/${P/-server/}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${P/-server/}"
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+DESCRIPTION="The server part of Akonadi"
+HOMEPAGE="http://pim.kde.org/akonadi"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="+mysql postgres sqlite test"
+
+CDEPEND="
+ dev-libs/boost:=
+ >=dev-libs/soprano-2.6.51
+ >=dev-qt/qtgui-4.5.0:4[dbus]
+ >=dev-qt/qtsql-4.5.0:4[mysql?,postgres?]
+ >=dev-qt/qttest-4.5.0:4
+ x11-misc/shared-mime-info
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ >=dev-util/automoc-0.9.88
+"
+RDEPEND="${CDEPEND}
+ postgres? ( dev-db/postgresql-server )
+"
+
+REQUIRED_USE="|| ( sqlite mysql postgres )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ # Set default storage backend in order: MySQL, SQLite PostgreSQL
+ # reverse driver check to keep the order
+ if use postgres; then
+ DRIVER="QPSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use sqlite; then
+ DRIVER="QSQLITE3"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use mysql; then
+ DRIVER="QMYSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ # Notify about MySQL is recommend by upstream
+ if use sqlite || has_version "<${CATEGORY}/${P}[sqlite]"; then
+ ewarn
+ ewarn "We strongly recommend you change your Akonadi database backend to MySQL in your"
+ ewarn "user configuration. This is the backend recommended by KDE upstream."
+ ewarn "In particular, kde-base/kmail-4.10 does not work properly with the sqlite"
+ ewarn "backend anymore."
+ ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "Available drivers are:${AVAILABLE}"
+ ewarn
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DAKONADI_USE_STRIGI_SEARCH=OFF
+ -DINSTALL_QSQLITE_IN_QT_PREFIX=ON
+ -DWITH_QT5=OFF
+ $(cmake-utils_use test AKONADI_BUILD_TESTS)
+ $(cmake-utils_use sqlite AKONADI_BUILD_QSQLITE)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+ elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are: ${AVAILABLE}"
+}