summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-03-25 12:44:35 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-03-25 12:44:35 +0000
commit9741c0e53da624dd01df48560a6e13d2584d5310 (patch)
tree9e4cde1be096ada00494e2c65b0efcef2c10723a /app-office/kmymoney2/kmymoney2-0.8.3-r1.ebuild
parentAdd HBCI online banking support to kmymoney2 (diff)
downloadgentoo-2-9741c0e53da624dd01df48560a6e13d2584d5310.tar.gz
gentoo-2-9741c0e53da624dd01df48560a6e13d2584d5310.tar.bz2
gentoo-2-9741c0e53da624dd01df48560a6e13d2584d5310.zip
Adding net banking support via from bug #110293
(Portage version: 2.0.54)
Diffstat (limited to 'app-office/kmymoney2/kmymoney2-0.8.3-r1.ebuild')
-rw-r--r--app-office/kmymoney2/kmymoney2-0.8.3-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-office/kmymoney2/kmymoney2-0.8.3-r1.ebuild b/app-office/kmymoney2/kmymoney2-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..5218a1dd753b
--- /dev/null
+++ b/app-office/kmymoney2/kmymoney2-0.8.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kmymoney2/kmymoney2-0.8.3-r1.ebuild,v 1.1 2006/03/25 12:44:35 caleb Exp $
+
+inherit kde
+
+DESCRIPTION="Personal Finances Manager for KDE."
+HOMEPAGE="http://kmymoney2.sourceforge.net"
+SRC_URI="mirror://sourceforge/kmymoney2/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="crypt ofx hbci"
+
+DEPEND="dev-libs/libxml2
+ hbci? ( >=net-libs/aqbanking-1.8.0_beta )
+ ofx? ( >=dev-libs/libofx-0.7 )"
+
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/gnupg )"
+
+need-kde 3.2
+
+# TODO: support maketest
+# (needs cppunit in DEPEND)
+
+pkg_setup() {
+ if use hbci && ! built_with_use net-libs/aqbanking kde; then
+ eerror "The HBCI plugin is shipped by net-libs/aqbanking,"
+ eerror "which has to be built with KDE support."
+ die "rebuild net-libs/aqbanking with USE=kde"
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_enable ofx ofxplugin)
+ $(use_enable hbci kbanking)
+ --disable-cppunit"
+
+ kde_src_compile
+}