summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-10-21 22:45:39 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-10-21 22:45:39 +0000
commitacbecfe18adfafea5841fca498749bf2a7ab4b49 (patch)
tree75b597b4cfedfd8fa5707ab77289f40859647390 /app-office/kmymoney
parentVersion bump, security bug #387637. (diff)
downloadgentoo-2-acbecfe18adfafea5841fca498749bf2a7ab4b49.tar.gz
gentoo-2-acbecfe18adfafea5841fca498749bf2a7ab4b49.tar.bz2
gentoo-2-acbecfe18adfafea5841fca498749bf2a7ab4b49.zip
Fix gnucash import, bug 384871
(Portage version: 2.1.10.29/cvs/Linux x86_64)
Diffstat (limited to 'app-office/kmymoney')
-rw-r--r--app-office/kmymoney/ChangeLog8
-rw-r--r--app-office/kmymoney/files/kmymoney-4.6.0-gnucash.patch19
-rw-r--r--app-office/kmymoney/kmymoney-4.6.0-r1.ebuild81
3 files changed, 107 insertions, 1 deletions
diff --git a/app-office/kmymoney/ChangeLog b/app-office/kmymoney/ChangeLog
index cbee7ebd46fa..2313eefa7902 100644
--- a/app-office/kmymoney/ChangeLog
+++ b/app-office/kmymoney/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kmymoney
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kmymoney/ChangeLog,v 1.21 2011/08/09 22:10:57 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kmymoney/ChangeLog,v 1.22 2011/10/21 22:45:39 dilfridge Exp $
+
+*kmymoney-4.6.0-r1 (21 Oct 2011)
+
+ 21 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kmymoney-4.6.0-r1.ebuild, +files/kmymoney-4.6.0-gnucash.patch:
+ Fix gnucash import, bug 384871
*kmymoney-4.6.0 (09 Aug 2011)
diff --git a/app-office/kmymoney/files/kmymoney-4.6.0-gnucash.patch b/app-office/kmymoney/files/kmymoney-4.6.0-gnucash.patch
new file mode 100644
index 000000000000..240ad186e9eb
--- /dev/null
+++ b/app-office/kmymoney/files/kmymoney-4.6.0-gnucash.patch
@@ -0,0 +1,19 @@
+diff -ruN kmymoney-4.6.0.orig/kmymoney/converter/mymoneygncreader.cpp kmymoney-4.6.0/kmymoney/converter/mymoneygncreader.cpp
+--- kmymoney-4.6.0.orig/kmymoney/converter/mymoneygncreader.cpp 2011-08-09 07:48:04.000000000 +0200
++++ kmymoney-4.6.0/kmymoney/converter/mymoneygncreader.cpp 2011-10-22 00:40:05.731618915 +0200
+@@ -1267,6 +1267,7 @@
+ if (bAnonymize) setFileHideFactor();
+ //m_defaultPayee = createPayee (i18n("Unknown payee"));
+
++ MyMoneyFile::instance()->attachStorage(m_storage);
+ MyMoneyFileTransaction ft;
+ m_xr = new XmlReader(this);
+ try {
+@@ -1277,6 +1278,7 @@
+ KMessageBox::error(0, i18n("Import failed:\n\n%1", e->what()), PACKAGE);
+ qWarning("%s", qPrintable(e->what()));
+ } // end catch
++ MyMoneyFile::instance()->detachStorage(m_storage);
+ signalProgress(0, 1, i18n("Import complete")); // switch off progress bar
+ delete m_xr;
+ qDebug("Exiting gnucash importer");
diff --git a/app-office/kmymoney/kmymoney-4.6.0-r1.ebuild b/app-office/kmymoney/kmymoney-4.6.0-r1.ebuild
new file mode 100644
index 000000000000..876bc5c87c49
--- /dev/null
+++ b/app-office/kmymoney/kmymoney-4.6.0-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kmymoney/kmymoney-4.6.0-r1.ebuild,v 1.1 2011/10/21 22:45:39 dilfridge Exp $
+
+EAPI=4
+
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et
+ eu fi fr ga gl hu it ja lt ms nds nl pl pt
+ pt_BR ro ru sk sv tr ug uk zh_CN zh_TW"
+ KDE_DOC_DIRS="doc doc-translations/%lingua_${PN}"
+ KDE_HANDBOOK="optional"
+ SRC_URI="mirror://sourceforge/kmymoney2/${P}.tar.bz2"
+fi
+
+VIRTUALX_REQUIRED=test
+
+inherit kde4-base
+
+DESCRIPTION="Personal finance manager for KDE"
+HOMEPAGE="http://kmymoney2.sourceforge.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug calendar doc hbci ofx quotes test"
+
+COMMON_DEPEND="
+ app-crypt/gpgme
+ >=app-office/libalkimia-4.3.1
+ dev-cpp/glibmm:2
+ dev-cpp/libxmlpp
+ dev-libs/boost
+ dev-libs/glib:2
+ dev-libs/gmp
+ dev-libs/libgpg-error
+ dev-libs/libxml2
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ calendar? ( dev-libs/libical )
+ hbci? (
+ >=net-libs/aqbanking-5.0.1
+ >=sys-libs/gwenhywfar-4.0.1[qt4]
+ )
+ ofx? ( >=dev-libs/libofx-0.9.4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ quotes? ( dev-perl/Finance-Quote )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.5.3-underlinking.patch"
+ "${FILESDIR}/${PN}-4.6.0-gnucash.patch"
+)
+
+src_configure() {
+ mycmakeargs=(
+ -DUSE_QT_DESIGNER=OFF
+ $(cmake-utils_use_enable calendar LIBICAL)
+ $(cmake-utils_use_use doc DEVELOPER_DOC)
+ $(cmake-utils_use_enable hbci KBANKING)
+ $(cmake-utils_use_enable ofx LIBOFX)
+ $(cmake-utils_use test KDE4_BUILD_TESTS)
+ )
+ kde4-base_src_configure
+}
+
+src_compile() {
+ kde4-base_src_compile
+ use doc && kde4-base_src_compile apidoc
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${CMAKE_BUILD_DIR}/apidocs/html/")
+ kde4-base_src_install
+}