summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-01-03 12:26:35 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-01-03 12:26:35 +0000
commitcd0b090f50afcd6b74fa5350aea8ba8a08107323 (patch)
tree2218abf0f059ccf3b26544907a65b42421f561bc /app-office/kmymoney
parentarm/sparc stable (bug 350410) (diff)
downloadgentoo-2-cd0b090f50afcd6b74fa5350aea8ba8a08107323.tar.gz
gentoo-2-cd0b090f50afcd6b74fa5350aea8ba8a08107323.tar.bz2
gentoo-2-cd0b090f50afcd6b74fa5350aea8ba8a08107323.zip
Version bump
(Portage version: 2.1.9.26/cvs/Linux i686)
Diffstat (limited to 'app-office/kmymoney')
-rw-r--r--app-office/kmymoney/ChangeLog10
-rw-r--r--app-office/kmymoney/kmymoney-4.5.2.ebuild76
2 files changed, 84 insertions, 2 deletions
diff --git a/app-office/kmymoney/ChangeLog b/app-office/kmymoney/ChangeLog
index 0be5d88d7564..ced7e2b5f34e 100644
--- a/app-office/kmymoney/ChangeLog
+++ b/app-office/kmymoney/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kmymoney
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kmymoney/ChangeLog,v 1.14 2010/11/11 23:54:50 dilfridge Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kmymoney/ChangeLog,v 1.15 2011/01/03 12:26:35 dilfridge Exp $
+
+*kmymoney-4.5.2 (03 Jan 2011)
+
+ 03 Jan 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kmymoney-4.5.2.ebuild:
+ Version bump
*kmymoney-4.5-r2 (11 Nov 2010)
diff --git a/app-office/kmymoney/kmymoney-4.5.2.ebuild b/app-office/kmymoney/kmymoney-4.5.2.ebuild
new file mode 100644
index 000000000000..b58f3da4e39a
--- /dev/null
+++ b/app-office/kmymoney/kmymoney-4.5.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kmymoney/kmymoney-4.5.2.ebuild,v 1.1 2011/01/03 12:26:35 dilfridge Exp $
+
+EAPI=3
+
+KMNAME="extragear/office"
+
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="bg ca ca@valencia cs da de el en_GB eo es et fi fr ga gl hu it lt
+ ms nds nl pl pt pt_BR ro ru sk sv tr uk zh_CN zh_TW"
+ KDE_DOC_DIRS="doc doc-translations/%lingua_${PN}"
+ KDE_HANDBOOK="optional"
+ SRC_URI="mirror://sourceforge/kmymoney2/${P}.tar.bz2
+ mirror://gentoo/${P}-aqbanking-5_x.patch.bz2"
+fi
+
+inherit virtualx kde4-base
+
+DESCRIPTION="A personal finance manager for KDE"
+HOMEPAGE="http://kmymoney2.sourceforge.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug calendar doc hbci ofx quotes test"
+
+COMMON_DEPEND="
+ app-crypt/gpgme
+ >=dev-libs/boost-1.33.1
+ dev-libs/libgpg-error
+ dev-libs/libxml2
+ $(add_kdebase_dep kdepimlibs)
+ calendar? ( dev-libs/libical )
+ hbci? (
+ >=net-libs/aqbanking-5.0.1
+ >=sys-libs/gwenhywfar-4.0.1[qt4]
+ )
+ ofx? ( >=dev-libs/libofx-0.9.1 )
+"
+RDEPEND="${COMMON_DEPEND}
+ quotes? ( >=dev-perl/Finance-Quote-1.17 )
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( >=dev-util/cppunit-1.12.1 )
+"
+
+PATCHES=( "${WORKDIR}/${P}"-aqbanking-5_x.patch )
+
+src_configure() {
+ mycmakeargs=(
+ -DUSE_QT_DESIGNER=OFF
+ $(cmake-utils_use_enable calendar LIBICAL)
+ $(cmake-utils_use_use doc DEVELOPER_DOC)
+ $(cmake-utils_use_enable hbci KBANKING)
+ $(cmake-utils_use_enable ofx LIBOFX)
+ $(cmake-utils_use test KDE4_BUILD_TESTS)
+ )
+ kde4-base_src_configure
+}
+
+src_compile() {
+ kde4-base_src_compile
+ use doc && kde4-base_src_compile apidoc
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${CMAKE_BUILD_DIR}/apidocs/html/")
+ kde4-base_src_install
+}
+
+src_test() {
+ export maketype="kde4-base_src_test"
+ virtualmake
+}