summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-08 12:33:26 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-08 12:33:26 +0000
commit84ccee17e5fd544e116814522dad046219c45a76 (patch)
tree0780bace4a8a2da0a8f4432019b5e5dd17229fe2 /app-office/libreoffice
parentVersion bump, closing bug #382189 (diff)
downloadgentoo-2-84ccee17e5fd544e116814522dad046219c45a76.tar.gz
gentoo-2-84ccee17e5fd544e116814522dad046219c45a76.tar.bz2
gentoo-2-84ccee17e5fd544e116814522dad046219c45a76.zip
Fix the case of passing without-system-libs when using -java.
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/ChangeLog7
-rw-r--r--app-office/libreoffice/files/libreoffice-java.patch52
-rw-r--r--app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild6
-rw-r--r--app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild6
-rw-r--r--app-office/libreoffice/libreoffice-9999-r1.ebuild6
5 files changed, 64 insertions, 13 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 31a4d9c41a45..4414f3fc4f81 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.129 2011/09/06 13:07:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.130 2011/09/08 12:33:26 scarabeus Exp $
+
+ 08 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ libreoffice-3.4.3.2-r1.ebuild, libreoffice-3.4.9999-r1.ebuild,
+ libreoffice-9999-r1.ebuild, +files/libreoffice-java.patch:
+ Fix the case of passing without-system-libs when using -java.
06 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
libreoffice-3.4.3.2-r1.ebuild, libreoffice-3.4.9999-r1.ebuild,
diff --git a/app-office/libreoffice/files/libreoffice-java.patch b/app-office/libreoffice/files/libreoffice-java.patch
new file mode 100644
index 000000000000..ac5b394de356
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-java.patch
@@ -0,0 +1,52 @@
+diff --git a/configure.in b/configure.in
+index 1dc00d4..262fe00 100755
+--- a/configure.in
++++ b/configure.in
+@@ -4962,6 +4962,7 @@ AC_SUBST(DB_CPPLIB)
+ dnl ===================================================================
+ dnl Check for system lucene
+ dnl ===================================================================
++if test "$with_java" != "no"; then
+ AC_MSG_CHECKING([which lucene to use])
+ if test -n "$with_system_lucene" -o -n "$with_system_libs" && \
+ test "$with_system_lucene" != "no" && test "$with_system_jars" != "no"; then
+@@ -5021,6 +5022,7 @@ else
+ SYSTEM_LUCENE=NO
+ BUILD_TYPE="$BUILD_TYPE LUCENE"
+ fi
++fi
+ AC_SUBST(SYSTEM_LUCENE)
+ AC_SUBST(LUCENE_CORE_JAR)
+ AC_SUBST(LUCENE_ANALYZERS_JAR)
+@@ -5189,6 +5191,7 @@ AC_SUBST(HSQLDB_JAR)
+ dnl ===================================================================
+ dnl Check for system beanshell
+ dnl ===================================================================
++if test "$with_java" != "no"; then
+ AC_MSG_CHECKING([which beanshell to use])
+ if test -n "$with_system_beanshell" -o -n "$with_system_libs" && \
+ test "$with_system_beanshell" != "no" && test "$with_system_jars" != "no"; then
+@@ -5204,6 +5207,7 @@ else
+ SYSTEM_BSH=NO
+ BUILD_TYPE="$BUILD_TYPE BSH"
+ fi
++fi
+ AC_SUBST(SYSTEM_BSH)
+ AC_SUBST(BSH_JAR)
+
+@@ -5211,6 +5215,7 @@ AC_SUBST(BSH_JAR)
+ dnl ===================================================================
+ dnl Check for system saxon
+ dnl ===================================================================
++if test "$with_java" != "no"; then
+ AC_MSG_CHECKING([which saxon to use])
+ if test -n "$with_system_saxon" -o -n "$with_system_libs" && \
+ test "$with_system_saxon" != "no" && test "$with_system_jars" != "no"; then
+@@ -5310,6 +5315,7 @@ else
+ SYSTEM_SAXON=NO
+ NEED_SAXON=TRUE
+ fi
++fi
+ AC_SUBST(SYSTEM_SAXON)
+ AC_SUBST(SAXON_JAR)
+
diff --git a/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild b/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild
index cf6faf4fbfb0..f8b3c46341cf 100644
--- a/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild
+++ b/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild,v 1.6 2011/09/06 13:07:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild,v 1.7 2011/09/08 12:33:26 scarabeus Exp $
EAPI=3
@@ -227,6 +227,7 @@ PATCHES=(
"${FILESDIR}/${PN}-binfilter-as-needed.patch"
"${FILESDIR}/${PN}-kill-cppunit.patch"
"${FILESDIR}/${PN}-honor-strip.patch"
+ "${FILESDIR}/${PN}-java.patch"
)
# Uncoment me when updating to eapi4
@@ -389,9 +390,6 @@ src_configure() {
# as internal libraries.
if ! use java; then
internal_libs+="
- --without-system-beanshell
- --without-system-lucene
- --without-system-saxon
--without-junit
"
else
diff --git a/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild b/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild
index 53d7c26eda28..7a7d3ba4eafe 100644
--- a/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild
+++ b/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild,v 1.6 2011/09/06 13:07:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild,v 1.7 2011/09/08 12:33:26 scarabeus Exp $
EAPI=3
@@ -227,6 +227,7 @@ PATCHES=(
"${FILESDIR}/${PN}-binfilter-as-needed.patch"
"${FILESDIR}/${PN}-kill-cppunit.patch"
"${FILESDIR}/${PN}-honor-strip.patch"
+ "${FILESDIR}/${PN}-java.patch"
)
# Uncoment me when updating to eapi4
@@ -389,9 +390,6 @@ src_configure() {
# as internal libraries.
if ! use java; then
internal_libs+="
- --without-system-beanshell
- --without-system-lucene
- --without-system-saxon
--without-junit
"
else
diff --git a/app-office/libreoffice/libreoffice-9999-r1.ebuild b/app-office/libreoffice/libreoffice-9999-r1.ebuild
index cc3a1f032091..abe8a8afe9bb 100644
--- a/app-office/libreoffice/libreoffice-9999-r1.ebuild
+++ b/app-office/libreoffice/libreoffice-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r1.ebuild,v 1.5 2011/09/05 17:01:17 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r1.ebuild,v 1.6 2011/09/08 12:33:26 scarabeus Exp $
EAPI=3
@@ -217,6 +217,7 @@ PATCHES=(
"${FILESDIR}/${PN}-installed-files-permissions.patch"
"${FILESDIR}/${PN}-binfilter-as-needed.patch"
"${FILESDIR}/${PN}-kill-cppunit.patch"
+ "${FILESDIR}/${PN}-java.patch"
)
# Uncoment me when updating to eapi4
@@ -379,9 +380,6 @@ src_configure() {
# as internal libraries.
if ! use java; then
internal_libs+="
- --without-system-beanshell
- --without-system-lucene
- --without-system-saxon
--without-junit
"
else