summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-30 10:09:16 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-30 10:09:16 +0000
commitbcbf6940caa90db98db4f8f713e2d1df5adf3c7f (patch)
tree6f0f2bbebcb6117fd0bd61b7dc7ae76b289cc8da /app-office/libreoffice
parentInitial import (bug #104244). (diff)
downloadgentoo-2-bcbf6940caa90db98db4f8f713e2d1df5adf3c7f.tar.gz
gentoo-2-bcbf6940caa90db98db4f8f713e2d1df5adf3c7f.tar.bz2
gentoo-2-bcbf6940caa90db98db4f8f713e2d1df5adf3c7f.zip
Add another patch to fix poppler for good.
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/ChangeLog7
-rw-r--r--app-office/libreoffice/files/libreoffice-poppler-0.18.0-2.patch33
-rw-r--r--app-office/libreoffice/files/libreoffice-poppler-0.18.0.patch66
-rw-r--r--app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild3
4 files changed, 93 insertions, 16 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index e44f14e6b5dc..46ff82b990b9 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.154 2011/09/30 08:25:53 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.155 2011/09/30 10:09:16 scarabeus Exp $
+
+ 30 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/libreoffice-poppler-0.18.0-2.patch,
+ files/libreoffice-poppler-0.18.0.patch, libreoffice-3.4.3.2-r1.ebuild:
+ Add another patch to fix poppler for good.
30 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
libreoffice-9999-r1.ebuild:
diff --git a/app-office/libreoffice/files/libreoffice-poppler-0.18.0-2.patch b/app-office/libreoffice/files/libreoffice-poppler-0.18.0-2.patch
new file mode 100644
index 000000000000..d627f9c9b1fb
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-poppler-0.18.0-2.patch
@@ -0,0 +1,33 @@
+From 9540db43f3f1b11d3407a45aefda235d7e78f76b Mon Sep 17 00:00:00 2001
+From: Caolán McNamara <caolanm@redhat.com>
+Date: Fri, 02 Sep 2011 12:15:49 +0000
+Subject: Resolves: rhbz#735182 libreoffice doesn't build with poppler-0.17.3
+
+---
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+index 5022dd5..bd6d721 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+@@ -150,7 +150,11 @@ void writeBinaryBuffer( const OutputBuffer& rBuffer )
+ void writeJpeg_( OutputBuffer& o_rOutputBuf, Stream* str, bool bWithLinefeed )
+ {
+ // dump JPEG file as-is
++#if POPPLER_CHECK_VERSION(0, 17, 3)
++ str = str->getBaseStream();
++#else
+ str = ((DCTStream *)str)->getRawStream();
++#endif
+ str->reset();
+
+ int c;
+@@ -490,7 +494,7 @@ void PDFOutDev::endPage()
+ }
+
+ #if POPPLER_CHECK_VERSION(0, 17, 0)
+-void PDFOutDev::processLink(AnnotLink *link, Catalog *catalog)
++void PDFOutDev::processLink(AnnotLink *link, Catalog *)
+ #else
+ void PDFOutDev::processLink(Link* link, Catalog*)
+ #endif
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/app-office/libreoffice/files/libreoffice-poppler-0.18.0.patch b/app-office/libreoffice/files/libreoffice-poppler-0.18.0.patch
index 87fbe41c48fd..819deaf29e14 100644
--- a/app-office/libreoffice/files/libreoffice-poppler-0.18.0.patch
+++ b/app-office/libreoffice/files/libreoffice-poppler-0.18.0.patch
@@ -1,24 +1,62 @@
-From 91313fc05abbfe35ee1e0c2464a28dd580780f07 Mon Sep 17 00:00:00 2001
-From: Caolán McNamara <caolanm@redhat.com>
-Date: Fri, 02 Sep 2011 12:15:49 +0000
-Subject: Resolves: rhbz#735182 libreoffice doesn't build with poppler-0.17.3
+From 53e66aea4c1b3617363fd138a7903190d964da6b Mon Sep 17 00:00:00 2001
+From: Tomáš Chvátal <tchvatal@suse.cz>
+Date: Fri, 30 Sep 2011 09:51:04 +0000
+Subject: This is merge of f6f8f67460bba296c49f794d14621b7313df4f7d.
+
+It is not posible to git-am due to merge to core/ repository.
+It had one minor collision on pdfioutdev_gpl.hxx.
+Orginal header:
+From f6f8f67460bba296c49f794d14621b7313df4f7d Mon Sep 17 00:00:00 2001
+From: Caolán McNamara <caolanm@redhat.com>
+Date: Tue, 19 Jul 2011 07:54:07 +0000
+Subject: poppler 0.17.0 changed its api for no some reason or other
---
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
-index cf28922..3f1261c 100644
+index f7741b4..5022dd5 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
-@@ -150,7 +150,11 @@ void writeBinaryBuffer( const OutputBuffer& rBuffer )
- void writeJpeg_( OutputBuffer& o_rOutputBuf, Stream* str, bool bWithLinefeed )
- {
- // dump JPEG file as-is
-+#if POPPLER_CHECK_VERSION(0, 17, 3)
-+ str = str->getBaseStream();
+@@ -489,7 +489,11 @@ void PDFOutDev::endPage()
+ printf("endPage\n");
+ }
+
++#if POPPLER_CHECK_VERSION(0, 17, 0)
++void PDFOutDev::processLink(AnnotLink *link, Catalog *catalog)
+#else
- str = ((DCTStream *)str)->getRawStream();
+ void PDFOutDev::processLink(Link* link, Catalog*)
+#endif
- str->reset();
+ {
+ assert(link);
+
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+index 3ac0f49..8a1708c 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+@@ -65,7 +65,10 @@ class GfxPath;
+ class GfxFont;
+ class PDFDoc;
+ #ifndef SYSTEM_POPPLER
++#define POPPLER_CHECK_VERSION(major,minor,micro) (0)
+ typedef GString GooString;
++#else
++#include <glib/poppler-features.h>
+ #endif
- int c;
+ namespace pdfi
+@@ -193,9 +196,13 @@ namespace pdfi
+ // Convert between device and user coordinates.
+ // virtual void cvtDevToUser(double dx, double dy, double *ux, double *uy);
+ // virtual void cvtUserToDev(double ux, double uy, int *dx, int *dy);
+-
++
++ #if POPPLER_CHECK_VERSION(0, 17, 0)
++ virtual void processLink(AnnotLink *link, Catalog *catalog);
++ #else
+ //----- link borders
+ virtual void processLink(Link *link, Catalog *catalog);
++ #endif
+
+ //----- save/restore graphics state
+ virtual void saveState(GfxState *state);
--
cgit v0.9.0.2-2-gbebe
diff --git a/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild b/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild
index 677423bd0d0a..032d316bdbba 100644
--- a/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild
+++ b/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild,v 1.8 2011/09/29 13:42:10 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild,v 1.9 2011/09/30 10:09:16 scarabeus Exp $
EAPI=3
@@ -229,6 +229,7 @@ PATCHES=(
"${FILESDIR}/${PN}-honor-strip.patch"
"${FILESDIR}/${PN}-java.patch"
"${FILESDIR}/${PN}-poppler-0.18.0.patch"
+ "${FILESDIR}/${PN}-poppler-0.18.0-2.patch"
)
# Uncoment me when updating to eapi4