summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-08 16:31:23 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-08 16:31:23 +0000
commite6c122340f0bf882e6230e2e86d102dd6f0902fb (patch)
tree8540c618ea8489a8c656aebd7a5e86f90037ef85 /app-office/libreoffice
parentIntroducing a new, simplified eclass for bash-completion. (diff)
downloadgentoo-2-e6c122340f0bf882e6230e2e86d102dd6f0902fb.tar.gz
gentoo-2-e6c122340f0bf882e6230e2e86d102dd6f0902fb.tar.bz2
gentoo-2-e6c122340f0bf882e6230e2e86d102dd6f0902fb.zip
Use bashcomp-r1 eclass instead of old one.
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/ChangeLog6
-rw-r--r--app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild6
-rw-r--r--app-office/libreoffice/libreoffice-9999-r1.ebuild6
3 files changed, 11 insertions, 7 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 4414f3fc4f81..d21ee1ce634d 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.130 2011/09/08 12:33:26 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.131 2011/09/08 16:31:23 scarabeus Exp $
+
+ 08 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ libreoffice-3.4.9999-r1.ebuild, libreoffice-9999-r1.ebuild:
+ Use bashcomp-r1 eclass instead of old one.
08 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
libreoffice-3.4.3.2-r1.ebuild, libreoffice-3.4.9999-r1.ebuild,
diff --git a/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild b/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild
index 7a7d3ba4eafe..91c8e0353815 100644
--- a/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild
+++ b/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild,v 1.7 2011/09/08 12:33:26 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild,v 1.8 2011/09/08 16:31:23 scarabeus Exp $
EAPI=3
@@ -25,7 +25,7 @@ ADDONS_URI="http://dev-www.libreoffice.org/src/"
BRANDING="${PN}-branding-gentoo-0.3.tar.xz"
[[ ${PV} == *9999* ]] && SCM_ECLASS="git-2"
-inherit base autotools bash-completion check-reqs eutils java-pkg-opt-2 kde4-base pax-utils prefix python multilib toolchain-funcs flag-o-matic nsplugins versionator ${SCM_ECLASS}
+inherit base autotools bash-completion-r1 check-reqs eutils java-pkg-opt-2 kde4-base pax-utils prefix python multilib toolchain-funcs flag-o-matic nsplugins versionator ${SCM_ECLASS}
unset SCM_ECLASS
DESCRIPTION="LibreOffice, a full office productivity suite."
@@ -529,7 +529,7 @@ src_install() {
make DESTDIR="${D}" distro-pack-install || die
# Fix bash completion placement
- dobashcompletion "${ED}"/etc/bash_completion.d/libreoffice.sh ${PN}
+ newbashcomp "${ED}"/etc/bash_completion.d/libreoffice.sh ${PN}
rm -rf "${ED}"/etc/
# symlink the plugin to system location
diff --git a/app-office/libreoffice/libreoffice-9999-r1.ebuild b/app-office/libreoffice/libreoffice-9999-r1.ebuild
index abe8a8afe9bb..26b6a179158d 100644
--- a/app-office/libreoffice/libreoffice-9999-r1.ebuild
+++ b/app-office/libreoffice/libreoffice-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r1.ebuild,v 1.6 2011/09/08 12:33:26 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r1.ebuild,v 1.7 2011/09/08 16:31:23 scarabeus Exp $
EAPI=3
@@ -25,7 +25,7 @@ ADDONS_URI="http://dev-www.libreoffice.org/src/"
BRANDING="${PN}-branding-gentoo-0.3.tar.xz"
[[ ${PV} == *9999* ]] && SCM_ECLASS="git-2"
-inherit base autotools bash-completion check-reqs eutils java-pkg-opt-2 kde4-base pax-utils prefix python multilib toolchain-funcs flag-o-matic nsplugins ${SCM_ECLASS}
+inherit base autotools bash-completion-r1 check-reqs eutils java-pkg-opt-2 kde4-base pax-utils prefix python multilib toolchain-funcs flag-o-matic nsplugins ${SCM_ECLASS}
unset SCM_ECLASS
DESCRIPTION="LibreOffice, a full office productivity suite."
@@ -519,7 +519,7 @@ src_install() {
make DESTDIR="${D}" distro-pack-install || die
# Fix bash completion placement
- dobashcompletion "${ED}"/etc/bash_completion.d/libreoffice.sh ${PN}
+ newbashcomp "${ED}"/etc/bash_completion.d/libreoffice.sh ${PN}
rm -rf "${ED}"/etc/
# symlink the plugin to system location