summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-10-29 22:20:37 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-10-29 22:20:37 +0000
commit1ea8eed0e9bef0144707599670f598f54fe8d23c (patch)
tree25ffcb2d07f7a135e500f686477df895572950d6 /app-office/ooqstart-gnome/ooqstart-gnome-0.8.3-r1.ebuild
parentOld-style PHP update, fixes a couple of bugs. (diff)
downloadgentoo-2-1ea8eed0e9bef0144707599670f598f54fe8d23c.tar.gz
gentoo-2-1ea8eed0e9bef0144707599670f598f54fe8d23c.tar.bz2
gentoo-2-1ea8eed0e9bef0144707599670f598f54fe8d23c.zip
update for openoffice 2.0
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'app-office/ooqstart-gnome/ooqstart-gnome-0.8.3-r1.ebuild')
-rw-r--r--app-office/ooqstart-gnome/ooqstart-gnome-0.8.3-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-office/ooqstart-gnome/ooqstart-gnome-0.8.3-r1.ebuild b/app-office/ooqstart-gnome/ooqstart-gnome-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..b6528bf52f2d
--- /dev/null
+++ b/app-office/ooqstart-gnome/ooqstart-gnome-0.8.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/ooqstart-gnome/ooqstart-gnome-0.8.3-r1.ebuild,v 1.1 2005/10/29 22:20:37 suka Exp $
+
+inherit eutils
+
+DESCRIPTION="OpenOffice.org Quickstarter Applet for Gnome 2.x"
+HOMEPAGE="http://ooqstart.sourceforge.net/"
+MY_P="ooqstart-${PV}"
+SRC_URI="mirror://sourceforge/ooqstart/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+SLOT="0"
+
+RDEPEND=">=virtual/ooo-2.0.0
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-panel-2
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gnome2update-2.0.patch.bz2
+ epatch ${FILESDIR}/${P}-gcc4.patch
+ epatch ${FILESDIR}/${P}-options-2.0.diff
+ epatch ${FILESDIR}/${P}-optflags.diff
+}
+
+src_install() {
+ make ROOT=${D} install-gnome || die
+}
+
+pkg_postinst() {
+ einfo " If you are you using openoffice-bin-2.0.0 and don't get any icons, "
+ einfo " please re-merge openoffice-bin, there have recently been some "
+ einfo " modifications to it, which solve this. "
+}