summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2007-09-04 21:09:27 +0000
committerAndreas Proschofsky <suka@gentoo.org>2007-09-04 21:09:27 +0000
commit7fb3d1b7c19fc4c3424700985c26cae10d957af4 (patch)
tree14edcabfd1981ca75a04ed7e146a0ba40e61ee79 /app-office/openoffice-bin
parentDon't pull in python-fchksum when the build flag is enabled since otherwise i... (diff)
downloadgentoo-2-7fb3d1b7c19fc4c3424700985c26cae10d957af4.tar.gz
gentoo-2-7fb3d1b7c19fc4c3424700985c26cae10d957af4.tar.bz2
gentoo-2-7fb3d1b7c19fc4c3424700985c26cae10d957af4.zip
Get rid of the wrapper script
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-office/openoffice-bin')
-rw-r--r--app-office/openoffice-bin/ChangeLog7
-rwxr-xr-xapp-office/openoffice-bin/files/2.3.0_rc1/ooo-wrapper2122
-rw-r--r--app-office/openoffice-bin/files/50-openoffice-bin (renamed from app-office/openoffice-bin/files/2.3.0_rc1/50-openoffice-bin)0
-rw-r--r--app-office/openoffice-bin/openoffice-bin-2.3.0_rc1.ebuild18
4 files changed, 13 insertions, 134 deletions
diff --git a/app-office/openoffice-bin/ChangeLog b/app-office/openoffice-bin/ChangeLog
index a60ba1f90405..47edc14528de 100644
--- a/app-office/openoffice-bin/ChangeLog
+++ b/app-office/openoffice-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/openoffice-bin
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.170 2007/09/04 19:17:13 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.171 2007/09/04 21:09:27 suka Exp $
+
+ 04 Sep 2007; Andreas Proschofsky <suka@gentoo.org>
+ -files/2.3.0_rc1/50-openoffice-bin, -files/2.3.0_rc1/ooo-wrapper2,
+ +files/50-openoffice-bin, openoffice-bin-2.3.0_rc1.ebuild:
+ Get rid of the wrapper script
*openoffice-bin-2.3.0_rc1 (04 Sep 2007)
diff --git a/app-office/openoffice-bin/files/2.3.0_rc1/ooo-wrapper2 b/app-office/openoffice-bin/files/2.3.0_rc1/ooo-wrapper2
deleted file mode 100755
index 2e3893f5d788..000000000000
--- a/app-office/openoffice-bin/files/2.3.0_rc1/ooo-wrapper2
+++ /dev/null
@@ -1,122 +0,0 @@
-#!/usr/bin/perl -w
-#*****************************************************************************
-#
-# ooffice - Wrapper script for OpenOffice.org
-#
-# Based on the Mandrake work.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License version 2, as
-# published by the Free Software Foundation.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-#
-#*****************************************************************************
-
-use strict;
-use IO::Handle;
-use Fcntl ':flock';
-
-my $Debug = $ENV{OOO_DEBUG};
-
-# Define the vendor of this particular OOo package
-my $VendorName = 'Gentoo';
-# Define system installation directory
-# Autoconf totally sucks for @libdir@ type substitution
-my $SystemInstallDir = 'INSTDIR';
-# Suffix for parallel installable versioning
-my $BinSuffix = '';
-# ooo-build version
-my $OOO_BUILDVERSION = 'PV';
-
-#=============================================================================
-# Main
-#=============================================================================
-
-# Parse command line arguments
-my @ooo_argv;
-my $session_quickstart;
-my $widgets_set;
-while ($ARGV[0]) {
- $_ = shift;
- if (m/^--session-quickstart/) {
- $session_quickstart = 1;
- } elsif (m/^--widgets-set/) {
- $widgets_set = shift;
- (defined $widgets_set) || die "Error: The option --widgets-set requires a value\n" .
- "For example: --widgets-set gtk\n";
- } elsif (m/^--version/) {
- print "This is OpenOffice.org $OOO_BUILDVERSION\n";
- exit 0;
- } else {
- push @ooo_argv, $_;
- }
-}
-
-if (!@ooo_argv) {
- my $arg;
- if ($0 =~ m/\/oo(calc|draw|impress|math|web|writer|base)$BinSuffix$/) {
- $arg = "-$1";
- } elsif ($0 =~ m/\/oofromtemplate$BinSuffix$/) {
- $arg = "slot:5500";
- }
-
- if ($arg) {
- push @ooo_argv, "$arg";
- $Debug && print "Append arg: $arg\n";
- }
-} else {
- $Debug && print "Ignoring type - since have filenames\n";
-}
-
-if (defined $widgets_set) {
- $ENV{SAL_USE_VCLPLUGIN} = $widgets_set;
-}
-
-# overcome ghastly up-stream evilness
-$ENV{SAL_NOEXPANDFPICKER}='TRUE';
-
-if ($session_quickstart) {
- $Debug && print "Execute quickstarter\n";
- push @ooo_argv, '-quickstart';
-}
-
-# FIXME: the following two fixes should be done by OOo itself
-# create the user config directory with safe rights 700 if it we find
-# the right path and the directory does not exist
-if (open BOOTSTRAPRC, "$SystemInstallDir/program/bootstraprc") {
- while (my $line = <BOOTSTRAPRC>) {
- chomp $line;
- if (($line =~ m/^\s*UserInstallation\s*=\s*([^\s]*)\s*$/) && ($1)) {
- my $userConfDir=$1;
- $userConfDir =~ s|\$SYSUSERCONFIG|$ENV{HOME}|;
- $userConfDir =~ s|file://||;
- mkdir ($userConfDir,0700) unless (-d $userConfDir);
- last;
- }
- }
- close BOOTSTRAPRC;
-}
-# touch ~/.recently-used with safe rights 700 if it does not exist
-if (! -f "$ENV{HOME}/.recently-used") {
- open (RECENTLY_USED, ">$ENV{HOME}/.recently-used") &&
- close RECENTLY_USED &&
- chmod 0600, "$ENV{HOME}/.recently-used";
-}
-
-if (!(-f '/proc/version')) {
- print STDERR "\n\n --- Warning - OO.o will not work without a mounted /proc filesystem --- \n\n\n";
-}
-
-# Clear PYTHONPATH, otherwise Python scripting does not work
-delete $ENV{'PYTHONPATH'};
-
-# And here we go.
-exec "$SystemInstallDir/program/soffice", @ooo_argv
diff --git a/app-office/openoffice-bin/files/2.3.0_rc1/50-openoffice-bin b/app-office/openoffice-bin/files/50-openoffice-bin
index 6b16e47f0187..6b16e47f0187 100644
--- a/app-office/openoffice-bin/files/2.3.0_rc1/50-openoffice-bin
+++ b/app-office/openoffice-bin/files/50-openoffice-bin
diff --git a/app-office/openoffice-bin/openoffice-bin-2.3.0_rc1.ebuild b/app-office/openoffice-bin/openoffice-bin-2.3.0_rc1.ebuild
index f370adaa5ff2..1011a76c6b7e 100644
--- a/app-office/openoffice-bin/openoffice-bin-2.3.0_rc1.ebuild
+++ b/app-office/openoffice-bin/openoffice-bin-2.3.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-2.3.0_rc1.ebuild,v 1.1 2007/09/04 19:17:13 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-2.3.0_rc1.ebuild,v 1.2 2007/09/04 21:09:27 suka Exp $
inherit eutils fdo-mime rpm multilib
@@ -108,17 +108,14 @@ src_install () {
insinto /usr/share/mime/packages
doins ${WORKDIR}/usr/share/mime/packages/openoffice.org.xml
- # Install wrapper script
- newbin ${FILESDIR}/${PV}/ooo-wrapper2 ooffice
- sed -i -e s/PV/${PV}/g ${D}/usr/bin/ooffice || die
- sed -i -e "s|INSTDIR|${INSTDIR}|g" ${D}/usr/bin/ooffice || die
-
# Component symlinks
- for app in base calc draw fromtemplate impress math web writer; do
- dosym ooffice /usr/bin/oo${app}
+ for app in base calc draw impress math writer; do
+ dosym ${INSTDIR}/program/s${app} /usr/bin/oo${app}
done
dosym ${INSTDIR}/program/spadmin.bin /usr/bin/ooffice-printeradmin
+ dosym ${INSTDIR}/program/soffice /usr/bin/soffice
+ dosym ${INSTDIR}/program/soffice.bin /usr/bin/ooffice
# Change user install dir
sed -i -e s/.openoffice.org2/.ooo-2.0/g ${D}${INSTDIR}/program/bootstraprc || die
@@ -130,7 +127,7 @@ src_install () {
rm -f ${D}${INSTDIR}/share/dict/ooo/*
# prevent revdep-rebuild from attempting to rebuild all the time
- insinto /etc/revdep-rebuild && doins ${FILESDIR}/${PV}/50-openoffice-bin
+ insinto /etc/revdep-rebuild && doins ${FILESDIR}/50-openoffice-bin
}
@@ -149,8 +146,7 @@ pkg_postinst() {
elog
elog " Also, for individual components, you can use any of:"
elog
- elog " oobase, oocalc, oodraw, oofromtemplate, ooimpress, oomath,"
- elog " ooweb or oowriter"
+ elog " oobase, oocalc, oodraw, ooimpress, oomath, or oowriter"
elog
elog " Spell checking is now provided through our own myspell-ebuilds, "
elog " if you want to use it, please install the correct myspell package "