summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2004-11-15 14:53:54 +0000
committerAndreas Proschofsky <suka@gentoo.org>2004-11-15 14:53:54 +0000
commitbbac95fba48202ff4a2574e7cd23ef86118e9a35 (patch)
treebb399e119e1ec954909fa067d4ddf966bd5fd831 /app-office/openoffice-ximian
parentFixed typo in einfo, was "but not mail was every delivered", now is "but not ... (diff)
downloadgentoo-2-bbac95fba48202ff4a2574e7cd23ef86118e9a35.tar.gz
gentoo-2-bbac95fba48202ff4a2574e7cd23ef86118e9a35.tar.bz2
gentoo-2-bbac95fba48202ff4a2574e7cd23ef86118e9a35.zip
Use toolchains-func.eclass instead of gcc.eclass
Diffstat (limited to 'app-office/openoffice-ximian')
-rw-r--r--app-office/openoffice-ximian/ChangeLog7
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild13
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.3.5-r1.ebuild13
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.3.6.ebuild13
4 files changed, 18 insertions, 28 deletions
diff --git a/app-office/openoffice-ximian/ChangeLog b/app-office/openoffice-ximian/ChangeLog
index c79289ee2c4b..7ab5a797f02a 100644
--- a/app-office/openoffice-ximian/ChangeLog
+++ b/app-office/openoffice-ximian/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/openoffice-ximian
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.82 2004/11/14 10:32:29 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.83 2004/11/15 14:53:54 suka Exp $
+
+ 15 Nov 2004; Andreas Proschofsky <suka@gentoo.org>
+ openoffice-ximian-1.1.55.ebuild, openoffice-ximian-1.3.5-r1.ebuild,
+ openoffice-ximian-1.3.6.ebuild:
+ Use toolchain-funcs.eclass instead of gcc.eclass
*openoffice-ximian-1.3.6 (14 Nov 2004)
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild
index 9645dacd85aa..ebd09e7938e5 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild,v 1.20 2004/11/11 23:34:06 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild,v 1.21 2004/11/15 14:53:54 suka Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -26,7 +26,7 @@
# Get support going for installing a custom language pack. Also
# need to be able to install more than one language pack.
-inherit flag-o-matic eutils gcc
+inherit flag-o-matic eutils toolchain-funcs
IUSE="gnome kde"
@@ -174,11 +174,6 @@ oo_setup() {
unset LANG
unset LC_ALL
- # We want gcc3 if possible!!!!
- export WANT_GCC_3="yes"
-
- export NEW_GCC="0"
-
if [ -x /usr/sbin/gcc-config ]
then
# Do we have a gcc that use the new layout and gcc-config ?
@@ -340,8 +335,8 @@ src_compile() {
if [ -z "$(grep 'CCCOMP' ${S}/${LinuxEnvSet})" ]
then
# Set CCCOMP and CXXCOMP. This is still needed for STLport
- export CCCOMP="$(gcc-getCC)"
- export CXXCOMP="$(gcc-getCXX)"
+ export CCCOMP="$(tc-getCC)"
+ export CXXCOMP="$(tc-getCXX)"
fi
einfo "Bootstrapping OpenOffice.org..."
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.3.5-r1.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.3.5-r1.ebuild
index 4c59dcf70a1c..575ae785fad5 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.3.5-r1.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.5-r1.ebuild,v 1.6 2004/11/11 23:34:06 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.5-r1.ebuild,v 1.7 2004/11/15 14:53:54 suka Exp $
# Notes:
#
@@ -24,7 +24,7 @@
# Get support going for installing a custom language pack. Also
# need to be able to install more than one language pack.
-inherit flag-o-matic eutils gcc
+inherit flag-o-matic eutils toolchain-funcs
IUSE="gnome kde java curl"
@@ -191,11 +191,6 @@ oo_setup() {
unset LANG
unset LC_ALL
- # We want gcc3 if possible!!!!
- export WANT_GCC_3="yes"
-
- export NEW_GCC="0"
-
if [ -x /usr/sbin/gcc-config ]
then
# Do we have a gcc that use the new layout and gcc-config ?
@@ -386,8 +381,8 @@ src_compile() {
if [ -z "$(grep 'CCCOMP' ${S}/${LinuxEnvSet})" ]
then
# Set CCCOMP and CXXCOMP. This is still needed for STLport
- export CCCOMP="$(gcc-getCC)"
- export CXXCOMP="$(gcc-getCXX)"
+ export CCCOMP="$(tc-getCC)"
+ export CXXCOMP="$(tc-getCXX)"
fi
einfo "Bootstrapping OpenOffice.org..."
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.3.6.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.3.6.ebuild
index 481ae4574034..604ffe273745 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.3.6.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.6.ebuild,v 1.1 2004/11/14 10:32:29 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.6.ebuild,v 1.2 2004/11/15 14:53:54 suka Exp $
# Notes:
#
@@ -24,7 +24,7 @@
# Get support going for installing a custom language pack. Also
# need to be able to install more than one language pack.
-inherit flag-o-matic eutils gcc
+inherit flag-o-matic eutils toolchain-funcs
IUSE="gnome kde java curl zlib nptl"
@@ -195,11 +195,6 @@ oo_setup() {
unset LANG
unset LC_ALL
- # We want gcc3 if possible!!!!
- export WANT_GCC_3="yes"
-
- export NEW_GCC="0"
-
if [ -x /usr/sbin/gcc-config ]
then
# Do we have a gcc that use the new layout and gcc-config ?
@@ -410,8 +405,8 @@ src_compile() {
if [ -z "$(grep 'CCCOMP' ${S}/${LinuxEnvSet})" ]
then
# Set CCCOMP and CXXCOMP. This is still needed for STLport
- export CCCOMP="$(gcc-getCC)"
- export CXXCOMP="$(gcc-getCXX)"
+ export CCCOMP="$(tc-getCC)"
+ export CXXCOMP="$(tc-getCXX)"
fi
einfo "Bootstrapping OpenOffice.org..."