summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2011-09-06 08:58:27 +0000
committerVlastimil Babka <caster@gentoo.org>2011-09-06 08:58:27 +0000
commitfa5a3e651a12424aecc9df4419738f414a6b5e45 (patch)
treeddae8485c64c6ddfc4fd91567556e28abdc714a9 /app-office/taskcoach
parentReintroduce last stable, it appears to have been accidentally deleted. This i... (diff)
downloadgentoo-2-fa5a3e651a12424aecc9df4419738f414a6b5e45.tar.gz
gentoo-2-fa5a3e651a12424aecc9df4419738f414a6b5e45.tar.bz2
gentoo-2-fa5a3e651a12424aecc9df4419738f414a6b5e45.zip
Version bump, bug #379221.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-office/taskcoach')
-rw-r--r--app-office/taskcoach/ChangeLog7
-rw-r--r--app-office/taskcoach/taskcoach-1.2.27.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index 04b9573ce6ed..b1937305311b 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/taskcoach
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.74 2011/07/29 06:55:23 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.75 2011/09/06 08:58:27 caster Exp $
+
+*taskcoach-1.2.27 (06 Sep 2011)
+
+ 06 Sep 2011; Vlastimil Babka <caster@gentoo.org> +taskcoach-1.2.27.ebuild:
+ Version bump, bug #379221.
*taskcoach-1.2.24 (29 Jul 2011)
diff --git a/app-office/taskcoach/taskcoach-1.2.27.ebuild b/app-office/taskcoach/taskcoach-1.2.27.ebuild
new file mode 100644
index 000000000000..5ba6f5287d16
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-1.2.27.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.2.27.ebuild,v 1.1 2011/09/06 08:58:27 caster Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+PYTHON_MODNAME="buildlib taskcoachlib"
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org http://pypi.python.org/pypi/TaskCoach"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}
+ libnotify? ( dev-python/notify-python )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt"
+
+src_unpack() {
+ default
+
+ einfo "Removing Funambol support, works only on x86 and python 2.5."
+ rm -fv "${S}"/taskcoachlib/bin.in/linux/*.so || die
+}
+
+src_install() {
+ distutils_src_install
+
+ # a bit ugly but...
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+ for file in "${D}"/usr/bin/taskcoach.py-*; do
+ dir=$(dirname ${file})
+ ver=$(basename ${file})
+ ver=${ver#taskcoach.py-}
+ mv "${file}" "${dir}/taskcoach-${ver}" || die
+ done
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}