summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-23 07:37:26 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-23 07:37:26 +0000
commit31bc23ef48eb1e55d9fd86d651bdfef6ce9a38b2 (patch)
treec3fb209332ee4c2c3a6bcda75411be017913e815 /app-office/texmaker
parentmarked x86 per bug 427592 (diff)
downloadgentoo-2-31bc23ef48eb1e55d9fd86d651bdfef6ce9a38b2.tar.gz
gentoo-2-31bc23ef48eb1e55d9fd86d651bdfef6ce9a38b2.tar.bz2
gentoo-2-31bc23ef48eb1e55d9fd86d651bdfef6ce9a38b2.zip
app-office/texmaker: Version Bump, #427134
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/files/texmaker-3.4.1-hunspell.patch148
-rw-r--r--app-office/texmaker/texmaker-3.4.1.ebuild75
3 files changed, 230 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index ef7856fdee48..a67527675d56 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.103 2012/07/19 17:50:58 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.104 2012/07/23 07:37:26 jlec Exp $
+
+*texmaker-3.4.1 (23 Jul 2012)
+
+ 23 Jul 2012; Justin Lecher <jlec@gentoo.org> +texmaker-3.4.1.ebuild,
+ +files/texmaker-3.4.1-hunspell.patch:
+ Version Bump, #427134
19 Jul 2012; Jeff Horelick <jdhore@gentoo.org> texmaker-3.3.4.ebuild:
marked x86 per bug 427198
diff --git a/app-office/texmaker/files/texmaker-3.4.1-hunspell.patch b/app-office/texmaker/files/texmaker-3.4.1-hunspell.patch
new file mode 100644
index 000000000000..b07990710814
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-3.4.1-hunspell.patch
@@ -0,0 +1,148 @@
+ latexeditor.h | 2 +-
+ latexeditorview.h | 2 +-
+ latexhighlighter.h | 2 +-
+ spellerdialog.h | 2 +-
+ texmaker.h | 2 +-
+ texmaker.pro | 40 ++++------------------------------------
+ 6 files changed, 9 insertions(+), 41 deletions(-)
+
+diff --git a/latexeditor.h b/latexeditor.h
+index c12bbe3..94b9a3c 100644
+--- a/latexeditor.h
++++ b/latexeditor.h
+@@ -33,7 +33,7 @@
+
+ #include "latexhighlighter.h"
+ #include "textblockselection.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ typedef int UserBookmarkList[3];
+
+diff --git a/latexeditorview.h b/latexeditorview.h
+index 5951656..796eb28 100644
+--- a/latexeditorview.h
++++ b/latexeditorview.h
+@@ -22,7 +22,7 @@
+ #include "gotolinewidget.h"
+ #include "replacewidget.h"
+ #include "minisplitter.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class LatexEditorView : public QWidget {
+ Q_OBJECT
+diff --git a/latexhighlighter.h b/latexhighlighter.h
+index e0b91b1..74ec42a 100644
+--- a/latexhighlighter.h
++++ b/latexhighlighter.h
+@@ -20,7 +20,7 @@
+ #include <QColor>
+ #include <QTextBlockUserData>
+ //#include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class QTextDocument;
+ class LatexEditor;
+diff --git a/spellerdialog.h b/spellerdialog.h
+index 83248ae..cd16dad 100644
+--- a/spellerdialog.h
++++ b/spellerdialog.h
+@@ -13,7 +13,7 @@
+
+ #include "ui_spellerdialog.h"
+ #include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ #include <QTextCursor>
+
+diff --git a/texmaker.h b/texmaker.h
+index 045ffc8..bf2705a 100644
+--- a/texmaker.h
++++ b/texmaker.h
+@@ -48,7 +48,7 @@
+ #include "usertagslistwidget.h"
+ #include "xmltagslistwidget.h"
+ #include "logeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+ #include "browser.h"
+ #include "pdfviewerwidget.h"
+ #include "pdfviewer.h"
+diff --git a/texmaker.pro b/texmaker.pro
+index 4e11282..9625bd5 100644
+--- a/texmaker.pro
++++ b/texmaker.pro
+@@ -4,7 +4,8 @@ TARGET = texmaker
+ QT += network \
+ xml \
+ webkit
+-CONFIG += qt warn_off release
++CONFIG += qt warn_off release link_pkgconfig
++PKGCONFIG = hunspell poppler-qt4
+ TEXMAKERVERSION=3.4.1
+ DEFINES += TEXMAKERVERSION=\\\"$${TEXMAKERVERSION}\\\"
+ DEFINES += HAVE_SPLASH
+@@ -67,25 +68,6 @@ HEADERS += texmaker.h \
+ synctex_parser_utils.h \
+ usertagslistwidget.h \
+ addtagdialog.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell \
+- hunspell/filemgr.hxx \
+- hunspell/hunzip.hxx \
+- hunspell/replist.hxx \
+- hunspell/w_char.hxx \
+ singleapp/qtlocalpeer.h \
+ singleapp/qtlockedfile.h \
+ singleapp/qtsingleapplication.h \
+@@ -171,18 +153,6 @@ SOURCES += main.cpp \
+ synctex_parser_utils.c \
+ usertagslistwidget.cpp \
+ addtagdialog.cpp \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx \
+- hunspell/filemgr.cxx \
+- hunspell/replist.cxx \
+- hunspell/hunzip.cxx \
+ singleapp/qtlocalpeer.cpp \
+ singleapp/qtlockedfile.cpp \
+ singleapp/qtsingleapplication.cpp \
+@@ -278,13 +248,11 @@ isEmpty( ICONDIR ) {
+ ICONDIR=/usr/share/pixmaps
+ }
+
+-INCLUDEPATH += /usr/include/poppler/qt4
+-LIBS += -L/usr/lib -lpoppler-qt4
+-LIBS += -L/usr/lib -lz
++LIBS += -lz
+ DEFINES += PREFIX=\\\"$${PREFIX}\\\"
+ target.path = $${PREFIX}/bin
+
+-#DEFINES += DEBIAN_SPELLDIR
++DEFINES += DEBIAN_SPELLDIR
+
+
+ INSTALLS = target
diff --git a/app-office/texmaker/texmaker-3.4.1.ebuild b/app-office/texmaker/texmaker-3.4.1.ebuild
new file mode 100644
index 000000000000..54d0463c2ee1
--- /dev/null
+++ b/app-office/texmaker/texmaker-3.4.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-3.4.1.ebuild,v 1.1 2012/07/23 07:37:26 jlec Exp $
+
+EAPI=4
+
+inherit base qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+MY_P="${P}"
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/poppler[qt4]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ x11-libs/qt-webkit:4
+ app-text/hunspell"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hunspell.patch
+ "${FILESDIR}"/${PN}-3.3.3-qt48.patch
+ )
+src_configure() {
+ eqmake4 \
+ ${PN}.pro \
+ PREFIX="${EPREFIX}/usr" \
+ DESKTOPDIR="${EPREFIX}/usr/share/applications" \
+ ICONDIR="${EPREFIX}/usr/share/pixmaps"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+
+ insinto /usr/share/pixmaps/texmaker
+ doins utilities/texmaker*.png
+ doins utilities/texmaker.svg
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}