summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-05-16 04:22:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-05-16 04:22:53 +0000
commit0f4ec2a8eff55b2c9019aeeff6e94ca754a4100f (patch)
tree1d92efbee8bf079b185d0121140821987deffda3 /app-office
parentsetup env before loading ACLOCAL_AMFLAGS #365401 by Dennis Schridde (diff)
downloadgentoo-2-0f4ec2a8eff55b2c9019aeeff6e94ca754a4100f.tar.gz
gentoo-2-0f4ec2a8eff55b2c9019aeeff6e94ca754a4100f.tar.bz2
gentoo-2-0f4ec2a8eff55b2c9019aeeff6e94ca754a4100f.zip
version bump, by Pavel again
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/ChangeLog8
-rw-r--r--app-office/lyx/lyx-2.0.0.ebuild181
-rw-r--r--app-office/lyx/metadata.xml10
3 files changed, 198 insertions, 1 deletions
diff --git a/app-office/lyx/ChangeLog b/app-office/lyx/ChangeLog
index 8a8a585bacaa..c6c6b6dbdbee 100644
--- a/app-office/lyx/ChangeLog
+++ b/app-office/lyx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/lyx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.226 2011/05/14 16:15:45 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.227 2011/05/16 04:22:53 aballier Exp $
+
+*lyx-2.0.0 (16 May 2011)
+
+ 16 May 2011; Alexis Ballier <aballier@gentoo.org> +lyx-2.0.0.ebuild,
+ metadata.xml:
+ version bump, by Pavel again
*lyx-1.6.10 (14 May 2011)
diff --git a/app-office/lyx/lyx-2.0.0.ebuild b/app-office/lyx/lyx-2.0.0.ebuild
new file mode 100644
index 000000000000..30281b75bc2e
--- /dev/null
+++ b/app-office/lyx/lyx-2.0.0.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-2.0.0.ebuild,v 1.1 2011/05/16 04:22:53 aballier Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit qt4-r2 eutils flag-o-matic font python toolchain-funcs
+
+MY_P="${P/_}"
+
+S="${WORKDIR}/${MY_P}"
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
+HOMEPAGE="http://www.lyx.org/"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/2.0.x/${P}.tar.xz"
+#SRC_URI="ftp://ftp.lyx.org/pub/lyx/devel/lyx-2.0/rc3/${MY_P}.tar.xz"
+#SRC_URI="ftp://ftp.devel.lyx.org/pub/lyx/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cups debug nls latex xetex luatex monolithic-build html rtf dot docbook dia subversion rcs svg gnumeric +hunspell aspell enchant"
+
+LANGS="ar ca cs de da el en es eu fi fr gl he hu ia id it ja nb nn pl pt ro ru sk sr sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+COMMONDEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXrender
+ x11-libs/libXfixes
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ dev-libs/libxml2
+ media-libs/fontconfig
+ media-libs/freetype
+ >=dev-libs/boost-1.34"
+
+RDEPEND="${COMMONDEPEND}
+ || ( dev-texlive/texlive-fontsextra app-text/ptex )
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick )
+ cups? ( virtual/lpr )
+ latex? (
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ app-text/noweb
+ app-text/dvipng
+ dev-tex/dvipost
+ dev-tex/chktex
+ app-text/ps2eps
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-science
+ dev-texlive/texlive-genericextra
+ dev-texlive/texlive-fontsrecommended
+ || (
+ dev-tex/latex2html
+ dev-tex/tth
+ dev-tex/hevea
+ dev-tex/tex4ht
+ )
+ )
+ xetex? ( dev-texlive/texlive-xetex )
+ luatex? ( >=dev-texlive/texlive-luatex-2010 )
+ html? ( dev-tex/html2latex )
+ rtf? (
+ dev-tex/latex2rtf
+ app-text/unrtf
+ dev-tex/html2latex
+ )
+ linguas_he? ( dev-tex/culmus-latex )
+ docbook? ( app-text/sgmltools-lite )
+ dot? ( media-gfx/graphviz )
+ dia? ( app-office/dia )
+ subversion? ( dev-vcs/subversion )
+ rcs? ( dev-vcs/rcs )
+ svg? ( || ( gnome-base/librsvg media-gfx/inkscape ) )
+ gnumeric? ( app-office/gnumeric )
+ hunspell? ( app-text/hunspell )
+ aspell? ( app-text/aspell )
+ enchant? ( app-text/enchant )"
+
+DEPEND="${COMMONDEPEND}
+ x11-proto/xproto
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python_set_active_version 2
+ font_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.6.7-python.patch
+ echo "#!/bin/sh" > config/py-compile
+ sed "s:python -tt:$(PYTHON) -tt:g" -i lib/configure.py || die
+}
+
+src_configure() {
+ tc-export CXX
+ #bug 221921
+ export VARTEXFONTS=${T}/fonts
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable monolithic-build) \
+ $(use_with hunspell) \
+ $(use_with aspell) \
+ $(use_with enchant) \
+ --without-included-boost --disable-stdlib-debug
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ANNOUNCE NEWS README RELEASE-NOTES UPGRADING "${FONT_S}"/*.txt || die
+
+ if use linguas_he ; then
+ echo "\bind_file cua" > "${T}"/hebrew.bind
+ echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind
+
+ insinto /usr/share/lyx/bind
+ doins "${T}"/hebrew.bind || die
+ fi
+
+ doicon ${PN} "$S/development/Win32/packaging/icons/lyx_32x32.png"
+ make_desktop_entry ${PN} "LyX" "/usr/share/pixmaps/lyx_32x32.png" "Office" "MimeType=application/x-lyx;"
+
+ # fix for bug 91108
+ if use latex ; then
+ dosym ../../../lyx/tex /usr/share/texmf/tex/latex/lyx || die
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+
+ python_convert_shebangs -r 2 "${D}"/usr/share/${PN}
+
+ if use hunspell ; then
+ dosym /usr/share/myspell /usr/share/lyx/dicts
+ dosym /usr/share/myspell /usr/share/lyx/thes
+ fi
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash
+ fi
+
+ # instructions for RTL support. See also bug 168331.
+ if use linguas_he || use linguas_ar; then
+ elog
+ elog "Enabling RTL support in LyX:"
+ elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
+ elog "You must enable RTL support in LyX. To do so start LyX and go to"
+ elog "Tools->Preferences->Language settings->Language"
+ elog "and make sure the \"Right-to-left language support\" is checked"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ if use latex ; then
+ texhash
+ fi
+}
diff --git a/app-office/lyx/metadata.xml b/app-office/lyx/metadata.xml
index 8dcafcd2f1f1..db3f142420fe 100644
--- a/app-office/lyx/metadata.xml
+++ b/app-office/lyx/metadata.xml
@@ -22,5 +22,15 @@
<flag name='rcs'>Add support for revision control via <pkg>dev-vcs/rcs</pkg>
</flag>
<flag name='rtf'>Add support for RTF import/export packages</flag>
+ <flag name='xetex'>Add support for XeTeX typesetting</flag>
+ <flag name='luatex'>Add support for LuaTeX typesetting</flag>
+ <flag name='gnumeric'>Add support for importing Gnumeric/OpenOffice/MS Excel
+ spreadsheets into LyX.</flag>
+ <flag name='hunspell'>Add support for spellchecking based on hunspell and
+ reuse system-wide OpenOffice dictionaries. This also enable thesaurus
+ dictionaries not accessible via aspell.</flag>
+ <flag name='aspell'>Add support for aspell spellchecking</flag>
+ <flag name='enchant'>Add support for enchant spellchecking wrapper
+ (both aspell and hunspell can be used by LyX).</flag>
</use>
</pkgmetadata>