summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-08-06 01:04:04 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-08-06 01:04:04 +0000
commit1c1ae86e1f3dfdbec95b5b4c594ca1bc5a192d1b (patch)
tree9946635ba490973303be50a0ff692edf0ecce356 /app-office
parentSome gcc compat patches (diff)
downloadgentoo-2-1c1ae86e1f3dfdbec95b5b4c594ca1bc5a192d1b.tar.gz
gentoo-2-1c1ae86e1f3dfdbec95b5b4c594ca1bc5a192d1b.tar.bz2
gentoo-2-1c1ae86e1f3dfdbec95b5b4c594ca1bc5a192d1b.zip
New version, updated deps, added new dep to gnome-extra/libgsf. Also closes 5395
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/ChangeLog7
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-1.1.61
-rw-r--r--app-office/gnumeric/gnumeric-1.1.6.ebuild89
3 files changed, 96 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index 692a1c93fe65..51f025c9477b 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/gnumeric
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.14 2002/07/29 06:08:32 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.15 2002/08/06 01:04:04 stroke Exp $
+
+*gnumeric-1.1.6 (06 Aug 2002)
+ 06 Aug 2002 ; Gabriele Giorgetti <stroke@gentoo.org> gnumeric-1.1.6.ebuild ChangeLog:
+ New version, updated deps, added new dep to gnome-extra/libgsf.
+ Also closes bug #5395
*gnumeric-1.0.9 (29 Jul 2002)
29 Jul 2002; Spider <spider@gentoo.org> gnumeric-1.0.9.ebuild gnumeric-1.0.8.ebuild gnumeric-1.1.5.ebuild :
diff --git a/app-office/gnumeric/files/digest-gnumeric-1.1.6 b/app-office/gnumeric/files/digest-gnumeric-1.1.6
new file mode 100644
index 000000000000..308dedeaa0bd
--- /dev/null
+++ b/app-office/gnumeric/files/digest-gnumeric-1.1.6
@@ -0,0 +1 @@
+MD5 0451ad5fa44ae688057dee8e0b990d3e gnumeric-1.1.6.tar.bz2 7030251
diff --git a/app-office/gnumeric/gnumeric-1.1.6.ebuild b/app-office/gnumeric/gnumeric-1.1.6.ebuild
new file mode 100644
index 000000000000..8fcb004c30de
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.1.6.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.1.6.ebuild,v 1.1 2002/08/06 01:04:04 stroke Exp $
+
+#provide Xmake and Xemake
+inherit virtualx
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+SRC_URI="mirror://gnome/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+#Eye Of Gnome (media-gfx/eog) is for image support.
+RDEPEND="=x11-libs/gtk+-2.0*
+ =dev-libs/glib-2.0*
+ >=gnome-base/libgnome-2.0.1
+ >=gnome-base/libgnomeui-2.0.1
+ >=gnome-base/libbonobo-2.0.0
+ >=gnome-base/libbonoboui-2.0.0
+ >=gnome-base/libgnomeprint-1.115.0
+ >=gnome-base/libgnomeprintui-1.115.0
+ >=gnome-extra/gal2-0.0.3
+ >=gnome-extra/libgsf-1.1.0
+ >=gnome-base/libglade-2.0.0
+ dev-libs/libxml2
+ perl? ( >=sys-devel/perl-5.6 )
+ python? ( >=dev-lang/python-2.0 )
+ gb? ( ~gnome-extra/gb-0.0.17 )
+ libgda? ( >=gnome-extra/libgda-0.2.91
+ >=gnome-base/bonobo-1.0.17 )
+ evo? ( >=net-mail/evolution-1.0.8 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fix the relink bug, and invalid paths in .ls files.
+ libtoolize --copy --force
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+ use gb && myconf="${myconf} --with-gb" || myconf="${myconf} --without-gb"
+
+ use guile && myconf="${myconf} --with-guile" || myconf="${myconf} --without-guile"
+ use perl && myconf="${myconf} --with-perl" || myconf="${myconf} --without-perl"
+ use python && yconf="${myconf} --with-python" || myconf="${myconf} --without-python"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ #'gnumeric --dump-func-defs' needs to write to ${HOME}/.gnome/, or
+ #else the build fails.
+ # addwrite "${HOME}/.gnome"
+
+ #the build process have to be able to connect to X
+ Xemake || Xmake || die
+}
+
+src_install() {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ install || die
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+}
+
+pkg_postinst() {
+ export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
+ echo ">>> updating GConf2 (modemlights)"
+ for SCHEMA in gnumeric-dialogs.schemas gnumeric-general.schemas ; do
+ echo $SCHEMA
+ /usr/bin/gconftool-2 --makefile-install-rule \
+ /etc/gconf/schemas/${SCHEMA}
+ done
+}