summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-05-31 19:42:04 +0000
committerVlastimil Babka <caster@gentoo.org>2010-05-31 19:42:04 +0000
commit3e4db1b3021a237b083189eb9bf645a79e9fa712 (patch)
treee6444820c693facbbc8be869d72c824bc4686885 /app-office
parentamd64 stable, bug #300173 (diff)
downloadgentoo-2-3e4db1b3021a237b083189eb9bf645a79e9fa712.tar.gz
gentoo-2-3e4db1b3021a237b083189eb9bf645a79e9fa712.tar.bz2
gentoo-2-3e4db1b3021a237b083189eb9bf645a79e9fa712.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/taskcoach/ChangeLog8
-rw-r--r--app-office/taskcoach/taskcoach-1.0.2.ebuild53
-rw-r--r--app-office/taskcoach/taskcoach-1.0.4.ebuild (renamed from app-office/taskcoach/taskcoach-1.0.1.ebuild)34
3 files changed, 27 insertions, 68 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index 0f11293784ba..08a1b2fef061 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/taskcoach
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.46 2010/04/25 19:54:32 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.47 2010/05/31 19:42:04 caster Exp $
+
+*taskcoach-1.0.4 (31 May 2010)
+
+ 31 May 2010; Vlastimil Babka <caster@gentoo.org> -taskcoach-1.0.1.ebuild,
+ -taskcoach-1.0.2.ebuild, +taskcoach-1.0.4.ebuild:
+ Version bump.
*taskcoach-1.0.3 (25 Apr 2010)
diff --git a/app-office/taskcoach/taskcoach-1.0.2.ebuild b/app-office/taskcoach/taskcoach-1.0.2.ebuild
deleted file mode 100644
index 9f3176b9eed7..000000000000
--- a/app-office/taskcoach/taskcoach-1.0.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.0.2.ebuild,v 1.1 2010/04/11 23:03:08 caster Exp $
-
-EAPI=1
-
-inherit distutils eutils
-
-MY_PN="TaskCoach"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple personal tasks and todo lists manager"
-HOMEPAGE="http://www.taskcoach.org"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=">=dev-lang/python-2.4
- >=dev-python/wxpython-2.8.9.2:2.8"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES.txt"
-
-src_unpack() {
- distutils_src_unpack
-
- cd "${S}"
- einfo "Removing Funambol support, works only on x86 and python 2.5."
- rm -fv taskcoachlib/bin.in/linux/*.so || die
-}
-
-src_compile() {
- # upstream now sets executable to /usr/bin/python2.5
- distutils_src_compile --executable=/usr/bin/python
-}
-
-src_install() {
- distutils_src_install
-
- mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
-
- doicon "icons.in/${PN}.png" || die
- make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
-}
-
-pkg_postinst() {
- elog "With version 1.0, taskcoach could be stabilized if there is enough user interest."
- elog "If you run a stable stable system and had to keyword taskcoach, please comment/vote"
- elog "on http://bugs.gentoo.org/show_bug.cgi?id=311841"
-}
diff --git a/app-office/taskcoach/taskcoach-1.0.1.ebuild b/app-office/taskcoach/taskcoach-1.0.4.ebuild
index 04a62dac9055..d220f6e1ed4d 100644
--- a/app-office/taskcoach/taskcoach-1.0.1.ebuild
+++ b/app-office/taskcoach/taskcoach-1.0.4.ebuild
@@ -1,8 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.0.1.ebuild,v 1.1 2010/03/29 13:37:28 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.0.4.ebuild,v 1.1 2010/05/31 19:42:04 caster Exp $
-EAPI=1
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_MODNAME="buildlib taskcoachlib"
inherit distutils eutils
@@ -15,32 +20,33 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=">=dev-lang/python-2.4
- >=dev-python/wxpython-2.8.9.2:2.8"
-RDEPEND="${DEPEND}"
+IUSE="libnotify"
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}
+ libnotify? ( dev-python/notify-python )"
S="${WORKDIR}/${MY_P}"
DOCS="CHANGES.txt"
src_unpack() {
- distutils_src_unpack
+ default
- cd "${S}"
einfo "Removing Funambol support, works only on x86 and python 2.5."
- rm -fv taskcoachlib/bin.in/linux/*.so || die
-}
-
-src_compile() {
- # upstream now sets executable to /usr/bin/python2.5
- distutils_src_compile --executable=/usr/bin/python
+ rm -fv "${S}"/taskcoachlib/bin.in/linux/*.so || die
}
src_install() {
distutils_src_install
+ # a bit ugly but...
mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+ for file in "${D}"/usr/bin/taskcoach.py-*; do
+ dir=$(dirname ${file})
+ ver=$(basename ${file})
+ ver=${ver#taskcoach.py-}
+ mv "${file}" "${dir}/taskcoach-${ver}" || die
+ done
doicon "icons.in/${PN}.png" || die
make_desktop_entry ${PN} "Task Coach" ${PN} Office || die