summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-25 20:43:32 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-25 20:43:32 +0000
commit4224a7bda7cc50580ce782942e3831d1660fa95c (patch)
treef44a3bbe76e2655e926dfbf12584cd76ac0cccc0 /app-office
parentVersion bump (diff)
downloadgentoo-2-4224a7bda7cc50580ce782942e3831d1660fa95c.tar.gz
gentoo-2-4224a7bda7cc50580ce782942e3831d1660fa95c.tar.bz2
gentoo-2-4224a7bda7cc50580ce782942e3831d1660fa95c.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kword/ChangeLog8
-rw-r--r--app-office/kword/kword-2.2.2.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/app-office/kword/ChangeLog b/app-office/kword/ChangeLog
index 7c7221b61e30..a2ad977a6de3 100644
--- a/app-office/kword/ChangeLog
+++ b/app-office/kword/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kword
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.147 2010/06/23 18:05:39 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.148 2010/09/25 20:43:32 dilfridge Exp $
+
+*kword-2.2.2 (25 Sep 2010)
+
+ 25 Sep 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kword-2.2.2.ebuild:
+ Version bump
23 Jun 2010; Markos Chandras <hwoarang@gentoo.org> kword-2.1.2.ebuild,
+files/kword-2.1.2-gcc45.patch:
diff --git a/app-office/kword/kword-2.2.2.ebuild b/app-office/kword/kword-2.2.2.ebuild
new file mode 100644
index 000000000000..6c5fc07149cd
--- /dev/null
+++ b/app-office/kword/kword-2.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-2.2.2.ebuild,v 1.1 2010/09/25 20:43:32 dilfridge Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice word processor."
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="wpd"
+
+DEPEND="
+ wpd? ( app-text/libwpd )
+"
+RDEPEND="${DEPEND}
+ !app-text/wv2
+"
+
+KMEXTRA="filters/${KMMODULE}/
+ filters/libmso/
+"
+
+KMEXTRACTONLY="
+ filters/
+ kspread/
+ libs/
+ plugins/
+"
+
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with wpd)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+}