summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-08-22 08:26:08 +0000
committerDan Armak <danarmak@gentoo.org>2002-08-22 08:26:08 +0000
commit543c6217a8f8810a5eb9be45e10baa0a297a1a23 (patch)
tree6d35134c8797e921fa487aa5ca10bb675fd94c06 /app-office
parentVersion bump. Closes 6532. (diff)
downloadgentoo-2-543c6217a8f8810a5eb9be45e10baa0a297a1a23.tar.gz
gentoo-2-543c6217a8f8810a5eb9be45e10baa0a297a1a23.tar.bz2
gentoo-2-543c6217a8f8810a5eb9be45e10baa0a297a1a23.zip
new version that fixes many issues. owen, please test and keywordify for ppc
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/ChangeLog10
-rw-r--r--app-office/lyx/files/digest-lyx-1.2.11
-rw-r--r--app-office/lyx/lyx-1.2.1.ebuild64
3 files changed, 73 insertions, 2 deletions
diff --git a/app-office/lyx/ChangeLog b/app-office/lyx/ChangeLog
index 7df0494bb455..0b926db59c4f 100644
--- a/app-office/lyx/ChangeLog
+++ b/app-office/lyx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/lyx
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.5 2002/08/06 17:44:43 gerk Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.6 2002/08/22 08:26:08 danarmak Exp $
+
+*lyx-1.2.1 (22 Aug 2002)
+
+ 22 Aug 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ New bugfix release that fixes many issues.
*lyx-1.2.0.20020705 (05 Jul 2002)
diff --git a/app-office/lyx/files/digest-lyx-1.2.1 b/app-office/lyx/files/digest-lyx-1.2.1
new file mode 100644
index 000000000000..bf8b370bb417
--- /dev/null
+++ b/app-office/lyx/files/digest-lyx-1.2.1
@@ -0,0 +1 @@
+MD5 6797b72d306000bd1579cfea21b3f1cf lyx-1.2.1.tar.gz 6476744
diff --git a/app-office/lyx/lyx-1.2.1.ebuild b/app-office/lyx/lyx-1.2.1.ebuild
new file mode 100644
index 000000000000..5604050f9ddb
--- /dev/null
+++ b/app-office/lyx/lyx-1.2.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.2.1.ebuild,v 1.1 2002/08/22 08:26:08 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LyX is an WYSIWYM frontend for LaTeX"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.gz"
+HOMEPAGE="http://www.lyx.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+# This lyx-base ebuild only depends on the absolutely necessary packages.
+# The acompanying lyx-utils ebuild depends on lyx-base and on everything
+# else that lyx can use.
+DEPEND="virtual/x11
+ >=x11-libs/xforms-1.0_rc4
+ app-text/tetex
+ >=sys-devel/perl-5
+ nls? ( sys-devel/gettext )
+ app-text/aiksaurus"
+RDEPEND="${DEPEND}
+ app-text/ghostscript
+ app-text/xpdf
+ app-text/ispell
+ app-text/gv
+ app-text/latex2html
+ media-gfx/imagemagick
+ cups? ( virtual/lpr )
+ app-text/rcs
+ dev-util/cvs
+ app-text/sgmltools-lite
+ app-text/noweb
+ app-text/chktex"
+
+src_compile() {
+
+ use nls || myconf="${myconf} --disable-nls"
+ [ -n "$DEBUG" ] && myconf="$myconf --enable-debug" || myconf="$myconf --disable-debug"
+
+ # -O3 and higher breaks
+ export CXXFLAGS="${CXXFLAGS//-O[3..9]/-O2}"
+ export CFLAGS="${CFLAGS//-O[3..9]/-O2}"
+
+ export WANT_AUTOCONF_2_5=1
+
+ #./autogen.sh
+
+ ./configure --host=${CHOST} --prefix=/usr ${myconf} || die "./configure failed"
+ #--infodir='$(prefix)/share/info' \
+ #--with-extra-inc=/usr/X11R6/include \
+ #--mandir='$(prefix)/share/man' \
+ emake || die "emake failed"
+}
+
+src_install () {
+ # The 'install-strip' target is provided by the LyX makefile
+ # for stripping installed binaries. Use prefix= instead of
+ # DESTDIR=, otherwise it violates the sandbox in the po directory.
+ make prefix=${D}/usr install
+ dodoc README* UPGRADING INSTALL* ChangeLog NEW COPYING ANNOUNCE ABOUT-NLS
+}
+