summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-10 17:22:39 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-10 17:22:39 +0000
commitc77a4c5b0c8a4d6169b810709858f5a58c497203 (patch)
tree18b79680a2f511629eb560f18027e62aa44991ef /app-office
parentalpha/ia64/sparc stable wrt #378373 (diff)
downloadgentoo-2-c77a4c5b0c8a4d6169b810709858f5a58c497203.tar.gz
gentoo-2-c77a4c5b0c8a4d6169b810709858f5a58c497203.tar.bz2
gentoo-2-c77a4c5b0c8a4d6169b810709858f5a58c497203.zip
Fix python modules installation, bug #381477 by Chris Mayo.
(Portage version: 2.1.10.14/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/ChangeLog5
-rw-r--r--app-office/gnucash/gnucash-2.4.7.ebuild14
2 files changed, 16 insertions, 3 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index 1ce3aa29f217..64a0224883d7 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-office/gnucash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.243 2011/08/29 15:59:50 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.244 2011/09/10 17:22:39 pacho Exp $
+
+ 10 Sep 2011; Pacho Ramos <pacho@gentoo.org> gnucash-2.4.7.ebuild:
+ Fix python modules installation, bug #381477 by Chris Mayo.
*gnucash-2.4.7 (29 Aug 2011)
diff --git a/app-office/gnucash/gnucash-2.4.7.ebuild b/app-office/gnucash/gnucash-2.4.7.ebuild
index 745a7641ad61..b255cdf03b31 100644
--- a/app-office/gnucash/gnucash-2.4.7.ebuild
+++ b/app-office/gnucash/gnucash-2.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-2.4.7.ebuild,v 1.1 2011/08/29 15:59:50 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-2.4.7.ebuild,v 1.2 2011/09/10 17:22:39 pacho Exp $
EAPI="3"
GNOME2_LA_PUNT="yes"
@@ -31,7 +31,7 @@ RDEPEND=">=dev-libs/glib-2.13:2
>=gnome-base/gconf-2:2
>=gnome-base/libgnomeui-2.4
>=gnome-base/libglade-2.4:2.0
- || ( <gnome-base/gnome-keyring-2.29 gnome-base/libgnome-keyring )
+ gnome-base/libgnome-keyring
media-libs/libart_lgpl
>=sys-libs/zlib-1.1.4
>=x11-libs/gtk+-2.14:2
@@ -140,3 +140,13 @@ src_install() {
mv "${ED}"/usr/share/doc/${PF} "${T}"/cantuseprepalldocs || die
dodoc "${T}"/cantuseprepalldocs/* || die
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use python && python_mod_optimize gnucash
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ use python && python_mod_cleanup gnucash
+}