summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2002-06-12 01:53:04 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2002-06-12 01:53:04 +0000
commitccd3215b1a437a093f5bfc26acd7160a9ba48562 (patch)
tree366d1a76a93158cb04d31fc7bdf82c0bd83ad8e8 /app-office
parentNew snapshot. Old snapshots removed. (diff)
downloadgentoo-2-ccd3215b1a437a093f5bfc26acd7160a9ba48562.tar.gz
gentoo-2-ccd3215b1a437a093f5bfc26acd7160a9ba48562.tar.bz2
gentoo-2-ccd3215b1a437a093f5bfc26acd7160a9ba48562.zip
first relase
Diffstat (limited to 'app-office')
-rw-r--r--app-office/scribus/ChangeLog11
-rw-r--r--app-office/scribus/files/digest-scribus-0.7.4-r11
-rw-r--r--app-office/scribus/scribus-0.7.4-r1.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/app-office/scribus/ChangeLog b/app-office/scribus/ChangeLog
new file mode 100644
index 000000000000..2a1515118d2d
--- /dev/null
+++ b/app-office/scribus/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-office/scribus
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# Author: Francisco Gimeno <kikov@fco-gimeno.com>
+# Maintainer: José Alberto Suárez López <bass@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.1 2002/06/12 01:53:03 bass Exp $
+
+*scribus-0.7.4-r1 (09 Jun 2002)
+
+ 09 Jun 2002; Francisco Gimeno <kikov@fco-gimeno.com> scribus-0.7.4-r1.ebuild:
+ The initial package.
+
diff --git a/app-office/scribus/files/digest-scribus-0.7.4-r1 b/app-office/scribus/files/digest-scribus-0.7.4-r1
new file mode 100644
index 000000000000..24fea2912eeb
--- /dev/null
+++ b/app-office/scribus/files/digest-scribus-0.7.4-r1
@@ -0,0 +1 @@
+MD5 4eda89669560b9477f6d8799aa6304cd scribus-0.7.4.tar.gz 1958912
diff --git a/app-office/scribus/scribus-0.7.4-r1.ebuild b/app-office/scribus/scribus-0.7.4-r1.ebuild
new file mode 100644
index 000000000000..5d8e5600b611
--- /dev/null
+++ b/app-office/scribus/scribus-0.7.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-0.7.4-r1.ebuild,v 1.1 2002/06/12 01:53:04 bass Exp $
+
+DESCRIPTION="Scribus is a Layout program"
+HOMEPAGE="http://web2.altmuehlnet.de/fschmid"
+LICENSE="GPL"
+
+DEPEND=">=x11-libs/qt-3.0.3 \
+ media-libs/freetype \
+ media-libs/lcms"
+RDEPEND="${DEPEND}"
+SRC_URI="http://web2.altmuehlnet.de/fschmid/${P}.tar.gz"
+SLOT="0"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ econf || die "./configure failed"
+ emake || die "make failed"
+ mv debian/scribus-debian.xpm debian/scribus.xpm
+}
+
+src_install () {
+
+ einstall destdir=${D} || die "couldn't be installed"
+
+ dodoc AUTHORS ChangeLog README TODO
+
+ # Fixing desktop.scribus
+ use kde &&
+ (
+ sed -e 's/local\///' desktop.scribus > desktop.scribus.2
+ echo "Name=Scribus" >> desktop.scribus.2
+ cp -f desktop.scribus.2 scribus.desktop
+ insinto /usr/kde/3/share/applnk/Graphics
+ doins scribus.desktop
+ )
+ # Copy the pixmaps to the generic place
+ insinto /usr/share/pixmaps/
+ doins debian/scribus.xpm
+
+ dosym /usr/share/scribus/doc /usr/share/doc/${PF}/html
+
+}