summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Houser <chouser@gentoo.org>2002-10-06 03:46:54 +0000
committerChris Houser <chouser@gentoo.org>2002-10-06 03:46:54 +0000
commitdbe10f1d529c5c05e619264bf35a3268faa57093 (patch)
tree622ddfee103da1b0ebfea043ebb64df6695c0767 /app-office
parentlong needed version bump (diff)
downloadgentoo-2-dbe10f1d529c5c05e619264bf35a3268faa57093.tar.gz
gentoo-2-dbe10f1d529c5c05e619264bf35a3268faa57093.tar.bz2
gentoo-2-dbe10f1d529c5c05e619264bf35a3268faa57093.zip
Bump up to gnucash 1.6.8. Both 1.6.7 and this version failed to build for me
with "postgres" in my use settings. I added a patch to this version that seems to fix it. I will submit my tiny patch to the gnucash team upstream.
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/ChangeLog8
-rw-r--r--app-office/gnucash/files/digest-gnucash-1.6.81
-rw-r--r--app-office/gnucash/gnucash-1.6.8.ebuild76
3 files changed, 84 insertions, 1 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index bb3b6b9ee771..458e239e6707 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/gnucash
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.6 2002/08/19 05:32:15 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.7 2002/10/06 03:46:50 chouser Exp $
+
+*gnucash-1.6.8 (05 Sep 2002)
+ 05 Sep 2002; Chris Houser <chouser@gentoo.org> gnucash-1.6.8.ebuild :
+ Bump up to latest version of gnucash. Both 1.6.7 and this version failed to
+ build for me with "postgres" in my use settings. I added a patch to this
+ version that seems to fix it.
*gnucash-1.6.7 (19 Aug 2002)
19 Aug 2002; Spider <spider@gentoo.org> gnucash-1.6.7.ebuild :
diff --git a/app-office/gnucash/files/digest-gnucash-1.6.8 b/app-office/gnucash/files/digest-gnucash-1.6.8
new file mode 100644
index 000000000000..1c667c446513
--- /dev/null
+++ b/app-office/gnucash/files/digest-gnucash-1.6.8
@@ -0,0 +1 @@
+MD5 2f881c603f7562dacf49977ec413c7ce gnucash-1.6.8.tar.gz 16655207
diff --git a/app-office/gnucash/gnucash-1.6.8.ebuild b/app-office/gnucash/gnucash-1.6.8.ebuild
new file mode 100644
index 000000000000..16b69d613e2b
--- /dev/null
+++ b/app-office/gnucash/gnucash-1.6.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.6.8.ebuild,v 1.1 2002/10/06 03:46:50 chouser Exp $
+
+IUSE="nls postgres"
+
+inherit flag-o-matic
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A personal finance manager"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnucash.org/"
+KEYWORDS="x86 ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ >=dev-libs/libxml-1.8.3
+ >=gnome-extra/gtkhtml-0.14.0-r1
+ >=gnome-extra/gal-0.13-r1
+ >=gnome-extra/guppi-0.35.5-r2
+ >=gnome-base/gnome-print-0.21
+ postgres? ( dev-db/postgresql )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/perl-5
+ >=dev-libs/slib-2.3.8
+ >=dev-lang/swig-1.3_alpha4
+ >=dev-libs/g-wrap-1.1.5
+ <gnome-base/libglade-2
+ media-libs/gdk-pixbuf
+ dev-util/guile
+ gnome-base/libghttp
+ nls? ( sys-devel/gettext )"
+
+
+# won't configure with this
+filter-flags -fomit-frame-pointer
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src/guile
+ cp argv-list-converters.c argv-list-converters.c.old
+ sed -e "s,printf,g_print,g" \
+ argv-list-converters.c.old > argv-list-converters.c
+ rm argv-list-converters.c.old
+
+ # With --enable-sql (use postgres), the gnucash 1.6.8 build process fails
+ # when making in src/engine. This should fix that. --Chouser
+ cd ${S}/src/engine || die
+ cp Makefile.am Makefile.am.old
+ sed -e 's/^SUBDIRS *= */&. /' Makefile.am.old > Makefile.am || die
+ cd ${S}
+ automake || die
+}
+
+src_compile() {
+ local myconf=""
+
+ use nls || myconf="--disable-nls"
+ use postgres && myconf="$myconf --enable-sql"
+
+ econf --enable-profile \
+ --enable-rpc \
+ $myconf || die "Configuration failed"
+
+ make || die # Doesn't work with make -j 4 (hallski)
+}
+
+src_install () {
+ einstall || die "Installation failed"
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING NEWS README* TODO
+}