summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-13 20:34:19 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-13 20:34:19 +0000
commitdc47e9aa585c0a5dea60cda9af2831c991a5f6d6 (patch)
treead5898be9633f616ca161abeb91ea3e4cbe076ad /app-office
parentVersion bump. (diff)
downloadgentoo-2-dc47e9aa585c0a5dea60cda9af2831c991a5f6d6.tar.gz
gentoo-2-dc47e9aa585c0a5dea60cda9af2831c991a5f6d6.tar.bz2
gentoo-2-dc47e9aa585c0a5dea60cda9af2831c991a5f6d6.zip
Use system hunspell, by Dustin Surawicz, bug #220617
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/files/texmaker-1.71-hunspell.patch64
-rw-r--r--app-office/texmaker/texmaker-1.71-r1.ebuild72
3 files changed, 143 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index a2be54a36555..1796193db30e 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.43 2008/05/11 19:38:14 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.44 2008/05/13 20:34:18 aballier Exp $
+
+*texmaker-1.71-r1 (13 May 2008)
+
+ 13 May 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/texmaker-1.71-hunspell.patch, +texmaker-1.71-r1.ebuild:
+ Use system hunspell, by Dustin Surawicz, bug #220617
11 May 2008; Alexis Ballier <aballier@gentoo.org> texmaker-1.60.ebuild:
switch to latex-base, allow split qt4 deps
diff --git a/app-office/texmaker/files/texmaker-1.71-hunspell.patch b/app-office/texmaker/files/texmaker-1.71-hunspell.patch
new file mode 100644
index 000000000000..39e1712633bc
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-1.71-hunspell.patch
@@ -0,0 +1,64 @@
+--- spellerdialog.h.old 2008-05-13 09:55:46.000000000 +0200
++++ spellerdialog.h 2008-05-13 09:56:06.000000000 +0200
+@@ -13,7 +13,7 @@
+
+ #include "ui_spellerdialog.h"
+ #include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ #include <QTextCursor>
+
+--- texmaker.pro.old 2008-05-13 10:09:23.000000000 +0200
++++ texmaker.pro 2008-05-13 10:11:15.000000000 +0200
+@@ -2,6 +2,8 @@
+ LANGUAGE = C++
+ TARGET = texmaker
+ CONFIG += qt warn_off release
++INCLUDEPATH += "/usr/include/hunspell"
++LIBS += "-lhunspell"
+ ###############################
+ HEADERS += texmaker.h \
+ symbollistwidget.h \
+@@ -32,22 +34,7 @@
+ webpublishdialog.h \
+ spellerdialog.h \
+ pstrickslistwidget.h \
+- blockdata.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell
++ blockdata.h
+ SOURCES += main.cpp \
+ texmaker.cpp \
+ symbollistwidget.cpp \
+@@ -77,16 +64,7 @@
+ aboutdialog.cpp \
+ webpublishdialog.cpp \
+ spellerdialog.cpp \
+- pstrickslistwidget.cpp \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx
++ pstrickslistwidget.cpp
+ RESOURCES += texmaker.qrc
+ FORMS += findwidget.ui\
+ gotolinedialog.ui \
diff --git a/app-office/texmaker/texmaker-1.71-r1.ebuild b/app-office/texmaker/texmaker-1.71-r1.ebuild
new file mode 100644
index 000000000000..a9fc618083ee
--- /dev/null
+++ b/app-office/texmaker/texmaker-1.71-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-1.71-r1.ebuild,v 1.1 2008/05/13 20:34:18 aballier Exp $
+
+EAPI=1
+
+inherit eutils versionator qt4
+
+DESCRIPTION="A nice LaTeX-IDE"
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+S="${WORKDIR}/${MY_P}"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXext
+ || ( ( x11-libs/qt-gui x11-libs/qt-core ) >=x11-libs/qt-4.3.0:4 )
+ >=app-text/hunspell-1.2.2"
+
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ virtual/ghostscript
+ media-libs/netpbm"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-hunspell.patch"
+}
+
+src_compile() {
+ eqmake4 texmaker.pro || die "qmake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+
+ insinto /usr/share/pixmaps/texmaker
+ doins utilities/texmaker*.png || die "doins failed."
+ doins utilities/texmaker.svg || die "doins failed."
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt || die "dodoc failed"
+
+ make_desktop_entry texmaker Texmaker "/usr/share/pixmaps/texmaker/texmaker48x48.png" Office
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "/usr/share/${PN}/usermanual_en.html"
+ elog
+}