summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2006-08-29 03:54:47 +0000
committerChris White <chriswhite@gentoo.org>2006-08-29 03:54:47 +0000
commit5d72475578adaddd194fbedaee6269449eacc5b2 (patch)
tree9aec55c1168b9917924599fea4238a8f59a46ef4 /app-pda/jpilot/jpilot-0.99.8.ebuild
parentReadd VIA IRQ quirk patch which was accidently dropped in 2.6.17-r5 (diff)
downloadgentoo-2-5d72475578adaddd194fbedaee6269449eacc5b2.tar.gz
gentoo-2-5d72475578adaddd194fbedaee6269449eacc5b2.tar.bz2
gentoo-2-5d72475578adaddd194fbedaee6269449eacc5b2.zip
So compnerds like "Wanna fix these ebuilds to be gtk USE flag only?" so Im like "Coo" (actually I argued with him about it for 2 days). So.. here it is! Back to dinner
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'app-pda/jpilot/jpilot-0.99.8.ebuild')
-rw-r--r--app-pda/jpilot/jpilot-0.99.8.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/app-pda/jpilot/jpilot-0.99.8.ebuild b/app-pda/jpilot/jpilot-0.99.8.ebuild
index b2ddf39a9cdb..db5382bb8039 100644
--- a/app-pda/jpilot/jpilot-0.99.8.ebuild
+++ b/app-pda/jpilot/jpilot-0.99.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-0.99.8.ebuild,v 1.1 2006/03/28 13:05:50 deltacow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-0.99.8.ebuild,v 1.2 2006/08/29 03:54:47 chriswhite Exp $
inherit eutils multilib
@@ -11,13 +11,12 @@ SRC_URI="mirror://gentoo/distfiles/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="nls gtk2"
+IUSE="nls gtk"
-RDEPEND="gtk2? ( >=x11-libs/gtk+-2 )
- !gtk2? ( >=x11-libs/gtk+-1.2 )
+RDEPEND="gtk? ( >=x11-libs/gtk+-2 )
>=app-pda/pilot-link-0.11.5"
DEPEND="${RDEPEND}
- gtk2? ( dev-util/pkgconfig )
+ gtk? ( dev-util/pkgconfig )
nls? ( sys-devel/gettext )"
src_unpack() {
@@ -33,7 +32,7 @@ src_unpack() {
}
src_compile() {
- econf $(use_enable gtk2) $(use_enable nls) || die "configure failed"
+ econf $(use_enable gtk gtk2) $(use_enable nls) || die "configure failed"
emake -j1 || die "make failed"
}