summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-02-20 03:40:57 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-02-20 03:40:57 +0000
commita2ae4c693c3e1a7c760e42f870ccb2d35507fc51 (patch)
tree78c98b79d4d8ea8260bd61731c66f1b50306f77c /app-pda/libopensync-plugin-python
parentUpdate live ebuild. (diff)
downloadgentoo-2-a2ae4c693c3e1a7c760e42f870ccb2d35507fc51.tar.gz
gentoo-2-a2ae4c693c3e1a7c760e42f870ccb2d35507fc51.tar.bz2
gentoo-2-a2ae4c693c3e1a7c760e42f870ccb2d35507fc51.zip
Fix dependencies, port to python eclass (bug #311765) and EAPI 3. Fix
building against new python versions (bug #276220). (Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/libopensync-plugin-python')
-rw-r--r--app-pda/libopensync-plugin-python/ChangeLog11
-rw-r--r--app-pda/libopensync-plugin-python/libopensync-plugin-python-0.22.ebuild24
-rw-r--r--app-pda/libopensync-plugin-python/libopensync-plugin-python-0.36.ebuild25
-rw-r--r--app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild25
4 files changed, 64 insertions, 21 deletions
diff --git a/app-pda/libopensync-plugin-python/ChangeLog b/app-pda/libopensync-plugin-python/ChangeLog
index e2681277525f..1687b178557b 100644
--- a/app-pda/libopensync-plugin-python/ChangeLog
+++ b/app-pda/libopensync-plugin-python/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/libopensync-plugin-python
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-python/ChangeLog,v 1.8 2009/11/15 23:51:39 eva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-python/ChangeLog,v 1.9 2011/02/20 03:40:57 dirtyepic Exp $
+
+ 20 Feb 2011; Ryan Hill <dirtyepic@gentoo.org>
+ libopensync-plugin-python-0.22.ebuild, libopensync-plugin-python-0.36.ebuild,
+ libopensync-plugin-python-9999.ebuild:
+ Fix dependencies, port to python eclass (bug #311765) and EAPI 3. Fix
+ building against new
+ python versions (bug #276220).
15 Nov 2009; Gilles Dartiguelongue <eva@gentoo.org>
-libopensync-plugin-python-0.21.ebuild,
diff --git a/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.22.ebuild b/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.22.ebuild
index be8996bc06c2..cb65ce3dd3a7 100644
--- a/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.22.ebuild
+++ b/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.22.ebuild
@@ -1,21 +1,31 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.22.ebuild,v 1.1 2007/03/28 20:22:10 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.22.ebuild,v 1.2 2011/02/20 03:40:57 dirtyepic Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+
+inherit python
DESCRIPTION="OpenSync Python Module"
HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://dev.gentooexperimental.org/~peper/distfiles/${P}.tar.bz2"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
LICENSE="LGPL-2.1"
IUSE=""
-DEPEND="=app-pda/libopensync-${PV}*
- >=dev-lang/python-2.0"
-RDEPEND="${DEPEND}"
+RDEPEND="~app-pda/libopensync-${PV}
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+pkg_setup() {
+ python_set_active_version 2
+}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog COPYING NEWS README
+ find "${D}" -name '*.la' -exec rm -f {} + || die
}
diff --git a/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.36.ebuild b/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.36.ebuild
index 8c31dd297f21..ffd96087ac55 100644
--- a/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.36.ebuild
+++ b/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.36.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.36.ebuild,v 1.1 2008/01/27 17:50:42 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.36.ebuild,v 1.2 2011/02/20 03:40:57 dirtyepic Exp $
-inherit cmake-utils
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+
+inherit cmake-utils python
DESCRIPTION="OpenSync Python Module"
HOMEPAGE="http://www.opensync.org/"
@@ -13,6 +16,16 @@ SLOT="0"
LICENSE="LGPL-2.1"
IUSE=""
-DEPEND="=app-pda/libopensync-${PV}*
- >=dev-lang/python-2.0"
-RDEPEND="${DEPEND}"
+RDEPEND="~app-pda/libopensync-${PV}
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # hardcoded python versions, use the module shipped with cmake (bug #276220)
+ rm "${S}"/cmake/modules/FindPythonLibs.cmake || die
+}
diff --git a/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild b/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild
index 07f248c04333..10b86f1ccb35 100644
--- a/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild
+++ b/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild,v 1.1 2007/11/26 20:23:01 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild,v 1.2 2011/02/20 03:40:57 dirtyepic Exp $
-inherit cmake-utils subversion
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+
+inherit cmake-utils python subversion
DESCRIPTION="OpenSync Python Module"
HOMEPAGE="http://www.opensync.org/"
@@ -15,6 +18,16 @@ SLOT="0"
LICENSE="LGPL-2.1"
IUSE=""
-DEPEND="=app-pda/libopensync-${PV}*
- >=dev-lang/python-2.0"
-RDEPEND="${DEPEND}"
+RDEPEND="~app-pda/libopensync-${PV}
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # hardcoded python versions, use the module shipped with cmake (bug #276220)
+ rm "${S}"/cmake/modules/FindPythonLibs.cmake || die
+}