summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-08-22 09:09:44 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-08-22 09:09:44 +0000
commit327658da928b5ed47bec4f2ee470b6996bc63d07 (patch)
tree0b295a4daaa57a4ba9cf389c7c06e0b87b749640 /app-pda/synce-gnomevfs
parent2.6.16 stable on ppc64; 2.6.17 now ~ppc64 (diff)
downloadgentoo-2-327658da928b5ed47bec4f2ee470b6996bc63d07.tar.gz
gentoo-2-327658da928b5ed47bec4f2ee470b6996bc63d07.tar.bz2
gentoo-2-327658da928b5ed47bec4f2ee470b6996bc63d07.zip
adding gcc4 patch to strip warnings (#135043)
(Portage version: 2.1-r2)
Diffstat (limited to 'app-pda/synce-gnomevfs')
-rw-r--r--app-pda/synce-gnomevfs/ChangeLog6
-rw-r--r--app-pda/synce-gnomevfs/files/0.9.0-gcc4.patch11
-rw-r--r--app-pda/synce-gnomevfs/synce-gnomevfs-0.9.0.ebuild10
3 files changed, 25 insertions, 2 deletions
diff --git a/app-pda/synce-gnomevfs/ChangeLog b/app-pda/synce-gnomevfs/ChangeLog
index a08224be760b..89d7b05def9d 100644
--- a/app-pda/synce-gnomevfs/ChangeLog
+++ b/app-pda/synce-gnomevfs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/synce-gnomevfs
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-gnomevfs/ChangeLog,v 1.11 2006/06/22 10:33:32 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-gnomevfs/ChangeLog,v 1.12 2006/08/22 09:09:43 liquidx Exp $
+
+ 22 Aug 2006; Alastair Tse <liquidx@gentoo.org> +files/0.9.0-gcc4.patch,
+ synce-gnomevfs-0.9.0.ebuild:
+ adding gcc4 patch to strip warnings (#135043)
22 Jun 2006; Karol Wojtaszek <sekretarz@gentoo.org>
synce-gnomevfs-0.9.0.ebuild:
diff --git a/app-pda/synce-gnomevfs/files/0.9.0-gcc4.patch b/app-pda/synce-gnomevfs/files/0.9.0-gcc4.patch
new file mode 100644
index 000000000000..25fb9994d474
--- /dev/null
+++ b/app-pda/synce-gnomevfs/files/0.9.0-gcc4.patch
@@ -0,0 +1,11 @@
+--- src/libsyncevfs.c 2006-07-17 14:35:29.000000000 +0200
++++ src/libsyncevfs.c 2006-07-17 14:35:29.000000000 +0200
+@@ -539,7 +539,7 @@
+ DIR_HANDLE *dh;
+ CE_FIND_DATA *data = NULL;
+ int optionflags;
+- int itemcount;
++ unsigned int itemcount;
+ WCHAR *tempwstr;
+ int index;
+
diff --git a/app-pda/synce-gnomevfs/synce-gnomevfs-0.9.0.ebuild b/app-pda/synce-gnomevfs/synce-gnomevfs-0.9.0.ebuild
index ee2f487ff6d7..5c130b29d433 100644
--- a/app-pda/synce-gnomevfs/synce-gnomevfs-0.9.0.ebuild
+++ b/app-pda/synce-gnomevfs/synce-gnomevfs-0.9.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-gnomevfs/synce-gnomevfs-0.9.0.ebuild,v 1.4 2006/06/22 10:33:32 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-gnomevfs/synce-gnomevfs-0.9.0.ebuild,v 1.5 2006/08/22 09:09:43 liquidx Exp $
+
+inherit eutils
DESCRIPTION="Synchronize Windows CE devices with Linux. GNOME Plugin for CE devices."
HOMEPAGE="http://sourceforge.net/projects/synce/"
@@ -18,6 +20,12 @@ RDEPEND=">=app-pda/synce-libsynce-0.9.0
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-gcc4.patch"
+}
+
src_compile() {
econf || die "econf failed"
emake || die "make failed"