summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-08 15:32:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-08 15:32:17 +0000
commite73486b83738a31c9c49c93f9d9b3fe0421315ae (patch)
treeb270cb51e55f8c4511bc4c4493157e2929c12c39 /app-pda/syncevolution
parentStable for HPPA (bug #350730). (diff)
downloadgentoo-2-e73486b83738a31c9c49c93f9d9b3fe0421315ae.tar.gz
gentoo-2-e73486b83738a31c9c49c93f9d9b3fe0421315ae.tar.bz2
gentoo-2-e73486b83738a31c9c49c93f9d9b3fe0421315ae.zip
Fix building with x11-libs/libnotify 0.5.x series wrt #354087 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/syncevolution')
-rw-r--r--app-pda/syncevolution/ChangeLog7
-rw-r--r--app-pda/syncevolution/files/syncevolution-1.1.1-libnotify-0.5.x.patch28
-rw-r--r--app-pda/syncevolution/syncevolution-1.1.1.ebuild9
3 files changed, 41 insertions, 3 deletions
diff --git a/app-pda/syncevolution/ChangeLog b/app-pda/syncevolution/ChangeLog
index 7efbd9e78570..b4bdbe924730 100644
--- a/app-pda/syncevolution/ChangeLog
+++ b/app-pda/syncevolution/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/syncevolution
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/syncevolution/ChangeLog,v 1.3 2011/01/10 03:58:46 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/syncevolution/ChangeLog,v 1.4 2011/02/08 15:32:16 ssuominen Exp $
+
+ 08 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ syncevolution-1.1.1.ebuild, +files/syncevolution-1.1.1-libnotify-0.5.x.patch:
+ Fix building with x11-libs/libnotify 0.5.x series wrt #354087 by Diego Elio
+ Pettenò.
*syncevolution-1.1.1 (10 Jan 2011)
diff --git a/app-pda/syncevolution/files/syncevolution-1.1.1-libnotify-0.5.x.patch b/app-pda/syncevolution/files/syncevolution-1.1.1-libnotify-0.5.x.patch
new file mode 100644
index 000000000000..ca24e48e583a
--- /dev/null
+++ b/app-pda/syncevolution/files/syncevolution-1.1.1-libnotify-0.5.x.patch
@@ -0,0 +1,28 @@
+--- src/syncevo-dbus-server.cpp
++++ src/syncevo-dbus-server.cpp
+@@ -64,6 +64,9 @@
+
+ #ifdef HAS_NOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ class DBusMessage;
+@@ -6108,10 +6111,11 @@
+ notify_notification_clear_actions(m_notification);
+ notify_notification_close(m_notification, NULL);
+ }
+-#if !defined(NOTIFY_CHECK_VERSION)
+- m_notification = notify_notification_new(summary, body, NULL, NULL);
+-#else // NOTIFY_CHECK_VERSION(0,7,0) is redundant, because 0.7.0 introduced NOTIFY_CHECK_VERSION
+- m_notification = notify_notification_new(summary, body, NULL);
++ m_notification = notify_notification_new(summary, body, NULL
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
+ #endif
+ //if actions are not supported, don't add actions
+ //An example is Ubuntu Notify OSD. It uses an alert box
diff --git a/app-pda/syncevolution/syncevolution-1.1.1.ebuild b/app-pda/syncevolution/syncevolution-1.1.1.ebuild
index 0e3a866dab94..48fa524d90fa 100644
--- a/app-pda/syncevolution/syncevolution-1.1.1.ebuild
+++ b/app-pda/syncevolution/syncevolution-1.1.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/syncevolution/syncevolution-1.1.1.ebuild,v 1.1 2011/01/10 03:58:46 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/syncevolution/syncevolution-1.1.1.ebuild,v 1.2 2011/02/08 15:32:16 ssuominen Exp $
EAPI=2
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="A SyncML desktop client and server"
HOMEPAGE="http://syncevolution.org/"
@@ -65,3 +65,8 @@ pkg_setup() {
G2CONF="${G2CONF} --enable-gui=no"
fi
}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.5.x.patch
+ gnome2_src_prepare
+}