summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2008-01-27 17:47:39 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2008-01-27 17:47:39 +0000
commitc0eb8da725bdc4e48cbc9a25b666d13817671b8a (patch)
treed3ab8843c821449b125eac552e8054d6a748ea9d /app-pda
parentversion bump (diff)
downloadgentoo-2-c0eb8da725bdc4e48cbc9a25b666d13817671b8a.tar.gz
gentoo-2-c0eb8da725bdc4e48cbc9a25b666d13817671b8a.tar.bz2
gentoo-2-c0eb8da725bdc4e48cbc9a25b666d13817671b8a.zip
Add 0.36.
(Portage version: 2.1.4)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libopensync-plugin-irmc/ChangeLog10
-rw-r--r--app-pda/libopensync-plugin-irmc/files/digest-libopensync-plugin-irmc-0.363
-rw-r--r--app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.36.ebuild52
3 files changed, 63 insertions, 2 deletions
diff --git a/app-pda/libopensync-plugin-irmc/ChangeLog b/app-pda/libopensync-plugin-irmc/ChangeLog
index 9c9e26ebac3b..ba5cb014e4ec 100644
--- a/app-pda/libopensync-plugin-irmc/ChangeLog
+++ b/app-pda/libopensync-plugin-irmc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/libopensync-plugin-irmc
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-irmc/ChangeLog,v 1.7 2007/12/21 23:14:39 peper Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-irmc/ChangeLog,v 1.8 2008/01/27 17:47:38 peper Exp $
+
+*libopensync-plugin-irmc-0.36 (27 Jan 2008)
+
+ 27 Jan 2008; Piotr Jaroszyński <peper@gentoo.org>
+ +libopensync-plugin-irmc-0.36.ebuild:
+ Add 0.36.
*libopensync-plugin-irmc-0.35 (21 Dec 2007)
diff --git a/app-pda/libopensync-plugin-irmc/files/digest-libopensync-plugin-irmc-0.36 b/app-pda/libopensync-plugin-irmc/files/digest-libopensync-plugin-irmc-0.36
new file mode 100644
index 000000000000..7c4db0127888
--- /dev/null
+++ b/app-pda/libopensync-plugin-irmc/files/digest-libopensync-plugin-irmc-0.36
@@ -0,0 +1,3 @@
+MD5 21f9789fa41c2f06c547a17bc13c6081 libopensync-plugin-irmc-0.36.tar.bz2 50009
+RMD160 e180f1de51574495ca84aba868c5c5b0ade0446a libopensync-plugin-irmc-0.36.tar.bz2 50009
+SHA256 f7ccff0bc136d3aa21ab961f31414f4856a94e9f1a1b17c44c8ec33b67ace4ac libopensync-plugin-irmc-0.36.tar.bz2 50009
diff --git a/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.36.ebuild b/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.36.ebuild
new file mode 100644
index 000000000000..6aa7546bb6bb
--- /dev/null
+++ b/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.36.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.36.ebuild,v 1.1 2008/01/27 17:47:38 peper Exp $
+
+inherit eutils cmake-utils
+
+DESCRIPTION="OpenSync IrMC plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="bluetooth irda"
+
+DEPEND="=app-pda/libopensync-${PV}*
+ >=dev-libs/openobex-1.0
+ bluetooth? ( net-wireless/bluez-libs )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! use irda && ! use bluetooth; then
+ eerror "${CATEGORY}/${P} without support for bluetooth nor irda is unusable."
+ eerror "Please enable \"bluetooth\" or/and \"irda\" USE flags."
+ die "Please enable \"bluetoot\" or/and \"irda\" USE flags."
+ fi
+
+ if use bluetooth && ! built_with_use dev-libs/openobex bluetooth; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "USE flag, but dev-libs/openobex was built without"
+ eerror "the \"bluetooth\" USE flag."
+ eerror "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ die "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ fi
+
+ if use irda && ! built_with_use dev-libs/openobex irda; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"irda\""
+ eerror "USE flag, but dev-libs/openobex was built without"
+ eerror "the \"irda\" USE flag."
+ eerror "Please rebuild dev-libs/openobex with \"irda\" USE flag."
+ die "Please rebuild dev-libs/openobex with \"irda\" USE flag."
+ fi
+}
+
+src_compile() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable bluetooth BLUETOOTH)
+ $(cmake-utils_use_enable irda IRDA)"
+
+ cmake-utils_src_compile
+}