summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-26 12:24:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-26 12:24:05 +0000
commitd424c6b24648897431ab4ddfbc895987e1b226d8 (patch)
tree21847ccf4297bd2e4fcdf64d198645faac9a0b09 /app-pda
parentEAPI bump (diff)
downloadgentoo-2-d424c6b24648897431ab4ddfbc895987e1b226d8.tar.gz
gentoo-2-d424c6b24648897431ab4ddfbc895987e1b226d8.tar.bz2
gentoo-2-d424c6b24648897431ab4ddfbc895987e1b226d8.zip
old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libimobiledevice/ChangeLog9
-rw-r--r--app-pda/libimobiledevice/files/libimobiledevice-1.1.4-HOME-segfault.patch15
-rw-r--r--app-pda/libimobiledevice/files/libimobiledevice-1.1.4-openssl.patch49
-rw-r--r--app-pda/libimobiledevice/files/libimobiledevice-1.1.4-property_list_service-do-not-strip-non-ASCII-charact.patch27
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.1.4-r4.ebuild57
5 files changed, 8 insertions, 149 deletions
diff --git a/app-pda/libimobiledevice/ChangeLog b/app-pda/libimobiledevice/ChangeLog
index eabdcefffc8a..ea17d8d2c63c 100644
--- a/app-pda/libimobiledevice/ChangeLog
+++ b/app-pda/libimobiledevice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/libimobiledevice
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.54 2014/05/30 18:37:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.55 2014/07/26 12:24:05 ssuominen Exp $
+
+ 26 Jul 2014; Samuli Suominen <ssuominen@gentoo.org>
+ -files/libimobiledevice-1.1.4-HOME-segfault.patch,
+ -files/libimobiledevice-1.1.4-openssl.patch, -files/libimobiledevice-1.1.4-pro
+ perty_list_service-do-not-strip-non-ASCII-charact.patch,
+ -libimobiledevice-1.1.4-r4.ebuild:
+ old
30 May 2014; Samuli Suominen <ssuominen@gentoo.org>
libimobiledevice-1.1.6.ebuild:
diff --git a/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-HOME-segfault.patch b/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-HOME-segfault.patch
deleted file mode 100644
index 1dc82b763aab..000000000000
--- a/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-HOME-segfault.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=423155#c3
-http://libiphone.lighthouseapp.com/projects/27916-libiphone/tickets/265
-
---- src/userpref.c
-+++ src/userpref.c
-@@ -125,6 +125,9 @@
- const char *cdir = getenv("XDG_CONFIG_HOME");
- if (!cdir) {
- cdir = getenv("HOME");
-+ if (!cdir) {
-+ cdir="/root";
-+ }
- strcpy(__config_dir, cdir);
- strcat(__config_dir, DIR_SEP_S);
- strcat(__config_dir, ".config");
diff --git a/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-openssl.patch b/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-openssl.patch
deleted file mode 100644
index dbb052c04080..000000000000
--- a/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-openssl.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 54dad58468a9879fb44aff0d760bbd6c3288b812 Mon Sep 17 00:00:00 2001
-From: Nikias Bassen
-Date: Wed, 18 Apr 2012 15:07:04 +0000
-Subject: idevice: fix openssl initialization and handle error to avoid crash
-
----
-diff --git a/src/idevice.c b/src/idevice.c
-index 91d67e6..a1cc013 100644
---- a/src/idevice.c
-+++ b/src/idevice.c
-@@ -559,6 +559,7 @@ static void internal_ssl_cleanup(ssl_data_t ssl_data)
- if (ssl_data->ctx) {
- SSL_CTX_free(ssl_data->ctx);
- }
-+ openssl_init_done = 0;
- #else
- if (ssl_data->session) {
- gnutls_deinit(ssl_data->session);
-@@ -667,6 +668,11 @@ idevice_error_t idevice_connection_enable_ssl(idevice_connection_t connection)
- }
-
- /* Set up OpenSSL */
-+ if (openssl_init_done == 0) {
-+ SSL_library_init();
-+ openssl_init_done = 1;
-+ }
-+
- BIO *ssl_bio = BIO_new(BIO_s_socket());
- if (!ssl_bio) {
- debug_info("ERROR: Could not create SSL bio.");
-@@ -674,11 +680,12 @@ idevice_error_t idevice_connection_enable_ssl(idevice_connection_t connection)
- }
- BIO_set_fd(ssl_bio, (int)(long)connection->data, BIO_NOCLOSE);
-
-- if (openssl_init_done == 0) {
-- SSL_library_init();
-- openssl_init_done = 1;
-- }
- SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv3_method());
-+ if (ssl_ctx == NULL) {
-+ debug_info("ERROR: Could not create SSL context.");
-+ BIO_free(ssl_bio);
-+ return ret;
-+ }
-
- BIO* membp;
- X509* rootCert = NULL;
---
-cgit v0.8.3.1-34-gbf3d
diff --git a/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-property_list_service-do-not-strip-non-ASCII-charact.patch b/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-property_list_service-do-not-strip-non-ASCII-charact.patch
deleted file mode 100644
index 7711839bb0a7..000000000000
--- a/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-property_list_service-do-not-strip-non-ASCII-charact.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 060e3f2683ed2b0b08e1a31deb9608a99e193b4a Mon Sep 17 00:00:00 2001
-From: Christophe Fergeau <teuf@gnome.org>
-Date: Tue, 26 Jun 2012 00:03:30 +0200
-Subject: [PATCH] property_list_service: do not strip non-ASCII characters from
- XML plists
-
-'content' is declared as char content[] so if char is signed, all characters with the high bit set will be negative so they will be < 0x20. This means the code will strip all non-ASCII (multi-byte) UTF-8 characters and replace them with spaces. This commit fixes it now by really only considering ASCII characters.
----
- src/property_list_service.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/property_list_service.c b/src/property_list_service.c
-index 8634864..c9a8edf 100644
---- a/src/property_list_service.c
-+++ b/src/property_list_service.c
-@@ -250,7 +250,7 @@ static property_list_service_error_t internal_plist_receive_timeout(property_lis
- } else {
- /* iOS 4.3+ hack: plist data might contain invalid characters, thus we convert those to spaces */
- for (bytes = 0; bytes < pktlen-1; bytes++) {
-- if ((content[bytes] < 0x20) && (content[bytes] != 0x09) && (content[bytes] != 0x0a) && (content[bytes] != 0x0d))
-+ if ((content[bytes] >= 0) && (content[bytes] < 0x20) && (content[bytes] != 0x09) && (content[bytes] != 0x0a) && (content[bytes] != 0x0d))
- content[bytes] = 0x20;
- }
- plist_from_xml(content, pktlen, plist);
---
-1.8.1.2
-
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.1.4-r4.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.1.4-r4.ebuild
deleted file mode 100644
index fa69b5d785c4..000000000000
--- a/app-pda/libimobiledevice/libimobiledevice-1.1.4-r4.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.1.4-r4.ebuild,v 1.5 2014/03/01 22:19:35 mgorny Exp $
-
-EAPI=5
-inherit autotools eutils
-
-DESCRIPTION="Support library to communicate with Apple iPhone/iPod Touch devices"
-HOMEPAGE="http://www.libimobiledevice.org/"
-SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
-IUSE="gnutls"
-
-RDEPEND=">=app-pda/libplist-1.8-r1
- >=app-pda/usbmuxd-1.0.8
- gnutls? (
- dev-libs/libgcrypt:0
- >=dev-libs/libtasn1-1.1
- >=net-libs/gnutls-2.2.0
- )
- !gnutls? ( dev-libs/openssl:0 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS="AUTHORS NEWS README"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-openssl.patch \
- "${FILESDIR}"/${P}-HOME-segfault.patch \
- "${FILESDIR}"/${P}-property_list_service-do-not-strip-non-ASCII-charact.patch
-
- eautoreconf
-}
-
-src_configure() {
- # Disable python support wrt #451044, look at -1.1.4-r2
- # from Attic if you need to restore it.
-
- local myconf
- use gnutls && myconf='--disable-openssl'
-
- econf \
- --disable-static \
- --without-cython \
- ${myconf}
-}
-
-src_install() {
- default
- dohtml docs/html/*
-
- prune_libtool_files --all
-}