summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2007-12-21 23:02:26 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2007-12-21 23:02:26 +0000
commiteac94a8508e213a3802f727742fd514d27036ad1 (patch)
treeda7bf137ccf37b154e2b127284383eccdbaee18e /app-pda
parentremove old version - fix quoting (diff)
downloadgentoo-2-eac94a8508e213a3802f727742fd514d27036ad1.tar.gz
gentoo-2-eac94a8508e213a3802f727742fd514d27036ad1.tar.bz2
gentoo-2-eac94a8508e213a3802f727742fd514d27036ad1.zip
Add 0.35.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libopensync/ChangeLog8
-rw-r--r--app-pda/libopensync/files/digest-libopensync-0.353
-rw-r--r--app-pda/libopensync/libopensync-0.35.ebuild58
-rw-r--r--app-pda/libopensync/libopensync-9999.ebuild12
4 files changed, 77 insertions, 4 deletions
diff --git a/app-pda/libopensync/ChangeLog b/app-pda/libopensync/ChangeLog
index 09f4830f3a20..d61be6d9c93d 100644
--- a/app-pda/libopensync/ChangeLog
+++ b/app-pda/libopensync/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/libopensync
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/ChangeLog,v 1.21 2007/11/26 20:12:07 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/ChangeLog,v 1.22 2007/12/21 23:02:25 peper Exp $
+
+*libopensync-0.35 (21 Dec 2007)
+
+ 21 Dec 2007; Piotr Jaroszyński <peper@gentoo.org>
+ +libopensync-0.35.ebuild, libopensync-9999.ebuild:
+ Add 0.35.
*libopensync-9999 (26 Nov 2007)
diff --git a/app-pda/libopensync/files/digest-libopensync-0.35 b/app-pda/libopensync/files/digest-libopensync-0.35
new file mode 100644
index 000000000000..0a163cc43784
--- /dev/null
+++ b/app-pda/libopensync/files/digest-libopensync-0.35
@@ -0,0 +1,3 @@
+MD5 a2f9d32126460f23164957722d9dc769 libopensync-0.35.tar.bz2 863792
+RMD160 8a06ffeba1a0cddc40a57f0bff7e5909ede77d4c libopensync-0.35.tar.bz2 863792
+SHA256 cc2cc8c40b136f7f29c4a2ed7869300e3a0ba2eda3afe494df2c9e2161f28083 libopensync-0.35.tar.bz2 863792
diff --git a/app-pda/libopensync/libopensync-0.35.ebuild b/app-pda/libopensync/libopensync-0.35.ebuild
new file mode 100644
index 000000000000..d14eb87b5f91
--- /dev/null
+++ b/app-pda/libopensync/libopensync-0.35.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.35.ebuild,v 1.1 2007/12/21 23:02:25 peper Exp $
+
+inherit cmake-utils eutils
+
+DESCRIPTION="OpenSync synchronisation framework library"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="debug doc python"
+
+# Tests don't pass
+#>=dev-libs/check-0.9.2
+#mycmakeargs="${mycmakeargs} -DOPENSYNC_UNITTESTS=ON"
+RESTRICT="test"
+
+RDEPEND=">=dev-db/sqlite-3
+ >=dev-libs/glib-2
+ dev-libs/libxml2
+ python? ( >=dev-lang/python-2.2 >=dev-lang/swig-1.3.17 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ local mycmakeargs
+ mycmakeargs="${mycmakeargs} -DCMAKE_SKIP_RPATH=ON"
+ mycmakeargs="${mycmakeargs} -DOPENSYNC_TRACE=$(use debug && echo ON || echo OFF)"
+ mycmakeargs="${mycmakeargs} -DOPENSYNC_DEBUG_MODULES=$(use debug && echo ON || echo OFF)"
+ mycmakeargs="${mycmakeargs} -DOPENSYNC_PYTHONBINDINGS=$(use python && echo ON || echo OFF)"
+ mycmakeargs="${mycmakeargs} -DBUILD_DOCUMENTATION=$(use doc && echo ON || echo OFF)"
+ cmake-utils_src_compile
+
+ if use doc ; then
+ cd "${WORKDIR}/${PN}_build"
+ doxygen Doxyfile || die "Failed to generate docs."
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc ; then
+ cd "${WORKDIR}/${PN}_build"
+ dohtml docs/html/* || die "Failed to install docs."
+ fi
+}
+
+pkg_postinst() {
+ elog "Building with 'debug' useflag is highly encouraged"
+ elog "and requiered for bug reports."
+ elog "Also see http://www.opensync.org/wiki/tracing"
+}
diff --git a/app-pda/libopensync/libopensync-9999.ebuild b/app-pda/libopensync/libopensync-9999.ebuild
index cc112f63fd2c..145fd6278131 100644
--- a/app-pda/libopensync/libopensync-9999.ebuild
+++ b/app-pda/libopensync/libopensync-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-9999.ebuild,v 1.1 2007/11/26 20:12:07 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-9999.ebuild,v 1.2 2007/12/21 23:02:25 peper Exp $
inherit cmake-utils eutils subversion
@@ -38,13 +38,19 @@ src_compile() {
mycmakeargs="${mycmakeargs} -DBUILD_DOCUMENTATION=$(use doc && echo ON || echo OFF)"
cmake-utils_src_compile
- use doc && doxygen Doxyfile
+ if use doc ; then
+ cd "${WORKDIR}/${PN}_build"
+ doxygen Doxyfile || die "Failed to generate docs."
+ fi
}
src_install() {
cmake-utils_src_install
- use doc && dohtml docs/html/*
+ if use doc ; then
+ cd "${WORKDIR}/${PN}_build"
+ dohtml docs/html/* || die "Failed to install docs."
+ fi
}
pkg_postinst() {