summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2013-01-21 21:59:34 +0000
committerPaul Varner <fuzzyray@gentoo.org>2013-01-21 21:59:34 +0000
commit11e00fdea55e41f38831c25706a51f58d95188b2 (patch)
treedd230d75e1eca77ce4aa7a6ad66328b1e094d34a /app-portage
parent2.2.0_alpha159 version bump. This includes all of the fixes in 2.1.11.48. (diff)
downloadgentoo-2-11e00fdea55e41f38831c25706a51f58d95188b2.tar.gz
gentoo-2-11e00fdea55e41f38831c25706a51f58d95188b2.tar.bz2
gentoo-2-11e00fdea55e41f38831c25706a51f58d95188b2.zip
Fix bug 453382 where genlop <pkg name> did not display package merge information.
(Portage version: 2.1.11.47/cvs/Linux x86_64, signed Manifest commit with key 0x4D269A1B)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/genlop/ChangeLog9
-rw-r--r--app-portage/genlop/files/genlop-0.30.9-display.patch26
-rw-r--r--app-portage/genlop/genlop-0.30.9-r1.ebuild31
3 files changed, 65 insertions, 1 deletions
diff --git a/app-portage/genlop/ChangeLog b/app-portage/genlop/ChangeLog
index 5a3cab236ddc..8e06297dcf15 100644
--- a/app-portage/genlop/ChangeLog
+++ b/app-portage/genlop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/genlop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/genlop/ChangeLog,v 1.81 2013/01/19 03:23:42 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/genlop/ChangeLog,v 1.82 2013/01/21 21:59:34 fuzzyray Exp $
+
+*genlop-0.30.9-r1 (21 Jan 2013)
+
+ 21 Jan 2013; Paul Varner <fuzzyray@gentoo.org> +genlop-0.30.9-r1.ebuild,
+ +files/genlop-0.30.9-display.patch:
+ Fix bug 453382 where genlop <pkg name> did not display package merge
+ information.
*genlop-0.30.9 (18 Jan 2013)
diff --git a/app-portage/genlop/files/genlop-0.30.9-display.patch b/app-portage/genlop/files/genlop-0.30.9-display.patch
new file mode 100644
index 000000000000..cd9919ee3a27
--- /dev/null
+++ b/app-portage/genlop/files/genlop-0.30.9-display.patch
@@ -0,0 +1,26 @@
+From 76cb98e439c65b5ec8d32d809100a67c653e5635 Mon Sep 17 00:00:00 2001
+From: Paul Varner <fuzzyray@gentoo.org>
+Date: Mon, 21 Jan 2013 15:37:19 -0600
+Subject: [PATCH] Fix issue where genlop <pkg name> no longer displays merge
+ information (Bug 453382).
+
+---
+ genlop | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/genlop b/genlop
+index 52af5ed..d5020eb 100755
+--- a/genlop
++++ b/genlop
+@@ -1127,7 +1127,7 @@ foreach my $ebuild_arg (@targets)
+ }
+ }
+ }
+- if ($list_found or $ebuild_found or $time_found)
++ if ($list_found or $ebuild_found or $time_found or !$info_found)
+ {
+ my $eb = $2;
+ my $extra = $3 || "";
+--
+1.8.1.1
+
diff --git a/app-portage/genlop/genlop-0.30.9-r1.ebuild b/app-portage/genlop/genlop-0.30.9-r1.ebuild
new file mode 100644
index 000000000000..490c7ad4b0bb
--- /dev/null
+++ b/app-portage/genlop/genlop-0.30.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/genlop/genlop-0.30.9-r1.ebuild,v 1.1 2013/01/21 21:59:34 fuzzyray Exp $
+
+EAPI="5"
+
+inherit base bash-completion-r1
+
+DESCRIPTION="A nice emerge.log parser"
+HOMEPAGE="http://www.gentoo.org/proj/en/perl"
+SRC_URI="mirror://gentoo//${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-perl/DateManip
+ dev-perl/libwww-perl"
+RDEPEND="${DEPEND}"
+
+# Populate the patches array for any patches for -rX releases
+PATCHES=( "${FILESDIR}"/${P}-display.patch )
+
+src_install() {
+ dobin genlop || die "failed to install genlop (via dobin)"
+ dodoc README Changelog
+ doman genlop.1
+ newbashcomp genlop.bash-completion genlop
+}