summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2012-06-20 20:09:15 +0000
committerPaul Varner <fuzzyray@gentoo.org>2012-06-20 20:09:15 +0000
commit1c3c83b2ff28da95acc8767ad2ae8bdf53a4d25e (patch)
tree5ac2fb0ccc58cc70f9c51faa21b7917bf8deb340 /app-portage
parentarm stable, bug #410273 (diff)
downloadgentoo-2-1c3c83b2ff28da95acc8767ad2ae8bdf53a4d25e.tar.gz
gentoo-2-1c3c83b2ff28da95acc8767ad2ae8bdf53a4d25e.tar.bz2
gentoo-2-1c3c83b2ff28da95acc8767ad2ae8bdf53a4d25e.zip
Revision bump to add patch for euse to support the md5-dict metadata cache
format. (Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/ChangeLog9
-rw-r--r--app-portage/gentoolkit/files/0.3.0.6-euse-422675.patch67
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.3.0.6-r3.ebuild98
3 files changed, 173 insertions, 1 deletions
diff --git a/app-portage/gentoolkit/ChangeLog b/app-portage/gentoolkit/ChangeLog
index 4bd8c02bf2e1..d1890719ba60 100644
--- a/app-portage/gentoolkit/ChangeLog
+++ b/app-portage/gentoolkit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/gentoolkit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.265 2012/05/28 13:49:53 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.266 2012/06/20 20:09:15 fuzzyray Exp $
+
+*gentoolkit-0.3.0.6-r3 (20 Jun 2012)
+
+ 20 Jun 2012; Paul Varner <fuzzyray@gentoo.org> +gentoolkit-0.3.0.6-r3.ebuild,
+ +files/0.3.0.6-euse-422675.patch:
+ Revision bump to add patch for euse to support the md5-dict metadata cache
+ format.
28 May 2012; Raúl Porcel <armin76@gentoo.org> gentoolkit-0.3.0.5.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #411479
diff --git a/app-portage/gentoolkit/files/0.3.0.6-euse-422675.patch b/app-portage/gentoolkit/files/0.3.0.6-euse-422675.patch
new file mode 100644
index 000000000000..9be4ed652068
--- /dev/null
+++ b/app-portage/gentoolkit/files/0.3.0.6-euse-422675.patch
@@ -0,0 +1,67 @@
+From 6b94fbd3b74471cf9740a35d669963e0b6c84eac Mon Sep 17 00:00:00 2001
+From: Paul Varner <fuzzyray@gentoo.org>
+Date: Wed, 20 Jun 2012 12:11:44 -0500
+Subject: [PATCH] Add support for the md5-cache metadata format. (Bug 422675)
+
+The gentoo tree is moving to the md5-cache format instead of pms. This
+add support for reading the md5-cache metadata format.
+---
+ bin/euse | 24 ++++++++++++++++++------
+ 1 files changed, 18 insertions(+), 6 deletions(-)
+
+diff --git a/bin/euse b/bin/euse
+index 85ff924..3b7556f 100755
+--- a/bin/euse
++++ b/bin/euse
+@@ -385,6 +385,7 @@ get_useflaglist() {
+ #
+ get_useflaglist_ebuild() {
+ local known=$(echo "${ACTIVE_FLAGS[5]}" | egrep "^${1}")
++ local cacheformat
+ if [[ -n $known ]]; then
+ # No need to recache
+ return
+@@ -400,23 +401,34 @@ get_useflaglist_ebuild() {
+ fi
+ # Open the ebuild file and retrieve defined USE flags
+ [[ ! -d "$portdir/${1}" ]] && continue
+- if [[ ! -d "$portdir/metadata/cache" ]]; then
++ cacheformat="unknown"
++ [[ -d "$portdir/metadata/cache" ]] && cacheformat="cache" # format is pms
++ [[ -d "$portdir/metadata/md5-cache" ]] && cacheformat="md5-cache" # format is md5-cache
++ if [[ "$cacheformat" == "unknown" ]]; then
+ echo "!!! Metadata cache not found. You need to run " >&2
+ echo "!!! 'egencache --repo=$overlay --update'" >&2
+ echo "!!! to generate metadata for your overlays" >&2
+ return 1
+ fi
+- append=$(set +f; ls $portdir/metadata/cache/${1}-* \
++ append=$(set +f; ls ${portdir}/metadata/${cacheformat}/${1}-* \
+ | egrep "${1}-[0-9.]+" \
+- | sed -e "s:$portdir/metadata/cache/${1}-::g" \
++ | sed -e "s:${portdir}/metadata/${cacheformat}/${1}-::g" \
+ | while read -d $'\n' version; do
+ IFS=$'\n'
+- if [[ ! -e "$portdir/metadata/cache/${1}-$version" ]]; then
++ if [[ ! -e "${portdir}/metadata/${cacheformat}/${1}-$version" ]]; then
+ # Repo does not have this particular package
+ continue
+ fi
+- iuse=$(head -11 "$portdir/metadata/cache/${1}-$version"|tail -1)
+- slot=$(head -3 "$portdir/metadata/cache/${1}-$version"|tail -1)
++ if [[ "${cacheformat}" == "cache" ]]; then
++ iuse=$(head -n 11 "${portdir}/metadata/${cacheformat}/${1}-$version"|tail -n 1)
++ slot=$(head -n 3 "${portdir}/metadata/${cacheformat}/${1}-$version"|tail -n 1)
++ elif [[ "${cacheformat}" == "md5-cache" ]]; then
++ iuse=$(grep "^IUSE=" "${portdir}/metadata/${cacheformat}/${1}-$version" | sed 's/^IUSE=//')
++ slot=$(grep "^SLOT=" "${portdir}/metadata/${cacheformat}/${1}-$version" | sed 's/^SLOT=//')
++ else
++ # This is a bug, we should have already returned
++ return 1
++ fi
+ echo "${1};${version};${slot};${iuse};${overlay}"
+ done
+ )
+--
+1.7.8.6
+
diff --git a/app-portage/gentoolkit/gentoolkit-0.3.0.6-r3.ebuild b/app-portage/gentoolkit/gentoolkit-0.3.0.6-r3.ebuild
new file mode 100644
index 000000000000..b7d6e57ce0cd
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.3.0.6-r3.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/gentoolkit-0.3.0.6-r3.ebuild,v 1.1 2012/06/20 20:09:15 fuzzyray Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45]"
+PYTHON_USE_WITH="xml"
+PYTHON_NONVERSIONED_EXECUTABLES=(".*")
+
+inherit distutils python eutils
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/tools/index.xml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Note: argparse is provided in python 2.7 and 3.2 (Bug 346005)
+# Note: dev-lang/python dependencies are so emerge will print a blocker if any
+# installed slot of python is not built with +xml. This is used since
+# PYTHON_USE_WITH just dies in the middle of the emerge. See bug 399331.
+DEPEND="sys-apps/portage"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.6[xml]
+ !>=dev-lang/python-2.6[-xml]
+ !<=app-portage/gentoolkit-dev-0.2.7
+ dev-python/argparse
+ || ( >=sys-apps/coreutils-8.15 app-misc/realpath sys-freebsd/freebsd-bin )
+ sys-apps/gawk
+ sys-apps/grep"
+
+distutils_src_compile_pre_hook() {
+ echo VERSION="${PVR}" "$(PYTHON)" setup.py set_version
+ VERSION="${PVR}" "$(PYTHON)" setup.py set_version \
+ || die "setup.py set_version failed"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-eread-413577.patch"
+ epatch "${FILESDIR}/${PV}-eshowkw-414627.patch"
+ epatch "${FILESDIR}/${PV}-gentoolkit-304125.patch"
+ epatch "${FILESDIR}/${PV}-euse-410365.patch"
+ epatch "${FILESDIR}/${PV}-eshowkw-409449.patch"
+ epatch "${FILESDIR}/${PV}-euse-422675.patch"
+}
+
+src_install() {
+ python_convert_shebangs -r "" build-*/scripts-*
+ distutils_src_install
+
+ # Rename the python versions of revdep-rebuild, since we are not ready
+ # to switch to the python version yet. Link /usr/bin/revdep-rebuild to
+ # revdep-rebuild.sh. Leaving the python version available for potential
+ # testing by a wider audience.
+ mv "${ED}"/usr/bin/revdep-rebuild "${ED}"/usr/bin/revdep-rebuild.py
+ dosym revdep-rebuild.sh /usr/bin/revdep-rebuild
+
+ # Create cache directory for revdep-rebuild
+ dodir /var/cache/revdep-rebuild
+ keepdir /var/cache/revdep-rebuild
+ use prefix || fowners root:root /var/cache/revdep-rebuild
+ fperms 0700 /var/cache/revdep-rebuild
+
+ # remove on Gentoo Prefix platforms where it's broken anyway
+ if use prefix; then
+ elog "The revdep-rebuild command is removed, the preserve-libs"
+ elog "feature of portage will handle issues."
+ rm "${ED}"/usr/bin/revdep-rebuild
+ rm "${ED}"/usr/bin/revdep-rebuild.py
+ rm "${ED}"/usr/share/man/man1/revdep-rebuild.1
+ rm -rf "${ED}"/etc/revdep-rebuild
+ rm -rf "${ED}"/var
+ fi
+
+ # Can distutils handle this?
+ dosym eclean /usr/bin/eclean-dist
+ dosym eclean /usr/bin/eclean-pkg
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo
+ einfo "For further information on gentoolkit, please read the gentoolkit"
+ einfo "guide: http://www.gentoo.org/doc/en/gentoolkit.xml"
+ einfo
+ einfo "Another alternative to equery is app-portage/portage-utils"
+ ewarn
+ ewarn "glsa-check since gentoolkit 0.3 has modified some output,"
+ ewarn "options and default behavior. The list of injected GLSAs"
+ ewarn "has moved to /var/lib/portage/glsa_injected, please"
+ ewarn "run 'glsa-check -p affected' before copying the existing checkfile."
+}