summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2013-10-06 16:51:01 +0000
committerDaniel Pielmeier <billie@gentoo.org>2013-10-06 16:51:01 +0000
commit3e7f1b6e75b22e1073ef6ff15bc2995aec4a5e0a (patch)
tree1628d44ca1bb7fbd690860afdaaf0da48cb6b3a1 /app-portage
parentInitial commit of 0.2.x branch, a complete rewrite in python (diff)
downloadgentoo-2-3e7f1b6e75b22e1073ef6ff15bc2995aec4a5e0a.tar.gz
gentoo-2-3e7f1b6e75b22e1073ef6ff15bc2995aec4a5e0a.tar.bz2
gentoo-2-3e7f1b6e75b22e1073ef6ff15bc2995aec4a5e0a.zip
Version bump. Fixes bug #420111, thanks to Jeroen Roovers for the patch. Fixed bug #481296, thanks to Alice Ferrazzi for the report and Daniel for the fix.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 215AD14D)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pfl/ChangeLog10
-rw-r--r--app-portage/pfl/files/e-file-20110906-portageq.patch44
-rw-r--r--app-portage/pfl/pfl-2.4.ebuild46
3 files changed, 99 insertions, 1 deletions
diff --git a/app-portage/pfl/ChangeLog b/app-portage/pfl/ChangeLog
index faa0c04586f8..30dc535d2cfb 100644
--- a/app-portage/pfl/ChangeLog
+++ b/app-portage/pfl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-portage/pfl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/ChangeLog,v 1.54 2013/08/20 22:08:33 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/ChangeLog,v 1.55 2013/10/06 16:51:01 billie Exp $
+
+*pfl-2.4 (06 Oct 2013)
+
+ 06 Oct 2013; Daniel Pielmeier <billie@gentoo.org> +pfl-2.4.ebuild,
+ +files/e-file-20110906-portageq.patch:
+ Version bump. Fixes bug #420111, thanks to Jeroen Roovers for the patch.
+ Fixed bug #481296, thanks to Alice Ferrazzi for the report and Daniel for the
+ fix.
20 Aug 2013; Sébastien Fabbro <bicatali@gentoo.org> pfl-2.3-r3.ebuild:
Keyword amd64-linux and x86-linux
diff --git a/app-portage/pfl/files/e-file-20110906-portageq.patch b/app-portage/pfl/files/e-file-20110906-portageq.patch
new file mode 100644
index 000000000000..608c9e5962e3
--- /dev/null
+++ b/app-portage/pfl/files/e-file-20110906-portageq.patch
@@ -0,0 +1,44 @@
+--- bin/e-file
++++ bin/e-file
+@@ -16,11 +16,11 @@
+ exit 1
+ fi
+
+-if type emerge >/dev/null 2>&1; then
++if type portageq >/dev/null 2>&1; then
+ isgentoo=1
+ else
+ isgentoo=0
+- echo 'WARNING: "emerge" no found. If your system is not gentoo, a part of function will not available!' >&2
++ echo 'WARNING: "portageq" no found. If your system is not gentoo, a part of function will not available!' >&2
+ fi
+
+ URL="http://www.portagefilelist.de/index.php/Special:PFLQuery2?file=$1&searchfile=lookup&lookup=file&txt"
+@@ -29,8 +29,7 @@
+ BEGIN{
+ FOUND=0
+ if(isgentoo){
+- "emerge --info | grep PORTDIR" | getline
+- split($0,PORTDIR,/\"/)
++ "portageq envvar / PORTDIR" | getline PORTDIR
+ }
+ }
+ {
+@@ -75,7 +74,7 @@
+ }
+
+ NF=0
+- cmd="(grep -h HOMEPAGE\\= " PORTDIR[2] "/" pkg "/*.ebuild | tail -n 1)2>/dev/null"
++ cmd="(grep -h HOMEPAGE\\= " PORTDIR "/" pkg "/*.ebuild | tail -n 1)2>/dev/null"
+ cmd | getline
+ if(NF==0){
+ HOMEPAGE=""
+@@ -85,7 +84,7 @@
+ }
+
+ NF=0
+- cmd="(grep -h DESCRIPTION " PORTDIR[2] "/" pkg "/*.ebuild | tail -n 1)2>/dev/null"
++ cmd="(grep -h DESCRIPTION " PORTDIR "/" pkg "/*.ebuild | tail -n 1)2>/dev/null"
+ cmd | getline
+ if(NF==0){
+ DESCRIPTION=""
diff --git a/app-portage/pfl/pfl-2.4.ebuild b/app-portage/pfl/pfl-2.4.ebuild
new file mode 100644
index 000000000000..9a1f248dd3d9
--- /dev/null
+++ b/app-portage/pfl/pfl-2.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/pfl-2.4.ebuild,v 1.1 2013/10/06 16:51:01 billie Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="xml"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de"
+SRC_URI="http://files.portagefilelist.de/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x64-freebsd ~x86-linux"
+IUSE="+network-cron"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ net-misc/curl
+ sys-apps/portage"
+
+src_prepare() {
+ epatch "${FILESDIR}"/e-file-20110906-portageq.patch
+}
+
+python_install_all() {
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ keepdir /var/lib/${PN}
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT%/}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT%/}/var/lib/${PN}/pfl.info"
+ chown -R 0:portage "${EROOT%/}/var/lib/${PN}"
+ chmod 775 "${EROOT%/}/var/lib/${PN}"
+ fi
+}