summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2014-05-22 15:41:38 +0000
committerPaul Varner <fuzzyray@gentoo.org>2014-05-22 15:41:38 +0000
commit416caa1f7e52f01ec225ca9d635e0d36cc9c387d (patch)
treef2260b3c48d11f46a89f5d046b56741f1c1c2c64 /app-portage
parentRevbumps. Cleaned up ebuilds a bit. Moved apxs to /usr/bin (bug #502384). Fix... (diff)
downloadgentoo-2-416caa1f7e52f01ec225ca9d635e0d36cc9c387d.tar.gz
gentoo-2-416caa1f7e52f01ec225ca9d635e0d36cc9c387d.tar.bz2
gentoo-2-416caa1f7e52f01ec225ca9d635e0d36cc9c387d.zip
Restore 1.3-Fix-python-3-compatability.patch which was removed by accident.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xDCB4A7FF)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/esearch/ChangeLog6
-rw-r--r--app-portage/esearch/files/1.3-Fix-python-3-compatability.patch34
2 files changed, 39 insertions, 1 deletions
diff --git a/app-portage/esearch/ChangeLog b/app-portage/esearch/ChangeLog
index 46646d7bb39a..fdfb8444e968 100644
--- a/app-portage/esearch/ChangeLog
+++ b/app-portage/esearch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-portage/esearch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/ChangeLog,v 1.123 2014/05/14 14:42:12 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/ChangeLog,v 1.124 2014/05/22 15:41:38 fuzzyray Exp $
+
+ 22 May 2014; Paul Varner <fuzzyray@gentoo.org>
+ +files/1.3-Fix-python-3-compatability.patch:
+ Restore 1.3-Fix-python-3-compatability.patch which was removed by accident.
14 May 2014; Agostino Sarubbo <ago@gentoo.org> esearch-1.3-r1.ebuild:
Stable for sparc, wrt bug #505118
diff --git a/app-portage/esearch/files/1.3-Fix-python-3-compatability.patch b/app-portage/esearch/files/1.3-Fix-python-3-compatability.patch
new file mode 100644
index 000000000000..36c9d2255b8c
--- /dev/null
+++ b/app-portage/esearch/files/1.3-Fix-python-3-compatability.patch
@@ -0,0 +1,34 @@
+From 3978f923ac814aef014cf412b63d11fd94f60692 Mon Sep 17 00:00:00 2001
+From: Paul Varner <fuzzyray@gentoo.org>
+Date: Wed, 8 May 2013 14:26:48 -0500
+Subject: [PATCH 1/2] Fix python 3 compatability with 'esearch -e' (Bug 469076)
+
+Thanks to zmedico for the patch.
+---
+ esearch/search.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/esearch/search.py b/esearch/search.py
+index f91f5b1..696a0f0 100755
+--- a/esearch/search.py
++++ b/esearch/search.py
+@@ -22,6 +22,7 @@ import re
+ try:
+ from portage.output import bold, red, green, darkgreen, turquoise, blue, nocolor
+ from portage import settings, pkgcmp, pkgsplit, portdb, best
++ from portage.util import cmp_sort_key
+ except ImportError:
+ print("Critical: portage imports failed!")
+ sys.exit(1)
+@@ -107,7 +108,7 @@ def searchEbuilds(path, portdir=True, searchdef="", repo_num="",
+ data['defebuild'] = (searchdef, pkgs[-1][3])
+ if not portdir:
+ config['found_in_overlay'] = True
+- pkgs.sort(mypkgcmp)
++ pkgs.sort(key=cmp_sort_key(mypkgcmp))
+ for pkg in pkgs:
+ rev = ""
+ if pkg[2] != "r0":
+--
+1.8.5.4
+