summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2004-12-31 00:31:04 +0000
committerDaniel Drake <dsd@gentoo.org>2004-12-31 00:31:04 +0000
commit74c3f001e0bf9fe14cbc2aed3e47cb7f599d9efc (patch)
tree3c1448406b3ca2d6e0fbbb3f005f64f453d91342 /app-portage
parentChange encoding to UTF-8 for GLEP 31 compliance (Manifest recommit) (diff)
downloadgentoo-2-74c3f001e0bf9fe14cbc2aed3e47cb7f599d9efc.tar.gz
gentoo-2-74c3f001e0bf9fe14cbc2aed3e47cb7f599d9efc.tar.bz2
gentoo-2-74c3f001e0bf9fe14cbc2aed3e47cb7f599d9efc.zip
New version, which checks for user confirmation (the first time) before sending data. Be sure to run a forced update (basc -u) if upgrading from an earlier version
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/basc/ChangeLog16
-rw-r--r--app-portage/basc/Manifest4
-rw-r--r--app-portage/basc/basc-1.5.1.ebuild74
-rw-r--r--app-portage/basc/files/digest-basc-1.5.11
4 files changed, 93 insertions, 2 deletions
diff --git a/app-portage/basc/ChangeLog b/app-portage/basc/ChangeLog
index f4f6065878ff..d28c0dcff806 100644
--- a/app-portage/basc/ChangeLog
+++ b/app-portage/basc/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for app-portage/basc
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/ChangeLog,v 1.6 2004/12/30 19:59:28 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/ChangeLog,v 1.7 2004/12/31 00:31:04 dsd Exp $
+
+*basc-1.5.1 (31 Dec 2004)
+
+ 31 Dec 2004; Daniel Drake <dsd@gentoo.org> +basc-1.5.1.ebuild:
+ New version, which checks for user confirmation (the first time) before
+ sending data. Be sure to run a forced update (basc -u) if upgrading from an
+ earlier version
+
+*basc-1.5.1 (31 Dec 2004)
+
+ 31 Dec 2004; Daniel Drake <dsd@gentoo.org> +basc-1.5.1.ebuild:
+ New version, which checks for user confirmation (the first time) before
+ sending data. Be sure to run a forced update (basc -u) if upgrading from an
+ earlier version
30 Dec 2004; Daniel Drake <dsd@gentoo.org> metadata.xml:
Add Alexander Mieland as project maintainer
diff --git a/app-portage/basc/Manifest b/app-portage/basc/Manifest
index 20841f8ebae2..ba00382e6f7a 100644
--- a/app-portage/basc/Manifest
+++ b/app-portage/basc/Manifest
@@ -1,4 +1,6 @@
+MD5 d50494eeee2074e4629c0e365cce05b0 basc-1.5.1.ebuild 1959
MD5 692f212cf12e9ddc6372a88ee46867bc basc-1.5.0.ebuild 1871
-MD5 f85e2992eceab386d26af999fbf85279 ChangeLog 1038
+MD5 4b9a724034566fff9e5d120c915fe992 ChangeLog 1564
MD5 36441a3af28aa17a592a5c409239a278 metadata.xml 616
MD5 2c675d7d3e70daedb76091e742fed699 files/digest-basc-1.5.0 61
+MD5 2f9f89ec54c46c4bfed7a3febf59d0b1 files/digest-basc-1.5.1 61
diff --git a/app-portage/basc/basc-1.5.1.ebuild b/app-portage/basc/basc-1.5.1.ebuild
new file mode 100644
index 000000000000..6abf3d143072
--- /dev/null
+++ b/app-portage/basc/basc-1.5.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/basc-1.5.1.ebuild,v 1.1 2004/12/31 00:31:04 dsd Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="client for Buildtime And Statistics Client (Unofficial Gentoo Project)"
+HOMEPAGE="http://www.gentoo-stats.org/"
+SRC_URI="http://www.gentoo-stats.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="app-portage/gentoolkit
+ dev-lang/perl
+ dev-perl/DateManip
+ net-misc/wget
+ sys-devel/gcc
+ sys-apps/sed
+ sys-apps/grep
+ app-arch/gzip
+ >=sys-apps/uhinv-0.4"
+
+pkg_setup() {
+ enewgroup stats
+ enewuser stats -1 /bin/false /tmp stats
+}
+
+src_compile() {
+ sed -i "s:/usr/local:/usr:g" client/basc client/hgenlop
+ $(tc-getCC) ${CFLAGS} -o client/smt-detect client/smt-detect.c || die "build failed"
+}
+
+src_install() {
+ dobin client/basc client/hgenlop client/smt-detect client/urandom.sh || die "dobin"
+ dodoc README ChangeLog TEAM
+ dodir /etc/basc
+ touch "${D}"/etc/basc/basc.conf
+
+ fowners root:stats /etc/basc
+ fperms ug+w /etc/basc
+
+ fowners root:stats /etc/basc/basc.conf
+ fperms ug+w /etc/basc/basc.conf
+}
+
+pkg_postinst() {
+ local GU=`/usr/bin/hgenlop -nt gcc`
+ echo "GU=\"${GU}\"" >> /etc/basc/basc.conf
+
+ ewarn "WARNING: If you upgraded from an earlier version, you must"
+ ewarn "perform a forced upgrade from a console now. Please follow"
+ ewarn "the instructions below to do this."
+ einfo
+ einfo "The Gentoo Buildtime and Statistics client can be started by"
+ einfo "typing:"
+ einfo ""
+ einfo " \"basc -u\"."
+ einfo ""
+ einfo "Note: You have to be in the stats group to use the client!"
+ einfo ""
+ einfo "If you want to automatically launch the client every 24h,"
+ einfo "you must set up a cronjob for the stats user or a user in"
+ einfo "the stats group."
+ einfo ""
+ einfo "For example:"
+ einfo ""
+ einfo " \"0 0 * * * /usr/bin/basc -q >/dev/null 2>&1\""
+ einfo ""
+ einfo "will start the client every day at 00:00am"
+ einfo
+}
diff --git a/app-portage/basc/files/digest-basc-1.5.1 b/app-portage/basc/files/digest-basc-1.5.1
new file mode 100644
index 000000000000..236eb414def8
--- /dev/null
+++ b/app-portage/basc/files/digest-basc-1.5.1
@@ -0,0 +1 @@
+MD5 26f8f2e6b3ffbfcf2f9d9662e377fe14 basc-1.5.1.tar.gz 16640