summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-05-02 00:03:52 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-05-02 00:03:52 +0000
commit01f50a63fe1b31beb40f55a1183c3ad88d97e8a0 (patch)
treec5d111af6f5bfbbfa9ef0925cfa5b6adee16af97 /app-sci/qcad
parentfix bug (diff)
downloadgentoo-2-01f50a63fe1b31beb40f55a1183c3ad88d97e8a0.tar.gz
gentoo-2-01f50a63fe1b31beb40f55a1183c3ad88d97e8a0.tar.bz2
gentoo-2-01f50a63fe1b31beb40f55a1183c3ad88d97e8a0.zip
new package
Diffstat (limited to 'app-sci/qcad')
-rw-r--r--app-sci/qcad/ChangeLog11
-rw-r--r--app-sci/qcad/files/digest-qcad-1.4.71
-rw-r--r--app-sci/qcad/qcad-1.4.7.ebuild36
3 files changed, 48 insertions, 0 deletions
diff --git a/app-sci/qcad/ChangeLog b/app-sci/qcad/ChangeLog
new file mode 100644
index 000000000000..10db8e1ab7cb
--- /dev/null
+++ b/app-sci/qcad/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-sci/qcad
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/qcad/ChangeLog,v 1.1 2002/05/02 00:03:52 seemant Exp $
+
+*qcad-1.4.7 (1 May 2002)
+
+ 1 May 2002; Seemant Kulleen <seemant@gentoo.org> qcad-1.4.7.ebuild ChangeLog
+ files/digest-qcad-1.4.7 :
+
+ New package based on simultaneous ebuild submissions from:
+ scott.claridge@bigfoot.com (Scott Claridge) and erics@cfl.rr.com (Eric Sorton)
diff --git a/app-sci/qcad/files/digest-qcad-1.4.7 b/app-sci/qcad/files/digest-qcad-1.4.7
new file mode 100644
index 000000000000..4f0398719a9d
--- /dev/null
+++ b/app-sci/qcad/files/digest-qcad-1.4.7
@@ -0,0 +1 @@
+MD5 f7b2a645ac1d5788471a221464a4ab69 qcad-1.4.7-src.tar.gz 1511955
diff --git a/app-sci/qcad/qcad-1.4.7.ebuild b/app-sci/qcad/qcad-1.4.7.ebuild
new file mode 100644
index 000000000000..f2992e3ee2dc
--- /dev/null
+++ b/app-sci/qcad/qcad-1.4.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Eric Sorton <erics@cfl.rr.com> and Scott Claridge <scott.claridge@bigfoot.com>
+# $Header: /var/cvsroot/gentoo-x86/app-sci/qcad/qcad-1.4.7.ebuild,v 1.1 2002/05/02 00:03:52 seemant Exp $
+
+MY_P=${P}-src
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A 2D CAD package based upon Qt."
+SRC_URI="http://www.qcad.org/archives/${MY_P}.tar.gz"
+HOMEPAGE="http://www.qcad.org"
+
+DEPEND=">=dev-util/tmake-1.8-r1
+ =x11-libs/qt-2.3*"
+
+src_compile() {
+ export QTDIR=/usr/qt/2
+ cd ${S}
+ tmake qcad.pro -o Makefile
+ emake CXXFLAGS="$CXXFLAGS" || die
+}
+
+src_install () {
+ dobin qcad
+
+ dohtml -r doc
+
+ dodoc AUTHORS COPYING INSTALL MANIFEST README TODO changes-1.4.8 changes-old
+ docinto examples
+ dodoc examples/*
+
+ dodir /usr/share/${PN}
+ cp -a fonts hatches libraries messages templates ${D}/usr/share/${PN}
+
+ insinto /usr/share/${PN}/pixmaps
+ doins xpm/*
+}